aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/src/others/mimesh/libg3d-0.0.8/plugins/import/imp_3dm/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/others/mimesh/libg3d-0.0.8/plugins/import/imp_3dm/Makefile.am')
-rw-r--r--src/others/mimesh/libg3d-0.0.8/plugins/import/imp_3dm/Makefile.am26
1 files changed, 26 insertions, 0 deletions
diff --git a/src/others/mimesh/libg3d-0.0.8/plugins/import/imp_3dm/Makefile.am b/src/others/mimesh/libg3d-0.0.8/plugins/import/imp_3dm/Makefile.am
new file mode 100644
index 0000000..125488f
--- /dev/null
+++ b/src/others/mimesh/libg3d-0.0.8/plugins/import/imp_3dm/Makefile.am
@@ -0,0 +1,26 @@
1pluginimpdir = $(pkglibdir)/plugins/import
2
3if EXPERIMENTAL
4pluginimp_LTLIBRARIES = imp_3dm.la
5endif
6
7AM_CFLAGS = \
8 -Wall -ansi -pedantic \
9 -DG_LOG_DOMAIN=\"LibG3D\" \
10 @DBG_CFLAGS@ -DDEBUG=@DEBUG@ \
11 @GLIB_CFLAGS@
12
13INCLUDES = -I$(top_srcdir)/include -I$(top_builddir)/include
14
15AM_LDFLAGS = \
16 -no-undefined -module \
17 @PLUGINS_LDFLAGS@
18
19LIBTOOL += --quiet
20
21imp_3dm_la_SOURCES = imp_3dm.c imp_3dm.h \
22 imp_3dm_callbacks.h imp_3dm_callbacks.c \
23 imp_3dm_object.c imp_3dm_object.h \
24 imp_3dm_chunks.h imp_3dm_object_types.h imp_3dm_types.h
25imp_3dm_la_LIBADD = $(top_builddir)/src/libg3d.la @GLIB_LIBS@
26