aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/src/others/mimesh/libg3d-0.0.8/plugins/image/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/others/mimesh/libg3d-0.0.8/plugins/image/Makefile.am')
-rw-r--r--src/others/mimesh/libg3d-0.0.8/plugins/image/Makefile.am36
1 files changed, 36 insertions, 0 deletions
diff --git a/src/others/mimesh/libg3d-0.0.8/plugins/image/Makefile.am b/src/others/mimesh/libg3d-0.0.8/plugins/image/Makefile.am
new file mode 100644
index 0000000..1c40c96
--- /dev/null
+++ b/src/others/mimesh/libg3d-0.0.8/plugins/image/Makefile.am
@@ -0,0 +1,36 @@
1pluginimgdir = $(pkglibdir)/plugins/image
2
3pluginimg_LTLIBRARIES = \
4 img_bmp.la \
5 img_sgi.la \
6 img_dds.la
7
8if HAVE_GDKPIXBUF
9pluginimg_LTLIBRARIES += img_gdkpixbuf.la
10endif
11
12AM_CFLAGS = \
13 -Wall -ansi -pedantic \
14 -DG_LOG_DOMAIN=\"LibG3D\" \
15 @DBG_CFLAGS@ -DDEBUG=@DEBUG@ \
16 @GLIB_CFLAGS@
17
18INCLUDES = -I$(top_srcdir)/include
19
20AM_LDFLAGS = \
21 -no-undefined -module \
22 @PLUGINS_LDFLAGS@
23
24LIBTOOL += --quiet
25
26img_bmp_la_SOURCES = img_bmp.c
27img_bmp_la_LIBADD = $(top_builddir)/src/libg3d.la @GLIB_LIBS@
28img_sgi_la_SOURCES = img_sgi.c
29img_sgi_la_LIBADD = $(top_builddir)/src/libg3d.la @GLIB_LIBS@
30img_dds_la_SOURCES = img_dds.c
31img_dds_la_LIBADD = $(top_builddir)/src/libg3d.la @GLIB_LIBS@
32
33img_gdkpixbuf_la_CFLAGS = ${AM_CFLAGS} @GDKPIXBUF_CFLAGS@
34img_gdkpixbuf_la_SOURCES = img_gdkpixbuf.c
35img_gdkpixbuf_la_LIBADD = $(top_builddir)/src/libg3d.la @GLIB_LIBS@ \
36 @GDKPIXBUF_LIBS@