aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/src/others/mimesh/libg3d-0.0.8/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'src/others/mimesh/libg3d-0.0.8/configure.in')
-rw-r--r--src/others/mimesh/libg3d-0.0.8/configure.in221
1 files changed, 221 insertions, 0 deletions
diff --git a/src/others/mimesh/libg3d-0.0.8/configure.in b/src/others/mimesh/libg3d-0.0.8/configure.in
new file mode 100644
index 0000000..4d1f639
--- /dev/null
+++ b/src/others/mimesh/libg3d-0.0.8/configure.in
@@ -0,0 +1,221 @@
1
2AC_INIT(configure.in)
3AC_CONFIG_AUX_DIR(config)
4
5# versioning stuff
6m4_define([g3d_major_version], [0])
7m4_define([g3d_minor_version], [0])
8m4_define([g3d_micro_version], [8])
9m4_define([g3d_interface_age], [8])
10m4_define([g3d_version],
11 [g3d_major_version.g3d_minor_version.g3d_micro_version])
12m4_define([g3d_binary_age],
13 [m4_eval(100 * g3d_minor_version + g3d_micro_version)])
14VERSION=g3d_version
15
16m4_define([lt_current],
17 [m4_eval(100 * g3d_minor_version + g3d_micro_version - g3d_interface_age)])
18m4_define([lt_revision], [g3d_interface_age])
19m4_define([lt_age], [m4_eval(g3d_binary_age - g3d_interface_age)])
20LTVERSION="lt_current:lt_revision:lt_age"
21
22PACKAGE=libg3d
23
24AM_INIT_AUTOMAKE($PACKAGE, $VERSION, no-define)
25AC_SUBST(VERSION)
26AC_SUBST(LTVERSION)
27
28AC_CONFIG_HEADERS(include/g3d/config.h)
29
30AC_PROG_CC
31AM_PROG_LEX
32AC_HEADER_STDC
33
34AC_DISABLE_STATIC
35
36AM_IS_WIN32
37AM_CONDITIONAL(OS_WIN32, test "$os_win32" = yes)
38
39AC_LIBTOOL_WIN32_DLL
40AC_PROG_LIBTOOL
41
42# gtk-doc
43GTK_DOC_CHECK
44
45# glib
46AM_PATH_GLIB_2_0(2.0.0,,AC_MSG_ERROR([glib >= 2.0 is needed]), gmodule gobject)
47
48# gdk-pixbuf
49AM_PATH_GTK_2_0(2.0.0, have_gtk2=true)
50if test "x$have_gtk2" = "xtrue" ; then
51GDKPIXBUF_CFLAGS=$GTK_CFLAGS
52GDKPIXBUF_LIBS=$GTK_LIBS
53AC_SUBST(GDKPIXBUF_CFLAGS)
54AC_SUBST(GDKPIXBUF_LIBS)
55fi
56AM_CONDITIONAL([HAVE_GDKPIXBUF], test "x$have_gtk2" = "xtrue")
57
58# libxml2
59AM_PATH_XML2(2.0.0, have_libxml2=true)
60if test "x$have_libxml2" = "xtrue" ; then
61LIBXML2_CFLAGS=$XML_CPPFLAGS
62LIBXML2_LIBS=$XML_LIBS
63AC_SUBST(LIBXML2_CFLAGS)
64AC_SUBST(LIBXML2_LIBS)
65fi
66AM_CONDITIONAL([HAVE_LIBXML2], test "x$have_libxml2" = "xtrue")
67
68# libgsf
69PKG_CHECK_MODULES(LIBGSF, libgsf-1 >= 1.0.0,
70 [have_libgsf=true], [have_libgsf=false])
71if test "x$have_libgsf" = "xtrue" ; then
72AC_DEFINE([HAVE_LIBGSF], 1, [have GSF library])
73fi
74AM_CONDITIONAL([HAVE_LIBGSF], test "x$have_libgsf" = "xtrue")
75
76# libmagic
77AC_ARG_ENABLE(libmagic,
78 [[ --disable-libmagic disable file type detection using libmagic]],
79 [if test "$enableval" = "no" ; then disable_libmagic=true ; fi])
80if test "x$disable_libmagic" != "xtrue" ; then
81AC_CHECK_HEADER([magic.h], have_magic_h=true)
82AC_CHECK_LIB([magic], [magic_open], have_magic_open=true)
83if test "x$have_magic_h" = "xtrue" && test "x$have_magic_open" = "xtrue"; then
84have_libmagic=true
85AC_DEFINE([USE_LIBMAGIC], 1, [use libmagic for file type detection])
86AC_DEFINE_DIR([MAGIC_FILENAME], libdir/$PACKAGE/libg3d.magic, [magic file])
87MAGIC_LIBS=-lmagic
88fi
89fi
90AC_SUBST(MAGIC_LIBS)
91#AM_CONDITIONAL([USE_LIBMAGIC], test "x$have_libmagic" = "xtrue")
92
93# libm
94AC_CHECK_LIB(m, sqrt,, [AC_MSG_ERROR([requires math library])])
95MATH_LIBS=-lm
96AC_SUBST(MATH_LIBS)
97
98# zlib
99Z_DIR= Z_LIBS= Z_CFLAGS=
100AC_ARG_WITH(zlib,
101 [[ --with-zlib=DIR use libz in DIR]],
102 [case $withval in
103 yes|no) ;;
104 *) Z_DIR=$withval
105 CPPFLAGS="${CPPFLAGS} -I$withval/include"
106 LDFLAGS="${LDFLAGS} -L$withval/lib"
107 ;;
108 esac])
109if test "x$with_zlib" != xno; then
110 with_zlib=no
111 AC_CHECK_HEADER(zlib.h, [AC_CHECK_LIB(z, gzread, [with_zlib=yes])])
112fi
113if test "x$Z_DIR" != "x"; then
114 Z_CFLAGS="-I$Z_DIR/include"
115 Z_LIBS="-L$Z_DIR/lib -lz"
116else
117 Z_LIBS="-lz"
118fi
119AC_SUBST(Z_CFLAGS)
120AC_SUBST(Z_LIBS)
121if test "$with_zlib" = "yes"; then
122 AC_DEFINE([HAVE_ZLIB], 1, [have zlib])
123fi
124AM_CONDITIONAL([HAVE_ZLIB], test "$with_zlib" = "yes")
125
126# Debug level (verbosity & optimization)
127AC_MSG_CHECKING([for debug level])
128AC_ARG_ENABLE(debug,
129 [[ --enable-debug[=LVL] enable debug level LVL or 1 (default is 0)]],
130 [if test "$enableval" = "yes" ; then DEBUG=1; else DEBUG=$enableval; fi],
131 DEBUG=0)
132AC_MSG_RESULT($DEBUG)
133AC_SUBST(DEBUG)
134
135AC_ARG_ENABLE(experimental,
136 [[ --enable-experimental enable experimental and unfinished plugins]],
137 [if test "x$enableval" = "xyes" ; then experimental=1
138 else experimental=0; fi],
139 experimental=0)
140AM_CONDITIONAL([EXPERIMENTAL], test "x$experimental" = "x1")
141
142AC_ARG_ENABLE(cxxtest,
143 [[ --enable-cxxtest enable C++ test]],
144 [if test "x$enableval" = "xyes" ; then cxxtest=1 else cxxtest=0; fi],
145 cxxtest=0)
146AM_CONDITIONAL([HAVE_CXX], test "x$cxxtest" = "x1")
147
148AC_ARG_ENABLE(profile,
149 [[ --enable-profile enable gprof profiling]],
150 [if test "x$enableval" = "xyes" ; then profile="-pg"
151 else profile=""; fi],
152 profile="")
153
154if test "$DEBUG" = "0"; then
155 DBG_CFLAGS="-O2 $profile"
156else
157 DBG_CFLAGS="-g $profile"
158fi
159AC_SUBST(DBG_CFLAGS)
160
161# plugin directories
162AC_DEFINE_DIR(PLUGIN_DIR, libdir/$PACKAGE/plugins, [Plugin directory])
163
164PLUGINS_LDFLAGS="-avoid-version -export-dynamic"
165AC_SUBST(PLUGINS_LDFLAGS)
166
167AC_OUTPUT(
168 Makefile
169 doc/Makefile
170 doc/api/Makefile
171 doc/support_matrix/Makefile
172 include/Makefile
173 include/g3d/Makefile
174 m4/Makefile
175 plugins/Makefile
176 plugins/image/Makefile
177 plugins/import/Makefile
178 plugins/import/imp_3dm/Makefile
179 plugins/import/imp_3dmf/Makefile
180 plugins/import/imp_3ds/Makefile
181 plugins/import/imp_ac3d/Makefile
182 plugins/import/imp_acf/Makefile
183 plugins/import/imp_ar/Makefile
184 plugins/import/imp_ase/Makefile
185 plugins/import/imp_blend/Makefile
186 plugins/import/imp_c4d/Makefile
187 plugins/import/imp_cob/Makefile
188 plugins/import/imp_dae/Makefile
189 plugins/import/imp_dpm/Makefile
190 plugins/import/imp_dxf/Makefile
191 plugins/import/imp_flt/Makefile
192 plugins/import/imp_glb/Makefile
193 plugins/import/imp_heightfield/Makefile
194 plugins/import/imp_iob/Makefile
195 plugins/import/imp_joe/Makefile
196 plugins/import/imp_kmz/Makefile
197 plugins/import/imp_ldraw/Makefile
198 plugins/import/imp_leocad/Makefile
199 plugins/import/imp_lwo/Makefile
200 plugins/import/imp_max/Makefile
201 plugins/import/imp_maya/Makefile
202 plugins/import/imp_md2/Makefile
203 plugins/import/imp_md3/Makefile
204 plugins/import/imp_nff/Makefile
205 plugins/import/imp_obj/Makefile
206 plugins/import/imp_osm/Makefile
207 plugins/import/imp_q3o/Makefile
208 plugins/import/imp_r4/Makefile
209 plugins/import/imp_rbh/Makefile
210 plugins/import/imp_skp/Makefile
211 plugins/import/imp_stl/Makefile
212 plugins/import/imp_ta/Makefile
213 plugins/import/imp_test/Makefile
214 plugins/import/imp_vrml/Makefile
215 plugins/import/imp_vrml2/Makefile
216 src/Makefile
217 programs/Makefile
218 tests/Makefile
219 libg3d.pc
220)
221