diff options
Diffstat (limited to 'libraries/irrlicht-1.8/source/Irrlicht/jpeglib/Makefile.am')
-rw-r--r-- | libraries/irrlicht-1.8/source/Irrlicht/jpeglib/Makefile.am | 134 |
1 files changed, 134 insertions, 0 deletions
diff --git a/libraries/irrlicht-1.8/source/Irrlicht/jpeglib/Makefile.am b/libraries/irrlicht-1.8/source/Irrlicht/jpeglib/Makefile.am new file mode 100644 index 0000000..b4b4600 --- /dev/null +++ b/libraries/irrlicht-1.8/source/Irrlicht/jpeglib/Makefile.am | |||
@@ -0,0 +1,134 @@ | |||
1 | ## Process this file with automake to produce Makefile.in | ||
2 | # | ||
3 | # Automake Makefile for the JPEG library | ||
4 | # | ||
5 | # This file is written by Bob Friesenhahn, Guido Vollbeding | ||
6 | # | ||
7 | |||
8 | # Sources to build library | ||
9 | LIBSOURCES = jaricom.c jcapimin.c jcapistd.c jcarith.c jccoefct.c jccolor.c \ | ||
10 | jcdctmgr.c jchuff.c jcinit.c jcmainct.c jcmarker.c jcmaster.c \ | ||
11 | jcomapi.c jcparam.c jcprepct.c jcsample.c jctrans.c jdapimin.c \ | ||
12 | jdapistd.c jdarith.c jdatadst.c jdatasrc.c jdcoefct.c jdcolor.c \ | ||
13 | jddctmgr.c jdhuff.c jdinput.c jdmainct.c jdmarker.c jdmaster.c \ | ||
14 | jdmerge.c jdpostct.c jdsample.c jdtrans.c jerror.c jfdctflt.c \ | ||
15 | jfdctfst.c jfdctint.c jidctflt.c jidctfst.c jidctint.c jquant1.c \ | ||
16 | jquant2.c jutils.c jmemmgr.c @MEMORYMGR@.c | ||
17 | |||
18 | # System dependent sources | ||
19 | SYSDEPSOURCES = jmemansi.c jmemname.c jmemnobs.c jmemdos.c jmemmac.c | ||
20 | |||
21 | # Headers which are installed to support the library | ||
22 | INSTINCLUDES = jerror.h jmorecfg.h jpeglib.h | ||
23 | |||
24 | # Headers which are not installed | ||
25 | OTHERINCLUDES = cderror.h cdjpeg.h jdct.h jinclude.h jmemsys.h jpegint.h \ | ||
26 | jversion.h transupp.h | ||
27 | |||
28 | # Manual pages (Automake uses 'MANS' for itself) | ||
29 | DISTMANS= cjpeg.1 djpeg.1 jpegtran.1 rdjpgcom.1 wrjpgcom.1 | ||
30 | |||
31 | # Other documentation files | ||
32 | DOCS= README install.txt usage.txt wizard.txt example.c libjpeg.txt \ | ||
33 | structure.txt coderules.txt filelist.txt change.log | ||
34 | |||
35 | # Makefiles for various systems | ||
36 | MKFILES= configure Makefile.in makefile.ansi makefile.unix makefile.bcc \ | ||
37 | makefile.mc6 makefile.dj makefile.wat makefile.vc makejdsw.vc6 \ | ||
38 | makeadsw.vc6 makejdep.vc6 makejdsp.vc6 makejmak.vc6 makecdep.vc6 \ | ||
39 | makecdsp.vc6 makecmak.vc6 makeddep.vc6 makeddsp.vc6 makedmak.vc6 \ | ||
40 | maketdep.vc6 maketdsp.vc6 maketmak.vc6 makerdep.vc6 makerdsp.vc6 \ | ||
41 | makermak.vc6 makewdep.vc6 makewdsp.vc6 makewmak.vc6 makejsln.v10 \ | ||
42 | makeasln.v10 makejvcx.v10 makejfil.v10 makecvcx.v10 makecfil.v10 \ | ||
43 | makedvcx.v10 makedfil.v10 maketvcx.v10 maketfil.v10 makervcx.v10 \ | ||
44 | makerfil.v10 makewvcx.v10 makewfil.v10 makeproj.mac makcjpeg.st \ | ||
45 | makdjpeg.st makljpeg.st maktjpeg.st makefile.manx makefile.sas \ | ||
46 | makefile.mms makefile.vms makvms.opt | ||
47 | |||
48 | # Configuration files | ||
49 | CONFIGFILES= jconfig.cfg jconfig.bcc jconfig.mc6 jconfig.dj jconfig.wat \ | ||
50 | jconfig.vc jconfig.mac jconfig.st jconfig.manx jconfig.sas \ | ||
51 | jconfig.vms | ||
52 | |||
53 | # Support scripts for configure | ||
54 | CONFIGUREFILES= config.guess config.sub install-sh ltmain.sh depcomp missing | ||
55 | |||
56 | # Miscellaneous support files | ||
57 | OTHERFILES= jconfig.txt ckconfig.c ansi2knr.c ansi2knr.1 jmemdosa.asm \ | ||
58 | libjpeg.map | ||
59 | |||
60 | # Test support files | ||
61 | TESTFILES= testorig.jpg testimg.ppm testimg.bmp testimg.jpg testprog.jpg \ | ||
62 | testimgp.jpg | ||
63 | |||
64 | # libtool libraries to build | ||
65 | lib_LTLIBRARIES = libjpeg.la | ||
66 | |||
67 | # Library sources for libjpeg.la | ||
68 | libjpeg_la_SOURCES = $(LIBSOURCES) | ||
69 | |||
70 | # LDFLAGS for libjpeg.la | ||
71 | libjpeg_la_LDFLAGS = -no-undefined \ | ||
72 | -version-info $(JPEG_LIB_VERSION) | ||
73 | |||
74 | if HAVE_LD_VERSION_SCRIPT | ||
75 | libjpeg_la_LDFLAGS += -Wl,--version-script=$(srcdir)/libjpeg.map | ||
76 | endif | ||
77 | |||
78 | # Executables to build | ||
79 | bin_PROGRAMS = cjpeg djpeg jpegtran rdjpgcom wrjpgcom | ||
80 | |||
81 | # Executable sources & libs | ||
82 | cjpeg_SOURCES = cjpeg.c rdppm.c rdgif.c rdtarga.c rdrle.c rdbmp.c \ | ||
83 | rdswitch.c cdjpeg.c | ||
84 | cjpeg_LDADD = libjpeg.la | ||
85 | djpeg_SOURCES = djpeg.c wrppm.c wrgif.c wrtarga.c wrrle.c wrbmp.c \ | ||
86 | rdcolmap.c cdjpeg.c | ||
87 | djpeg_LDADD = libjpeg.la | ||
88 | jpegtran_SOURCES = jpegtran.c rdswitch.c cdjpeg.c transupp.c | ||
89 | jpegtran_LDADD = libjpeg.la | ||
90 | rdjpgcom_SOURCES = rdjpgcom.c | ||
91 | wrjpgcom_SOURCES = wrjpgcom.c | ||
92 | |||
93 | # Manual pages to install | ||
94 | man_MANS = $(DISTMANS) | ||
95 | |||
96 | # Headers to install | ||
97 | include_HEADERS = $(INSTINCLUDES) | ||
98 | |||
99 | # Other distributed headers | ||
100 | noinst_HEADERS = $(OTHERINCLUDES) | ||
101 | |||
102 | # Other distributed files | ||
103 | EXTRA_DIST = $(DOCS) $(DISTMANS) $(MKFILES) $(CONFIGFILES) $(SYSDEPSOURCES) \ | ||
104 | $(OTHERFILES) $(TESTFILES) | ||
105 | |||
106 | # Files to be cleaned | ||
107 | CLEANFILES = testout.ppm testout.bmp testout.jpg testoutp.ppm testoutp.jpg \ | ||
108 | testoutt.jpg | ||
109 | |||
110 | # Install jconfig.h | ||
111 | install-data-local: | ||
112 | $(mkinstalldirs) $(DESTDIR)$(includedir) | ||
113 | $(INSTALL_HEADER) jconfig.h $(DESTDIR)$(includedir)/jconfig.h | ||
114 | |||
115 | # Uninstall jconfig.h | ||
116 | uninstall-local: | ||
117 | rm -f $(DESTDIR)$(includedir)/jconfig.h | ||
118 | |||
119 | # Run tests | ||
120 | test: check-local | ||
121 | check-local: | ||
122 | rm -f testout* | ||
123 | ./djpeg -dct int -ppm -outfile testout.ppm $(srcdir)/testorig.jpg | ||
124 | ./djpeg -dct int -bmp -colors 256 -outfile testout.bmp $(srcdir)/testorig.jpg | ||
125 | ./cjpeg -dct int -outfile testout.jpg $(srcdir)/testimg.ppm | ||
126 | ./djpeg -dct int -ppm -outfile testoutp.ppm $(srcdir)/testprog.jpg | ||
127 | ./cjpeg -dct int -progressive -opt -outfile testoutp.jpg $(srcdir)/testimg.ppm | ||
128 | ./jpegtran -outfile testoutt.jpg $(srcdir)/testprog.jpg | ||
129 | cmp $(srcdir)/testimg.ppm testout.ppm | ||
130 | cmp $(srcdir)/testimg.bmp testout.bmp | ||
131 | cmp $(srcdir)/testimg.jpg testout.jpg | ||
132 | cmp $(srcdir)/testimg.ppm testoutp.ppm | ||
133 | cmp $(srcdir)/testimgp.jpg testoutp.jpg | ||
134 | cmp $(srcdir)/testorig.jpg testoutt.jpg | ||