diff options
Diffstat (limited to '')
-rw-r--r-- | libraries/evas/src/modules/savers/eet/Makefile.am | 35 |
1 files changed, 35 insertions, 0 deletions
diff --git a/libraries/evas/src/modules/savers/eet/Makefile.am b/libraries/evas/src/modules/savers/eet/Makefile.am new file mode 100644 index 0000000..1c7f71c --- /dev/null +++ b/libraries/evas/src/modules/savers/eet/Makefile.am | |||
@@ -0,0 +1,35 @@ | |||
1 | |||
2 | MAINTAINERCLEANFILES = Makefile.in | ||
3 | |||
4 | AM_CPPFLAGS = \ | ||
5 | -I. \ | ||
6 | -I$(top_srcdir)/src/lib \ | ||
7 | -I$(top_srcdir)/src/lib/include \ | ||
8 | @FREETYPE_CFLAGS@ \ | ||
9 | @PIXMAN_CFLAGS@ \ | ||
10 | @EINA_CFLAGS@ \ | ||
11 | @evas_image_loader_eet_cflags@ | ||
12 | |||
13 | AM_CFLAGS = @WIN32_CFLAGS@ | ||
14 | |||
15 | if BUILD_LOADER_EET | ||
16 | if !EVAS_STATIC_BUILD_EET | ||
17 | |||
18 | pkgdir = $(libdir)/evas/modules/savers/eet/$(MODULE_ARCH) | ||
19 | pkg_LTLIBRARIES = module.la | ||
20 | |||
21 | module_la_SOURCES = evas_image_save_eet.c | ||
22 | |||
23 | module_la_LIBADD = @EINA_LIBS@ @evas_image_loader_eet_libs@ $(top_builddir)/src/lib/libevas.la | ||
24 | module_la_LDFLAGS = -no-undefined @lt_enable_auto_import@ -module -avoid-version | ||
25 | module_la_LIBTOOLFLAGS = --tag=disable-static | ||
26 | |||
27 | else | ||
28 | |||
29 | noinst_LTLIBRARIES = libevas_saver_eet.la | ||
30 | |||
31 | libevas_saver_eet_la_SOURCES = evas_image_save_eet.c | ||
32 | libevas_saver_eet_la_LIBADD = @evas_image_loader_eet_libs@ | ||
33 | |||
34 | endif | ||
35 | endif | ||