diff options
Diffstat (limited to 'libraries/evas/evas.spec')
-rw-r--r-- | libraries/evas/evas.spec | 624 |
1 files changed, 624 insertions, 0 deletions
diff --git a/libraries/evas/evas.spec b/libraries/evas/evas.spec new file mode 100644 index 0000000..f3ebad3 --- /dev/null +++ b/libraries/evas/evas.spec | |||
@@ -0,0 +1,624 @@ | |||
1 | # Conditional build stuff; from rpm 4.4 /usr/lib/rpm/macros. | ||
2 | # bcond_without defaults to WITH, and vice versa. Yes, it's | ||
3 | # ass-backward. Blame PLD. | ||
4 | %if %{!?with:1}0 | ||
5 | %define with() %{expand:%%{?with_%{1}:1}%%{!?with_%{1}:0}} | ||
6 | %endif | ||
7 | %if %{!?without:1}0 | ||
8 | %define without() %{expand:%%{?with_%{1}:0}%%{!?with_%{1}:1}} | ||
9 | %endif | ||
10 | %if %{!?bcond_with:1}0 | ||
11 | %define bcond_with() %{expand:%%{?_with_%{1}:%%global with_%{1} 1}} | ||
12 | %endif | ||
13 | %if %{!?bcond_without:1}0 | ||
14 | %define bcond_without() %{expand:%%{!?_without_%{1}:%%global with_%{1} 1}} | ||
15 | %endif | ||
16 | |||
17 | ## disabled features | ||
18 | %bcond_with module_loader_edb | ||
19 | %bcond_with module_saver_edb | ||
20 | %bcond_with module_engine_directfb | ||
21 | %bcond_with module_engine_gl_x11 | ||
22 | %bcond_with module_engine_software_16_x11 | ||
23 | %bcond_with module_engine_software_sdl | ||
24 | %bcond_with module_engine_software_xcb | ||
25 | %bcond_with module_loader_gif | ||
26 | %bcond_with module_loader_svg | ||
27 | |||
28 | ## enabled features | ||
29 | %bcond_without module_engine_software_x11 | ||
30 | %bcond_without module_engine_buffer | ||
31 | %bcond_without module_engine_fb | ||
32 | %bcond_without module_loader_pmaps | ||
33 | %bcond_without module_loader_png | ||
34 | %bcond_without module_saver_png | ||
35 | %bcond_without module_loader_jpeg | ||
36 | %bcond_without module_saver_jpeg | ||
37 | %bcond_without module_loader_tiff | ||
38 | %bcond_without module_saver_tiff | ||
39 | %bcond_without module_loader_eet | ||
40 | %bcond_without module_saver_eet | ||
41 | %bcond_without module_loader_xpm | ||
42 | %bcond_without module_loader_bmp | ||
43 | %bcond_without module_loader_wbmp | ||
44 | %bcond_without module_loader_tga | ||
45 | %bcond_without module_loader_ico | ||
46 | %bcond_without module_loader_psd | ||
47 | %bcond_without module_loader_generic | ||
48 | |||
49 | # This just keeps a missing doxygen from killing the build. | ||
50 | %define _missing_doc_files_terminate_build 0 | ||
51 | |||
52 | # Macros for ./configure use | ||
53 | %define ac_with_module_loader_eet --%{?with_module_loader_eet:en}%{!?with_module_loader_eet:dis}able-image-loader-eet | ||
54 | %define ac_with_module_loader_jpeg --%{?with_module_loader_jpeg:en}%{!?with_module_loader_jpeg:dis}able-image-loader-jpeg | ||
55 | %define ac_with_module_loader_pmaps --%{?with_module_loader_pmaps:en}%{!?with_module_loader_pmaps:dis}able-image-loader-pmaps | ||
56 | %define ac_with_module_loader_png --%{?with_module_loader_png:en}%{!?with_module_loader_png:dis}able-image-loader-png | ||
57 | %define ac_with_module_loader_tiff --%{?with_module_loader_tiff:en}%{!?with_module_loader_tiff:dis}able-image-loader-tiff | ||
58 | %define ac_with_module_loader_gif --%{?with_module_loader_gif:en}%{!?with_module_loader_gif:dis}able-image-loader-gif | ||
59 | %define ac_with_module_loader_edb --%{?with_module_loader_edb:en}%{!?with_module_loader_edb:dis}able-image-loader-edb | ||
60 | %define ac_with_module_loader_xpm --%{?with_module_loader_xpm:en}%{!?with_module_loader_xpm:dis}able-image-loader-xpm | ||
61 | %define ac_with_module_loader_svg --%{?with_module_loader_svg:en}%{!?with_module_loader_svg:dis}able-image-loader-svg | ||
62 | %define ac_with_module_loader_bmp --%{?with_module_loader_bmp:en}%{!?with_module_loader_bmp:dis}able-image-loader-bmp | ||
63 | %define ac_with_module_loader_wbmp --%{?with_module_loader_wbmp:en}%{!?with_module_loader_wbmp:dis}able-image-loader-wbmp | ||
64 | %define ac_with_module_loader_tga --%{?with_module_loader_tga:en}%{!?with_module_loader_tga:dis}able-image-loader-tga | ||
65 | %define ac_with_module_loader_ico --%{?with_module_loader_ico:en}%{!?with_module_loader_ico:dis}able-image-loader-ico | ||
66 | %define ac_with_module_loader_psd --%{?with_module_loader_psd:en}%{!?with_module_loader_psd:dis}able-image-loader-psd | ||
67 | %define ac_with_module_loader_generic --%{?with_module_loader_generic:en}%{!?with_module_loader_generic:dis}able-image-loader-generic | ||
68 | %define ac_with_module_saver_eet --%{?with_module_saver_eet:en}%{!?with_module_saver_eet:dis}able-image-saver-eet | ||
69 | %define ac_with_module_saver_jpeg --%{?with_module_saver_jpeg:en}%{!?with_module_saver_jpeg:dis}able-image-saver-jpeg | ||
70 | %define ac_with_module_saver_png --%{?with_module_saver_png:en}%{!?with_module_saver_png:dis}able-image-saver-png | ||
71 | %define ac_with_module_saver_tiff --%{?with_module_saver_tiff:en}%{!?with_module_saver_tiff:dis}able-image-saver-tiff | ||
72 | %define ac_with_module_saver_gif --%{?with_module_saver_gif:en}%{!?with_module_saver_gif:dis}able-image-saver-gif | ||
73 | %define ac_with_module_saver_edb --%{?with_module_saver_edb:en}%{!?with_module_saver_edb:dis}able-image-saver-edb | ||
74 | %define ac_with_module_saver_xpm --%{?with_module_saver_xpm:en}%{!?with_module_saver_xpm:dis}able-image-saver-xpm | ||
75 | %define ac_with_module_engine_software-x11 --%{?with_module_engine_software_x11:en}%{!?with_module_engine_software_x11:dis}able-software-x11 | ||
76 | %define ac_with_module_engine_buffer --%{?with_module_engine_buffer:en}%{!?with_module_engine_buffer:dis}able-buffer | ||
77 | %define ac_with_module_engine_fb --%{?with_module_engine_fb:en}%{!?with_module_engine_fb:dis}able-fb | ||
78 | %define ac_with_module_engine_gl_x11 --%{?with_module_engine_gl_x11:en}%{!?with_module_engine_gl_x11:dis}able-gl-x11 | ||
79 | %define ac_with_module_engine_directfb --%{?with_module_engine_directfb:en}%{!?with_module_engine_directfb:dis}able-directfb | ||
80 | %define ac_with_module_engine_software_16_x11 --%{?with_module_engine_software_16_x11:en}%{!?with_module_engine_software_16_x11:dis}able-software-16-x11 | ||
81 | %define ac_with_module_engine_software_sdl --%{?with_module_engine_software_sdl:en}%{!?with_module_engine_software_sdl:dis}able-sdl | ||
82 | %define ac_with_module_engine_software_xcb --%{?with_module_engine_software_xcb:en}%{!?with_module_engine_software_xcb:dis}able-software-xcb | ||
83 | |||
84 | %{!?_rel:%{expand:%%global _rel 0.enl%{?dist}}} | ||
85 | |||
86 | Summary: Multi-platform Canvas Library | ||
87 | Name: evas | ||
88 | Version: 1.1.0 | ||
89 | Release: %{_rel} | ||
90 | License: BSD | ||
91 | Group: System Environment/Libraries | ||
92 | URL: http://www.enlightenment.org/ | ||
93 | Source: http://download.enlightenment.org/releases/%{name}-%{version}.tar.gz | ||
94 | Packager: %{?_packager:%{_packager}}%{!?_packager:Michael Jennings <mej@eterm.org>} | ||
95 | Vendor: %{?_vendorinfo:%{_vendorinfo}}%{!?_vendorinfo:The Enlightenment Project (http://www.enlightenment.org/)} | ||
96 | Distribution: %{?_distribution:%{_distribution}}%{!?_distribution:%{_vendor}} | ||
97 | BuildRequires: /usr/bin/freetype-config | ||
98 | Provides: evas | ||
99 | BuildRoot: %{_tmppath}/%{name}-%{version}-root | ||
100 | |||
101 | %description | ||
102 | Evas is a clean display canvas API for several target display systems | ||
103 | that can draw anti-aliased text, smooth super and sub-sampled scaled | ||
104 | images, alpha-blend objects much and more. | ||
105 | |||
106 | %package devel | ||
107 | Summary: Evas headers, static libraries, documentation and test programs | ||
108 | Group: System Environment/Libraries | ||
109 | Requires: %{name} = %{version} | ||
110 | |||
111 | %description devel | ||
112 | Headers, static libraries, test programs and documentation for Evas. | ||
113 | |||
114 | %if %{with module_loader_eet} | ||
115 | %package module_loader_eet | ||
116 | Summary: EET Image loader module for Evas | ||
117 | Group: System Environment/Libraries | ||
118 | BuildRequires: eet-devel | ||
119 | %description module_loader_eet | ||
120 | EET Image loader module for Evas | ||
121 | %endif | ||
122 | |||
123 | %if %{with module_saver_eet} | ||
124 | %package module_saver_eet | ||
125 | Summary: EET Image saver module for Evas | ||
126 | Group: System Environment/Libraries | ||
127 | BuildRequires: eet-devel | ||
128 | %description module_saver_eet | ||
129 | EET Image saver module for Evas | ||
130 | %endif | ||
131 | |||
132 | %if %{with module_loader_jpeg} | ||
133 | %package module_loader_jpeg | ||
134 | Summary: JPEG Image loader module for Evas | ||
135 | Group: System Environment/Libraries | ||
136 | BuildRequires: libjpeg-devel | ||
137 | %description module_loader_jpeg | ||
138 | JPEG Image loader module for Evas | ||
139 | %endif | ||
140 | |||
141 | %if %{with module_saver_jpeg} | ||
142 | %package module_saver_jpeg | ||
143 | Summary: JPEG Image saver module for Evas | ||
144 | Group: System Environment/Libraries | ||
145 | BuildRequires: libjpeg-devel | ||
146 | %description module_saver_jpeg | ||
147 | JPEG Image saver module for Evas | ||
148 | %endif | ||
149 | |||
150 | %if %{with module_loader_pmaps} | ||
151 | %package module_loader_pmaps | ||
152 | Summary: Pixmap Image loader module for Evas | ||
153 | Group: System Environment/Libraries | ||
154 | BuildRequires: libXpm-devel | ||
155 | %description module_loader_pmaps | ||
156 | Pixmap Image loader module for Evas | ||
157 | %endif | ||
158 | |||
159 | %if %{with module_loader_png} | ||
160 | %package module_loader_png | ||
161 | Summary: PNG Image loader module for Evas | ||
162 | Group: System Environment/Libraries | ||
163 | BuildRequires: libpng-devel | ||
164 | %description module_loader_png | ||
165 | PNG Image loader module for Evas | ||
166 | %endif | ||
167 | |||
168 | %if %{with module_saver_png} | ||
169 | %package module_saver_png | ||
170 | Summary: PNG Image saver module for Evas | ||
171 | Group: System Environment/Libraries | ||
172 | BuildRequires: libpng-devel | ||
173 | %description module_saver_png | ||
174 | PNG Image saver module for Evas | ||
175 | %endif | ||
176 | |||
177 | %if %{with module_loader_tiff} | ||
178 | %package module_loader_tiff | ||
179 | Summary: TIFF Image loader module for Evas | ||
180 | Group: System Environment/Libraries | ||
181 | BuildRequires: libtiff-devel | ||
182 | %description module_loader_tiff | ||
183 | TIFF Image loader module for Evas | ||
184 | %endif | ||
185 | |||
186 | %if %{with module_saver_tiff} | ||
187 | %package module_saver_tiff | ||
188 | Summary: TIFF Image saver module for Evas | ||
189 | Group: System Environment/Libraries | ||
190 | BuildRequires: libtiff-devel | ||
191 | %description module_saver_tiff | ||
192 | TIFF Image saver module for Evas | ||
193 | %endif | ||
194 | |||
195 | %if %{with module_loader_gif} | ||
196 | %package module_loader_gif | ||
197 | Summary: GIF Image loader module for Evas | ||
198 | Group: System Environment/Libraries | ||
199 | #BuildSuggests: libungif-devel, giflib-devel | ||
200 | BuildRequires: /usr/include/gif_lib.h | ||
201 | %description module_loader_gif | ||
202 | GIF Image loader module for Evas | ||
203 | %endif | ||
204 | |||
205 | %if %{with module_loader_edb} | ||
206 | %package module_loader_edb | ||
207 | Summary: EDB Image loader module for Evas | ||
208 | Group: System Environment/Libraries | ||
209 | BuildRequires: edb-devel | ||
210 | %description module_loader_edb | ||
211 | EDB Image loader module for Evas | ||
212 | %endif | ||
213 | |||
214 | %if %{with module_saver_edb} | ||
215 | %package module_saver_edb | ||
216 | Summary: EDB Image saver module for Evas | ||
217 | Group: System Environment/Libraries | ||
218 | BuildRequires: edb-devel | ||
219 | %description module_saver_edb | ||
220 | EDB Image saver module for Evas | ||
221 | %endif | ||
222 | |||
223 | %if %{with module_loader_xpm} | ||
224 | %package module_loader_xpm | ||
225 | Summary: XPM Image loader module for Evas | ||
226 | Group: System Environment/Libraries | ||
227 | ##BuildRequires: (none, X?) | ||
228 | %description module_loader_xpm | ||
229 | XPM Image loader module for Evas | ||
230 | %endif | ||
231 | |||
232 | %if %{with module_loader_svg} | ||
233 | %package module_loader_svg | ||
234 | Summary: SVG Image loader module for Evas | ||
235 | Group: System Environment/Libraries | ||
236 | BuildRequires: librsvg-devel >= 2.14 | ||
237 | %description module_loader_svg | ||
238 | svg Image loader module for Evas | ||
239 | %endif | ||
240 | |||
241 | %if %{with module_loader_bmp} | ||
242 | %package module_loader_bmp | ||
243 | Summary: BMP Image loader module for Evas | ||
244 | Group: System Environment/Libraries | ||
245 | BuildRequires: libjpeg-devel | ||
246 | %description module_loader_bmp | ||
247 | BMP Image loader module for Evas | ||
248 | %endif | ||
249 | |||
250 | %if %{with module_loader_wbmp} | ||
251 | %package module_loader_wbmp | ||
252 | Summary: WBMP Image loader module for Evas | ||
253 | Group: System Environment/Libraries | ||
254 | BuildRequires: libjpeg-devel | ||
255 | %description module_loader_wbmp | ||
256 | WBMP Image loader module for Evas | ||
257 | %endif | ||
258 | |||
259 | %if %{with module_loader_tga} | ||
260 | %package module_loader_tga | ||
261 | Summary: TGA Image loader module for Evas | ||
262 | Group: System Environment/Libraries | ||
263 | BuildRequires: libjpeg-devel | ||
264 | %description module_loader_tga | ||
265 | TGA Image loader module for Evas | ||
266 | %endif | ||
267 | |||
268 | %if %{with module_loader_ico} | ||
269 | %package module_loader_ico | ||
270 | Summary: ICO Image loader module for Evas | ||
271 | Group: System Environment/Libraries | ||
272 | BuildRequires: libjpeg-devel | ||
273 | %description module_loader_ico | ||
274 | ICO Image loader module for Evas | ||
275 | %endif | ||
276 | |||
277 | %if %{with module_loader_psd} | ||
278 | %package module_loader_psd | ||
279 | Summary: PSD Image loader module for Evas | ||
280 | Group: System Environment/Libraries | ||
281 | BuildRequires: libjpeg-devel | ||
282 | %description module_loader_psd | ||
283 | PSD Image loader module for Evas | ||
284 | %endif | ||
285 | |||
286 | %if %{with module_loader_generic} | ||
287 | %package module_loader_generic | ||
288 | Summary: Generic Image loader module for Evas | ||
289 | Group: System Environment/Libraries | ||
290 | BuildRequires: libjpeg-devel | ||
291 | %description module_loader_generic | ||
292 | Generic Image loader module for Evas | ||
293 | %endif | ||
294 | |||
295 | %package module_engine_software_generic | ||
296 | Summary: Software X11 rendering engine module for Evas | ||
297 | Group: System Environment/Libraries | ||
298 | Requires: evas | ||
299 | %description module_engine_software_generic | ||
300 | Software X11 rendering engine module for Evas | ||
301 | |||
302 | %if %{with module_engine_software_x11} | ||
303 | %package module_engine_software_x11 | ||
304 | Summary: Software X11 rendering engine module for Evas | ||
305 | Group: System Environment/Libraries | ||
306 | BuildRequires: libX11-devel, libICE-devel, libXext-devel | ||
307 | Requires: evas-module_engine_software_generic | ||
308 | Requires: evas | ||
309 | %description module_engine_software_x11 | ||
310 | Software X11 rendering engine module for Evas | ||
311 | %endif | ||
312 | |||
313 | %if %{with module_engine_buffer} | ||
314 | %package module_engine_buffer | ||
315 | Summary: Buffer rendering engine module for Evas | ||
316 | Group: System Environment/Libraries | ||
317 | Requires: evas-module_engine_software_generic | ||
318 | Requires: evas | ||
319 | %description module_engine_buffer | ||
320 | Memory Buffer rendering engine module for Evas | ||
321 | %endif | ||
322 | |||
323 | %if %{with module_engine_fb} | ||
324 | %package module_engine_fb | ||
325 | Summary: Framebuffer rendering engine module for Evas | ||
326 | Group: System Environment/Libraries | ||
327 | Requires: evas-module_engine_software_generic | ||
328 | Requires: evas | ||
329 | %description module_engine_fb | ||
330 | Framebuffer rendering engine module for Evas | ||
331 | %endif | ||
332 | |||
333 | %if %{with module_engine_gl_x11} | ||
334 | %package module_engine_gl_x11 | ||
335 | Summary: OpenGL under X11 rendering engine module for Evas | ||
336 | Group: System Environment/Libraries | ||
337 | #BuildSuggests: xorg-x11-devel, xorg-x11-Mesa-libGL, XFree86-devel | ||
338 | Requires: evas | ||
339 | %description module_engine_gl_x11 | ||
340 | OpenGL under X11 rendering engine module for Evas | ||
341 | %endif | ||
342 | |||
343 | %if %{with module_engine_directfb} | ||
344 | %package module_engine_directfb | ||
345 | Summary: Directfb rendering engine module for Evas | ||
346 | Group: System Environment/Libraries | ||
347 | #BuildSuggests: DirectFB, libdirectfb-devel, directfb-devel | ||
348 | BuildRequires: /usr/include/directfb/dfb_types.h | ||
349 | Requires: evas | ||
350 | %description module_engine_directfb | ||
351 | Directfb rendering engine module for Evas | ||
352 | %endif | ||
353 | |||
354 | %if %{with module_engine_software_16_x11} | ||
355 | %package module_engine_software_16_x11 | ||
356 | Summary: Software 16-bit X11 rendering engine module for Evas | ||
357 | Group: System Environment/Libraries | ||
358 | Requires: evas-module_engine_software_generic | ||
359 | Requires: evas | ||
360 | %description module_engine_software_16_x11 | ||
361 | Software 16-bit X11 rendering engine module for Evas | ||
362 | %endif | ||
363 | |||
364 | %if %{with module_engine_software_sdl} | ||
365 | %package module_engine_software_sdl | ||
366 | Summary: Software SDL X11 rendering engine module for Evas | ||
367 | Group: System Environment/Libraries | ||
368 | BuildRequires: SDL-devel | ||
369 | Requires: evas-module_engine_software_generic | ||
370 | Requires: evas | ||
371 | %description module_engine_software_sdl | ||
372 | Software SDL X11 rendering engine module for Evas | ||
373 | %endif | ||
374 | |||
375 | %if %{with module_engine_software_xcb} | ||
376 | %package module_engine_software_xcb | ||
377 | Summary: Software XCB X11 rendering engine module for Evas | ||
378 | Group: System Environment/Libraries | ||
379 | BuildRequires: libxcb-devel | ||
380 | Requires: evas-module_engine_software_generic | ||
381 | Requires: evas | ||
382 | %description module_engine_software_xcb | ||
383 | Software XCB X11 rendering engine module for Evas | ||
384 | %endif | ||
385 | |||
386 | %prep | ||
387 | %setup -q | ||
388 | |||
389 | %build | ||
390 | %{configure} --prefix=%{_prefix} --x-libraries=%{_prefix}/X11R6/%{_lib} \ | ||
391 | --disable-install-examples \ | ||
392 | %{?ac_with_module_loader_eet} \ | ||
393 | %{?ac_with_module_saver_eet} \ | ||
394 | %{?ac_with_module_loader_jpeg} \ | ||
395 | %{?ac_with_module_saver_jpeg} \ | ||
396 | %{?ac_with_module_loader_pmaps} \ | ||
397 | %{?ac_with_module_loader_png} \ | ||
398 | %{?ac_with_module_saver_png} \ | ||
399 | %{?ac_with_module_loader_tiff} \ | ||
400 | %{?ac_with_module_saver_tiff} \ | ||
401 | %{?ac_with_module_loader_gif} \ | ||
402 | %{?ac_with_module_loader_edb} \ | ||
403 | %{?ac_with_module_saver_edb} \ | ||
404 | %{?ac_with_module_loader_xpm} \ | ||
405 | %{?ac_with_module_loader_svg} \ | ||
406 | %{?ac_with_module_loader_bmp} \ | ||
407 | %{?ac_with_module_loader_wbmp} \ | ||
408 | %{?ac_with_module_loader_tga} \ | ||
409 | %{?ac_with_module_loader_ico} \ | ||
410 | %{?ac_with_module_loader_psd} \ | ||
411 | %{?ac_with_module_loader_generic} \ | ||
412 | %{?ac_with_module_engine_software_x11} \ | ||
413 | %{?ac_with_module_engine_buffer} \ | ||
414 | %{?ac_with_module_engine_fb} \ | ||
415 | %{?ac_with_module_engine_gl_x11} \ | ||
416 | %{?ac_with_module_engine_directfb} \ | ||
417 | %{?ac_with_module_engine_software_16_x11} \ | ||
418 | %{?ac_with_module_engine_software_sdl} \ | ||
419 | %{?ac_with_module_engine_software_xcb} \ | ||
420 | $RPM_CONFIGURE_OPTS | ||
421 | %{__make} %{?_smp_mflags} %{?mflags} | ||
422 | test -x `which doxygen` && /bin/sh gendoc || : | ||
423 | |||
424 | %install | ||
425 | %{__make} %{?mflags_install} DESTDIR=$RPM_BUILD_ROOT install | ||
426 | %{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/modules/*/*/*/*a | ||
427 | |||
428 | %clean | ||
429 | test "x$RPM_BUILD_ROOT" != "x/" && rm -rf $RPM_BUILD_ROOT | ||
430 | |||
431 | %post | ||
432 | /sbin/ldconfig | ||
433 | |||
434 | %postun | ||
435 | /sbin/ldconfig | ||
436 | |||
437 | %files | ||
438 | %defattr(-, root, root) | ||
439 | %doc AUTHORS COPYING ChangeLog INSTALL README | ||
440 | %{_bindir}/%{name}* | ||
441 | %{_libdir}/*.so.* | ||
442 | |||
443 | %files devel | ||
444 | %defattr(-, root, root) | ||
445 | %doc src/examples/*.edc src/examples/*.png src/examples/*.c | ||
446 | %{_libdir}/*.so | ||
447 | %{_libdir}/*.la | ||
448 | %{_libdir}/*.a | ||
449 | %{_libdir}/pkgconfig/* | ||
450 | %{_includedir}/evas-1/*.h | ||
451 | %files module_engine_software_generic | ||
452 | %defattr(-, root, root) | ||
453 | %{_libdir}/evas/modules/engines/software_generic/*/module.so | ||
454 | |||
455 | %if %{with module_loader_eet} | ||
456 | %files module_loader_eet | ||
457 | %defattr(-, root, root) | ||
458 | %{_libdir}/evas/modules/loaders/eet/*/module.so | ||
459 | %endif | ||
460 | |||
461 | %if %{with module_saver_eet} | ||
462 | %files module_saver_eet | ||
463 | %defattr(-, root, root) | ||
464 | %{_libdir}/evas/modules/savers/eet/*/module.so | ||
465 | %endif | ||
466 | |||
467 | %if %{with module_loader_pmaps} | ||
468 | %files module_loader_pmaps | ||
469 | %defattr(-, root, root) | ||
470 | %{_libdir}/evas/modules/loaders/pmaps/*/module.so | ||
471 | %endif | ||
472 | |||
473 | %if %{with module_loader_png} | ||
474 | %files module_loader_png | ||
475 | %defattr(-, root, root) | ||
476 | %{_libdir}/evas/modules/loaders/png/*/module.so | ||
477 | %endif | ||
478 | |||
479 | %if %{with module_saver_png} | ||
480 | %files module_saver_png | ||
481 | %defattr(-, root, root) | ||
482 | %{_libdir}/evas/modules/savers/png/*/module.so | ||
483 | %endif | ||
484 | |||
485 | %if %{with module_loader_jpeg} | ||
486 | %files module_loader_jpeg | ||
487 | %defattr(-, root, root) | ||
488 | %{_libdir}/evas/modules/loaders/jpeg/*/module.so | ||
489 | %endif | ||
490 | |||
491 | %if %{with module_saver_jpeg} | ||
492 | %files module_saver_jpeg | ||
493 | %defattr(-, root, root) | ||
494 | %{_libdir}/evas/modules/savers/jpeg/*/module.so | ||
495 | %endif | ||
496 | |||
497 | %if %{with module_loader_tiff} | ||
498 | %files module_loader_tiff | ||
499 | %defattr(-, root, root) | ||
500 | %{_libdir}/evas/modules/loaders/tiff/*/module.so | ||
501 | %endif | ||
502 | |||
503 | %if %{with module_saver_tiff} | ||
504 | %files module_saver_tiff | ||
505 | %defattr(-, root, root) | ||
506 | %{_libdir}/evas/modules/savers/tiff/*/module.so | ||
507 | %endif | ||
508 | |||
509 | %if %{with module_loader_gif} | ||
510 | %files module_loader_gif | ||
511 | %defattr(-, root, root) | ||
512 | %{_libdir}/evas/modules/loaders/gif/*/module.so | ||
513 | %endif | ||
514 | |||
515 | %if %{with module_loader_edb} | ||
516 | %files module_loader_edb | ||
517 | %defattr(-, root, root) | ||
518 | %{_libdir}/evas/modules/loaders/edb/*/module.so | ||
519 | %endif | ||
520 | |||
521 | %if %{with module_saver_edb} | ||
522 | %files module_saver_edb | ||
523 | %defattr(-, root, root) | ||
524 | %{_libdir}/evas/modules/savers/edb/*/module.so | ||
525 | %endif | ||
526 | |||
527 | %if %{with module_loader_xpm} | ||
528 | %files module_loader_xpm | ||
529 | %defattr(-, root, root) | ||
530 | %{_libdir}/evas/modules/loaders/xpm/*/module.so | ||
531 | %endif | ||
532 | |||
533 | %if %{with module_loader_svg} | ||
534 | %files module_loader_svg | ||
535 | %defattr(-, root, root) | ||
536 | %{_libdir}/evas/modules/loaders/svg/*/module.so | ||
537 | %endif | ||
538 | |||
539 | %if %{with module_loader_bmp} | ||
540 | %files module_loader_bmp | ||
541 | %defattr(-, root, root) | ||
542 | %{_libdir}/evas/modules/loaders/bmp/*/module.so | ||
543 | %endif | ||
544 | |||
545 | %if %{with module_loader_wbmp} | ||
546 | %files module_loader_wbmp | ||
547 | %defattr(-, root, root) | ||
548 | %{_libdir}/evas/modules/loaders/wbmp/*/module.so | ||
549 | %endif | ||
550 | |||
551 | %if %{with module_loader_tga} | ||
552 | %files module_loader_tga | ||
553 | %defattr(-, root, root) | ||
554 | %{_libdir}/evas/modules/loaders/tga/*/module.so | ||
555 | %endif | ||
556 | |||
557 | %if %{with module_loader_ico} | ||
558 | %files module_loader_ico | ||
559 | %defattr(-, root, root) | ||
560 | %{_libdir}/evas/modules/loaders/ico/*/module.so | ||
561 | %endif | ||
562 | |||
563 | %if %{with module_loader_psd} | ||
564 | %files module_loader_psd | ||
565 | %defattr(-, root, root) | ||
566 | %{_libdir}/evas/modules/loaders/psd/*/module.so | ||
567 | %endif | ||
568 | |||
569 | %if %{with module_loader_generic} | ||
570 | %files module_loader_generic | ||
571 | %defattr(-, root, root) | ||
572 | %{_libdir}/evas/modules/loaders/generic/*/module.so | ||
573 | %endif | ||
574 | |||
575 | %if %{with module_engine_software_x11} | ||
576 | %files module_engine_software_x11 | ||
577 | %defattr(-, root, root) | ||
578 | %{_libdir}/evas/modules/engines/software_x11/*/module.so | ||
579 | %endif | ||
580 | |||
581 | %if %{with module_engine_buffer} | ||
582 | %files module_engine_buffer | ||
583 | %defattr(-, root, root) | ||
584 | %{_libdir}/evas/modules/engines/buffer/*/module.so | ||
585 | %endif | ||
586 | |||
587 | %if %{with module_engine_fb} | ||
588 | %files module_engine_fb | ||
589 | %defattr(-, root, root) | ||
590 | %{_libdir}/evas/modules/engines/fb/*/module.so | ||
591 | %endif | ||
592 | |||
593 | %if %{with module_engine_gl_x11} | ||
594 | %files module_engine_gl_x11 | ||
595 | %defattr(-, root, root) | ||
596 | %{_libdir}/evas/modules/engines/gl_x11/*/module.so | ||
597 | %endif | ||
598 | |||
599 | %if %{with module_engine_directfb} | ||
600 | %files module_engine_directfb | ||
601 | %defattr(-, root, root) | ||
602 | %{_libdir}/evas/modules/engines/directfb/*/module.so | ||
603 | %endif | ||
604 | |||
605 | %if %{with module_engine_software_16_x11} | ||
606 | %files module_engine_software_16_x11 | ||
607 | %defattr(-, root, root) | ||
608 | %{_libdir}/evas/modules/engines/software_16/*/module.so | ||
609 | %{_libdir}/evas/modules/engines/software_16_x11/*/module.so | ||
610 | %endif | ||
611 | |||
612 | %if %{with module_engine_software_sdl} | ||
613 | %files module_engine_software_sdl | ||
614 | %defattr(-, root, root) | ||
615 | %{_libdir}/evas/modules/engines/software_sdl/*/module.so | ||
616 | %endif | ||
617 | |||
618 | %if %{with module_engine_software_xcb} | ||
619 | %files module_engine_software_xcb | ||
620 | %defattr(-, root, root) | ||
621 | %{_libdir}/evas/modules/engines/software_xcb/*/module.so | ||
622 | %endif | ||
623 | |||
624 | %changelog | ||