aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/libraries/evas/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/evas/Makefile.am')
-rw-r--r--libraries/evas/Makefile.am28
1 files changed, 13 insertions, 15 deletions
diff --git a/libraries/evas/Makefile.am b/libraries/evas/Makefile.am
index b42e7f9..ee73e82 100644
--- a/libraries/evas/Makefile.am
+++ b/libraries/evas/Makefile.am
@@ -43,7 +43,6 @@ evas-software-ddraw.pc.in \
43evas-software-16-ddraw.pc.in \ 43evas-software-16-ddraw.pc.in \
44evas-direct3d.pc.in \ 44evas-direct3d.pc.in \
45evas-software-16-wince.pc.in \ 45evas-software-16-wince.pc.in \
46evas-software-sdl.pc.in \
47evas-psl1ght.pc.in \ 46evas-psl1ght.pc.in \
48evas-wayland-shm.pc.in \ 47evas-wayland-shm.pc.in \
49evas-wayland-egl.pc.in \ 48evas-wayland-egl.pc.in \
@@ -121,7 +120,7 @@ if BUILD_ENGINE_SOFTWARE_16_WINCE
121pkgconfig_DATA += evas-software-16-wince.pc 120pkgconfig_DATA += evas-software-16-wince.pc
122endif 121endif
123 122
124if BUILD_ENGINE_SOFTWARE_SDL 123if BUILD_ENGINE_SOFTWARE_16_SDL
125pkgconfig_DATA += evas-software-sdl.pc 124pkgconfig_DATA += evas-software-sdl.pc
126endif 125endif
127 126
@@ -161,23 +160,22 @@ endif
161 160
162if EFL_ENABLE_COVERAGE 161if EFL_ENABLE_COVERAGE
163lcov-reset: 162lcov-reset:
164 @rm -rf coverage 163 @rm -rf $(top_builddir)/coverage
165 @find . -name "*.gcda" -exec rm {} \; 164 @find $(top_builddir) -name "*.gcda" -delete
166 @lcov --directory . --zerocounters 165 @lcov --zerocounters --directory $(top_builddir)
167 166
168lcov-report: 167lcov-report:
169 @mkdir coverage 168 @mkdir $(top_builddir)/coverage
170 @lcov --compat-libtool --directory $(top_srcdir)/src --capture --output-file coverage/coverage.info 169 lcov --capture --compat-libtool --output-file $(top_builddir)/coverage/coverage.info --directory $(top_builddir)
171 @lcov -l coverage/coverage.info |grep "\\.h" |cut -d " " -f 2 > coverage/remove 170 lcov --remove $(top_builddir)/coverage/coverage.info '*.h' --output-file $(top_builddir)/coverage/coverage.cleaned.info
172 @lcov -r coverage/coverage.info `cat coverage/remove` > coverage/coverage.cleaned.info 171 genhtml -t "$(PACKAGE_STRING)" -o $(top_builddir)/coverage/html $(top_builddir)/coverage/coverage.cleaned.info
173 @rm coverage/remove 172 @echo "Coverage Report at $(top_builddir)/coverage/html"
174 @mv coverage/coverage.cleaned.info coverage/coverage.info 173
175 @genhtml -t "$(PACKAGE_STRING)" -o coverage coverage/coverage.info
176 174
177coverage: 175coverage:
178 @make lcov-reset 176 @$(MAKE) lcov-reset
179 @make check 177 @$(MAKE) check
180 @make lcov-report 178 @$(MAKE) lcov-report
181else 179else
182lcov-reset: 180lcov-reset:
183 @echo "reconfigure with --enable-coverage" 181 @echo "reconfigure with --enable-coverage"