diff options
Diffstat (limited to '')
-rw-r--r-- | libraries/embryo/src/lib/Makefile.am | 35 |
1 files changed, 35 insertions, 0 deletions
diff --git a/libraries/embryo/src/lib/Makefile.am b/libraries/embryo/src/lib/Makefile.am new file mode 100644 index 0000000..f5c78aa --- /dev/null +++ b/libraries/embryo/src/lib/Makefile.am | |||
@@ -0,0 +1,35 @@ | |||
1 | |||
2 | MAINTAINERCLEANFILES = Makefile.in | ||
3 | |||
4 | AM_CPPFLAGS = \ | ||
5 | -I. \ | ||
6 | -I$(top_srcdir)/src/lib \ | ||
7 | -I$(top_builddir) \ | ||
8 | -I$(top_srcdir)/src/lib \ | ||
9 | -I$(top_srcdir)/src/lib/include \ | ||
10 | -DPACKAGE_BIN_DIR=\"$(bindir)\" \ | ||
11 | -DPACKAGE_LIB_DIR=\"$(libdir)\" \ | ||
12 | -DPACKAGE_DATA_DIR=\"$(datadir)/$(PACKAGE)\" \ | ||
13 | @EVIL_CFLAGS@ \ | ||
14 | @EMBRYO_CPPFLAGS@ \ | ||
15 | @EFL_EMBRYO_BUILD@ | ||
16 | |||
17 | includes_HEADERS = Embryo.h | ||
18 | includesdir = $(includedir)/embryo-@VMAJ@ | ||
19 | |||
20 | lib_LTLIBRARIES = libembryo.la | ||
21 | |||
22 | libembryo_la_SOURCES = \ | ||
23 | embryo_amx.c \ | ||
24 | embryo_args.c \ | ||
25 | embryo_float.c \ | ||
26 | embryo_main.c \ | ||
27 | embryo_rand.c \ | ||
28 | embryo_str.c \ | ||
29 | embryo_time.c | ||
30 | |||
31 | libembryo_la_CFLAGS = @EMBRYO_CFLAGS@ | ||
32 | libembryo_la_LIBADD = @EVIL_LIBS@ -lm | ||
33 | libembryo_la_LDFLAGS = -no-undefined @lt_enable_auto_import@ -version-info @version_info@ @release_info@ | ||
34 | |||
35 | EXTRA_DIST = embryo_private.h | ||