aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/libraries/elementary/data/objects/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--libraries/elementary/data/objects/Makefile.am62
1 files changed, 62 insertions, 0 deletions
diff --git a/libraries/elementary/data/objects/Makefile.am b/libraries/elementary/data/objects/Makefile.am
new file mode 100644
index 0000000..cbdd478
--- /dev/null
+++ b/libraries/elementary/data/objects/Makefile.am
@@ -0,0 +1,62 @@
1AUTOMAKE_OPTIONS = 1.4 foreign
2MAINTAINERCLEANFILES = Makefile.in
3
4EDJE_CC = @edje_cc@
5EDJE_FLAGS_VERBOSE_ =
6EDJE_FLAGS_VERBOSE_0 =
7EDJE_FLAGS_VERBOSE_1 = -v
8EDJE_FLAGS = $(EDJE_FLAGS_$(V)) -id $(top_srcdir)/data/objects -fd $(top_srcdir)/data/objects
9
10filesdir = $(datadir)/elementary/objects
11
12files_DATA = test.edj multip.edj cursors.edj font_preview.edj postit_ent.edj multibuttonentry.edj
13
14EXTRA_DIST = \
15test.edc \
16multip.edc \
17cursors.edc \
18font_preview.edc \
19postit_ent.edc \
20multibuttonentry.edc \
21over.png \
22under.png \
23sky.jpg \
24clo.png \
25cross.png
26
27test.edj: Makefile $(EXTRA_DIST)
28 $(EDJE_CC) $(EDJE_FLAGS) \
29 $(top_srcdir)/data/objects/test.edc \
30 $(top_builddir)/data/objects/test.edj
31
32multip.edj: Makefile $(EXTRA_DIST)
33 $(EDJE_CC) $(EDJE_FLAGS) \
34 $(top_srcdir)/data/objects/multip.edc \
35 $(top_builddir)/data/objects/multip.edj
36
37colorpreview.edj: Makefile $(EXTRA_DIST)
38 $(EDJE_CC) $(EDJE_FLAGS) \
39 $(top_srcdir)/data/objects/colorpreview.edc \
40 $(top_builddir)/data/objects/colorpreview.edj
41
42cursors.edj: Makefile $(EXTRA_DIST)
43 $(EDJE_CC) $(EDJE_FLAGS) \
44 $(top_srcdir)/data/objects/cursors.edc \
45 $(top_builddir)/data/objects/cursors.edj
46
47font_preview.edj: Makefile $(EXTRA_DIST)
48 $(EDJE_CC) $(EDJE_FLAGS) \
49 $(top_srcdir)/data/objects/font_preview.edc \
50 $(top_builddir)/data/objects/font_preview.edj
51
52postit_ent.edj: Makefile $(EXTRA_DIST)
53 $(EDJE_CC) $(EDJE_FLAGS) \
54 $(top_srcdir)/data/objects/postit_ent.edc \
55 $(top_builddir)/data/objects/postit_ent.edj
56multibuttonentry.edj: Makefile $(EXTRA_DIST)
57 $(EDJE_CC) $(EDJE_FLAGS) \
58 $(top_srcdir)/data/objects/multibuttonentry.edc \
59 $(top_builddir)/data/objects/multibuttonentry.edj
60
61clean-local:
62 rm -f *.edj