diff options
Diffstat (limited to 'libraries/eina/Makefile.am')
-rw-r--r-- | libraries/eina/Makefile.am | 44 |
1 files changed, 21 insertions, 23 deletions
diff --git a/libraries/eina/Makefile.am b/libraries/eina/Makefile.am index 7778fd8..501653c 100644 --- a/libraries/eina/Makefile.am +++ b/libraries/eina/Makefile.am | |||
@@ -1,6 +1,6 @@ | |||
1 | ## Process this file with automake to produce Makefile.in | 1 | ## Process this file with automake to produce Makefile.in |
2 | 2 | ||
3 | ACLOCAL_AMFLAGS = -I m4 | 3 | ACLOCAL_AMFLAGS = -I m4 -I m4/common -I m4/eina |
4 | 4 | ||
5 | SUBDIRS = src doc | 5 | SUBDIRS = src doc |
6 | 6 | ||
@@ -38,18 +38,18 @@ autogen.sh \ | |||
38 | eina.pc.in \ | 38 | eina.pc.in \ |
39 | eina.spec \ | 39 | eina.spec \ |
40 | eina.spec.in \ | 40 | eina.spec.in \ |
41 | m4/efl_attribute.m4 \ | 41 | m4/common/efl_attribute.m4 \ |
42 | m4/efl_benchmark.m4 \ | 42 | m4/common/efl_benchmark.m4 \ |
43 | m4/efl_compiler_flag.m4 \ | 43 | m4/common/efl_compiler_flag.m4 \ |
44 | m4/efl_coverage.m4 \ | 44 | m4/common/efl_coverage.m4 \ |
45 | m4/efl_cpu.m4 \ | 45 | m4/common/efl_cpu.m4 \ |
46 | m4/efl_doxygen.m4 \ | 46 | m4/common/efl_doxygen.m4 \ |
47 | m4/efl_fnmatch.m4 \ | 47 | m4/common/efl_fnmatch.m4 \ |
48 | m4/efl_tests.m4 \ | 48 | m4/common/efl_tests.m4 \ |
49 | m4/efl_threads.m4 \ | 49 | m4/common/efl_threads.m4 \ |
50 | m4/eina_bench.m4 \ | 50 | m4/common/efl_path_max.m4 \ |
51 | m4/eina_check.m4 \ | 51 | m4/eina/eina_bench.m4 \ |
52 | m4/efl_path_max.m4 | 52 | m4/eina/eina_check.m4 |
53 | 53 | ||
54 | .PHONY: doc coverage benchmark | 54 | .PHONY: doc coverage benchmark |
55 | 55 | ||
@@ -77,18 +77,16 @@ endif | |||
77 | 77 | ||
78 | if EFL_ENABLE_COVERAGE | 78 | if EFL_ENABLE_COVERAGE |
79 | lcov-reset: | 79 | lcov-reset: |
80 | @rm -rf coverage | 80 | @rm -rf $(top_builddir)/coverage |
81 | @find . -name "*.gcda" -exec rm {} \; | 81 | @find $(top_builddir) -name "*.gcda" -delete |
82 | @lcov --directory . --zerocounters | 82 | @lcov --zerocounters --directory $(top_builddir) |
83 | 83 | ||
84 | lcov-report: | 84 | lcov-report: |
85 | @mkdir coverage | 85 | @mkdir $(top_builddir)/coverage |
86 | @lcov --compat-libtool --directory $(top_srcdir)/src --capture --output-file coverage/coverage.info | 86 | lcov --capture --compat-libtool --output-file $(top_builddir)/coverage/coverage.info --directory $(top_builddir) |
87 | @lcov -l coverage/coverage.info |grep "\\.h" |cut -d " " -f 2 > coverage/remove | 87 | lcov --remove $(top_builddir)/coverage/coverage.info '*.h' --output-file $(top_builddir)/coverage/coverage.cleaned.info |
88 | @lcov -r coverage/coverage.info `cat coverage/remove` > coverage/coverage.cleaned.info | 88 | genhtml -t "$(PACKAGE_STRING)" -o $(top_builddir)/coverage/html $(top_builddir)/coverage/coverage.cleaned.info |
89 | @rm coverage/remove | 89 | @echo "Coverage Report at $(top_builddir)/coverage/html" |
90 | @mv coverage/coverage.cleaned.info coverage/coverage.info | ||
91 | @genhtml -t "$(PACKAGE_STRING)" -o coverage coverage/coverage.info | ||
92 | 90 | ||
93 | coverage: | 91 | coverage: |
94 | @$(MAKE) lcov-reset | 92 | @$(MAKE) lcov-reset |