aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/libraries/eet/src/lib/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/eet/src/lib/Makefile.am')
-rw-r--r--libraries/eet/src/lib/Makefile.am162
1 files changed, 162 insertions, 0 deletions
diff --git a/libraries/eet/src/lib/Makefile.am b/libraries/eet/src/lib/Makefile.am
new file mode 100644
index 0000000..4633749
--- /dev/null
+++ b/libraries/eet/src/lib/Makefile.am
@@ -0,0 +1,162 @@
1
2MAINTAINERCLEANFILES = Makefile.in
3
4AM_CPPFLAGS = \
5-I. \
6-I$(top_srcdir)/src/lib \
7-I$(top_builddir)/src/lib \
8-DPACKAGE_BIN_DIR=\"$(bindir)\" \
9-DPACKAGE_LIB_DIR=\"$(libdir)\" \
10-DPACKAGE_DATA_DIR=\"$(datadir)/$(PACKAGE)\" \
11@EVIL_CFLAGS@ \
12@EINA_CFLAGS@ \
13@EET_CPPFLAGS@ \
14@EFL_EET_BUILD@ \
15@EFL_COVERAGE_CFLAGS@ \
16@OPENSSL_CFLAGS@ \
17@GNUTLS_CFLAGS@
18
19includes_HEADERS = Eet.h
20includesdir = $(includedir)/eet-@VMAJ@
21
22lib_LTLIBRARIES = libeet.la
23
24base_sources = \
25eet_lib.c \
26eet_data.c \
27eet_image.c \
28eet_cipher.c \
29eet_dictionary.c \
30eet_node.c \
31eet_utils.c \
32eet_connection.c
33
34if EET_AMALGAMATION
35nodist_libeet_la_SOURCES = eet_amalgamation.c
36
37eet_amalgamation.c: $(base_sources) Makefile
38 -rm -f eet_amalgamation.c
39
40 @echo "#ifdef HAVE_CONFIG_H" >> eet_amalgamation.c
41 @echo "# include \"config.h\"" >> eet_amalgamation.c
42 @echo "#endif" >> eet_amalgamation.c
43
44 @echo "#ifdef HAVE_ALLOCA_H" >> eet_amalgamation.c
45 @echo "# include <alloca.h>" >> eet_amalgamation.c
46 @echo "#elif defined __GNUC__" >> eet_amalgamation.c
47 @echo "# define alloca __builtin_alloca" >> eet_amalgamation.c
48 @echo "#elif defined _AIX" >> eet_amalgamation.c
49 @echo "# define alloca __alloca" >> eet_amalgamation.c
50 @echo "#elif defined _MSC_VER" >> eet_amalgamation.c
51 @echo "# include <malloc.h>" >> eet_amalgamation.c
52 @echo "# define alloca _alloca" >> eet_amalgamation.c
53 @echo "#else" >> eet_amalgamation.c
54 @echo "# include <stddef.h>" >> eet_amalgamation.c
55 @echo "# ifdef __cplusplus" >> eet_amalgamation.c
56 @echo "#extern \"C\"" >> eet_amalgamation.c
57 @echo "# endif" >> eet_amalgamation.c
58 @echo "#void *alloca (size_t);" >> eet_amalgamation.c
59 @echo "#endif" >> eet_amalgamation.c
60
61 @echo "#include <stdio.h>" >> eet_amalgamation.c
62 @echo "#include <string.h>" >> eet_amalgamation.c
63 @echo "#include <math.h>" >> eet_amalgamation.c
64 @echo "#include <ctype.h>" >> eet_amalgamation.c
65 @echo "#include <limits.h>" >> eet_amalgamation.c
66 @echo "#include <sys/types.h>" >> eet_amalgamation.c
67 @echo "#include <sys/stat.h>" >> eet_amalgamation.c
68 @echo "#ifdef HAVE_SIGNATURE" >> eet_amalgamation.c
69 @echo "# include <sys/mman.h>" >> eet_amalgamation.c
70 @echo "#endif" >> eet_amalgamation.c
71 @echo "#include <setjmp.h>" >> eet_amalgamation.c
72 @echo "#include <errno.h>" >> eet_amalgamation.c
73 @echo "#include <time.h>" >> eet_amalgamation.c
74 @echo "#include <fnmatch.h>" >> eet_amalgamation.c
75 @echo "#include <fcntl.h>" >> eet_amalgamation.c
76
77 @echo "#ifdef _WIN32" >> eet_amalgamation.c
78 @echo "# include <winsock2.h>" >> eet_amalgamation.c
79 @echo "#endif" >> eet_amalgamation.c
80
81 @echo "#ifndef _MSC_VER" >> eet_amalgamation.c
82 @echo "# include <unistd.h>" >> eet_amalgamation.c
83 @echo "#endif" >> eet_amalgamation.c
84
85 @echo "#ifdef HAVE_NETINET_IN_H" >> eet_amalgamation.c
86 @echo "# include <netinet/in.h>" >> eet_amalgamation.c
87 @echo "#endif" >> eet_amalgamation.c
88
89 @echo "#ifdef HAVE_GNUTLS" >> eet_amalgamation.c
90 @echo "# include <gnutls/gnutls.h>" >> eet_amalgamation.c
91 @echo "# include <gcrypt.h>" >> eet_amalgamation.c
92 @echo "#endif" >> eet_amalgamation.c
93
94 @echo "#ifdef HAVE_OPENSSL" >> eet_amalgamation.c
95 @echo "# include <openssl/err.h>" >> eet_amalgamation.c
96 @echo "# include <openssl/evp.h>" >> eet_amalgamation.c
97 @echo "# include <openssl/sha.h>" >> eet_amalgamation.c
98 @echo "#endif" >> eet_amalgamation.c
99
100 @echo "#ifdef HAVE_SIGNATURE" >> eet_amalgamation.c
101 @echo "# ifdef HAVE_GNUTLS" >> eet_amalgamation.c
102 @echo "# include <gnutls/gnutls.h>" >> eet_amalgamation.c
103 @echo "# include <gnutls/x509.h>" >> eet_amalgamation.c
104 @echo "# else" >> eet_amalgamation.c
105 @echo "# include <openssl/rsa.h>" >> eet_amalgamation.c
106 @echo "# include <openssl/objects.h>" >> eet_amalgamation.c
107 @echo "# include <openssl/err.h>" >> eet_amalgamation.c
108 @echo "# include <openssl/ssl.h>" >> eet_amalgamation.c
109 @echo "# include <openssl/dh.h>" >> eet_amalgamation.c
110 @echo "# include <openssl/dsa.h>" >> eet_amalgamation.c
111 @echo "# include <openssl/evp.h>" >> eet_amalgamation.c
112 @echo "# include <openssl/x509.h>" >> eet_amalgamation.c
113 @echo "# include <openssl/pem.h>" >> eet_amalgamation.c
114 @echo "# endif" >> eet_amalgamation.c
115 @echo "#endif" >> eet_amalgamation.c
116
117 @echo "#ifdef HAVE_CIPHER" >> eet_amalgamation.c
118 @echo "# ifdef HAVE_GNUTLS" >> eet_amalgamation.c
119 @echo "# include <gnutls/x509.h>" >> eet_amalgamation.c
120 @echo "# include <gcrypt.h>" >> eet_amalgamation.c
121 @echo "# else" >> eet_amalgamation.c
122 @echo "# include <openssl/evp.h>" >> eet_amalgamation.c
123 @echo "# include <openssl/hmac.h>" >> eet_amalgamation.c
124 @echo "# include <openssl/rand.h>" >> eet_amalgamation.c
125 @echo "# endif" >> eet_amalgamation.c
126 @echo "#endif" >> eet_amalgamation.c
127
128 @echo "#include <zlib.h>" >> eet_amalgamation.c
129 @echo "#include <jpeglib.h>" >> eet_amalgamation.c
130
131 @echo "#ifdef HAVE_EVIL" >> eet_amalgamation.c
132 @echo "# include <Evil.h>" >> eet_amalgamation.c
133 @echo "#endif" >> eet_amalgamation.c
134
135 @echo "#include <Eet.h>" >> eet_amalgamation.c
136
137 @echo "#include \"Eet_private.h\"" >> eet_amalgamation.c
138 @echo "#include \"Eet.h\"" >> eet_amalgamation.c
139
140 @for f in $(base_sources); do \
141 if [ `echo $$f | sed -e 's/^...\(.\).*/\1/'` != '/' ]; then \
142 file="$(srcdir)/$$f" ; \
143 else \
144 file="$$f" ; \
145 fi ; \
146 echo "/* file: $$file */" >> eet_amalgamation.c; \
147 grep -v -e '^# *include \+.\(config\|\|Evil\|Eina\|stdio\|string\|math\|ctype\|limits\|sys/types\|sys/stat\|sys/mman\|setjmp\|errno\|time\|fnmatch\|fcntl\|winsock2\|unistd\|netinet/in\|gnutls/gnutls\|gcrypt\|gnutls/x509\|openssl/rsa\|openssl/objects\|openssl/err\|openssl/ssl\|openssl/dh\|openssl/dsa\|openssl/evp\|openssl/pem\|openssl/sha\|openssl/hmac\|openssl/x509\|openssl/rand\|zlib\|jpeglib\|Eet_private\|Eet\)[.]h.*' $$file >> eet_amalgamation.c; \
148 done
149 @echo "eet_amalgamation.c generated"
150
151else
152libeet_la_SOURCES = $(base_sources)
153endif
154
155libeet_la_CFLAGS = @EET_CFLAGS@ @DEBUG_CFLAGS@
156libeet_la_LIBADD = @GNUTLS_LIBS@ @OPENSSL_LIBS@ @EFL_COVERAGE_LIBS@ @EET_LIBS@ @EINA_LIBS@ @EVIL_LIBS@ -lz -ljpeg -lm
157libeet_la_LDFLAGS = -no-undefined @lt_enable_auto_import@ -version-info @version_info@ @release_info@
158
159EXTRA_DIST = Eet_private.h
160
161clean-local:
162 @rm -rf *.gcno eet_amalgamation.c