aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/libraries/eet/eet.spec
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/eet/eet.spec')
-rw-r--r--libraries/eet/eet.spec75
1 files changed, 75 insertions, 0 deletions
diff --git a/libraries/eet/eet.spec b/libraries/eet/eet.spec
new file mode 100644
index 0000000..07cabba
--- /dev/null
+++ b/libraries/eet/eet.spec
@@ -0,0 +1,75 @@
1%{!?_rel:%{expand:%%global _rel 0.enl%{?dist}}}
2%define _missing_doc_files_terminate_build 0
3
4Summary: Library for speedy data storage, retrieval, and compression.
5Name: eet
6Version: 1.5.0
7Release: %{_rel}
8License: BSD
9Group: System Environment/Libraries
10Source: http://download.enlightenment.org/releases/%{name}-%{version}.tar.gz
11Packager: %{?_packager:%{_packager}}%{!?_packager:Michael Jennings <mej@eterm.org>}
12Vendor: %{?_vendorinfo:%{_vendorinfo}}%{!?_vendorinfo:The Enlightenment Project (http://www.enlightenment.org/)}
13Distribution: %{?_distribution:%{_distribution}}%{!?_distribution:%{_vendor}}
14URL: http://www.enlightenment.org/
15BuildRequires: libjpeg-devel zlib-devel
16BuildRoot: %{_tmppath}/%{name}-%{version}-root
17
18%description
19Eet is a tiny library designed to write an arbitrary set of chunks of
20data to a file and optionally compress each chunk (very much like a
21zip file) and allow fast random-access reading of the file later
22on. It does not do zip as a zip itself has more complexity than is
23needed, and it was much simpler to implement this once here.
24
25It also can encode and decode data structures in memory, as well as
26image data for saving to eet files or sending across the network to
27other machines, or just writing to arbitrary files on the system. All
28data is encoded in a platform independent way and can be written and
29read by any architecture.
30
31%package devel
32Summary: Eet headers, static libraries, documentation and test programs
33Group: System Environment/Libraries
34Requires: %{name} = %{version}
35Requires: libjpeg-devel, zlib-devel
36
37%description devel
38Headers, static libraries, test programs and documentation for Eet
39
40%prep
41%setup -q
42
43%build
44%{configure} --prefix=%{_prefix}
45### use this if you have build problems
46#./configure --prefix=%{_prefix}
47%{__make} %{?_smp_mflags} %{?mflags}
48
49%install
50%{__make} %{?mflags_install} DESTDIR=$RPM_BUILD_ROOT install
51
52%clean
53test "x$RPM_BUILD_ROOT" != "x/" && rm -rf $RPM_BUILD_ROOT
54
55%post
56/sbin/ldconfig
57
58%postun
59/sbin/ldconfig
60
61%files
62%defattr(-, root, root)
63%doc AUTHORS COPYING COPYING-PLAIN README
64%{_libdir}/*.so.*
65
66%files devel
67%defattr(-, root, root)
68%{_bindir}/eet*
69%{_libdir}/pkgconfig/*
70%{_includedir}/*
71%{_libdir}/*.a
72%{_libdir}/*.so
73%{_libdir}/*.la
74
75%changelog