aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/libraries/eet/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/eet/Makefile.am')
-rw-r--r--libraries/eet/Makefile.am99
1 files changed, 0 insertions, 99 deletions
diff --git a/libraries/eet/Makefile.am b/libraries/eet/Makefile.am
deleted file mode 100644
index d3622dc..0000000
--- a/libraries/eet/Makefile.am
+++ /dev/null
@@ -1,99 +0,0 @@
1ACLOCAL_AMFLAGS = -I m4
2
3SUBDIRS = src doc
4
5MAINTAINERCLEANFILES = \
6Makefile.in \
7aclocal.m4 \
8compile \
9config.guess \
10config.h.in \
11config.h.in~ \
12config.sub \
13configure \
14depcomp \
15install-sh \
16ltmain.sh \
17missing \
18$(PACKAGE_TARNAME)-$(PACKAGE_VERSION).tar.gz \
19$(PACKAGE_TARNAME)-$(PACKAGE_VERSION).tar.bz2 \
20$(PACKAGE_TARNAME)-$(PACKAGE_VERSION)-doc.tar.bz2 \
21m4/libtool.m4 \
22m4/lt~obsolete.m4 \
23m4/ltoptions.m4 \
24m4/ltsugar.m4 \
25m4/ltversion.m4
26
27EXTRA_DIST = \
28AUTHORS \
29COPYING \
30autogen.sh \
31eet.pc.in \
32eet.spec.in \
33eet.spec \
34m4/ac_attribute.m4 \
35m4/ac_path_generic.m4 \
36m4/efl_binary.m4 \
37m4/efl_coverage.m4 \
38m4/efl_doxygen.m4 \
39m4/efl_fnmatch.m4 \
40m4/efl_tests.m4 \
41m4/efl_path_max.m4
42
43pkgconfigdir = $(libdir)/pkgconfig
44pkgconfig_DATA = eet.pc
45
46.PHONY: doc coverage
47
48# Documentation
49
50doc:
51 @echo "entering doc/"
52 $(MAKE) -C doc doc
53
54# Unit tests
55
56if EFL_ENABLE_TESTS
57
58check-local:
59 @./src/tests/eet_suite
60
61else
62
63check-local:
64 @echo "reconfigure with --enable-tests"
65
66endif
67
68# Coverage report
69
70if EFL_ENABLE_COVERAGE
71lcov-reset:
72 @rm -rf $(top_builddir)/coverage
73 @find $(top_builddir) -name "*.gcda" -delete
74 @lcov --zerocounters --directory $(top_builddir)
75
76lcov-report:
77 @mkdir $(top_builddir)/coverage
78 lcov --capture --compat-libtool --output-file $(top_builddir)/coverage/coverage.info --directory $(top_builddir)
79 lcov --remove $(top_builddir)/coverage/coverage.info '*.h' --output-file $(top_builddir)/coverage/coverage.cleaned.info
80 genhtml -t "$(PACKAGE_STRING)" -o $(top_builddir)/coverage/html $(top_builddir)/coverage/coverage.cleaned.info
81 @echo "Coverage Report at $(top_builddir)/coverage/html"
82
83coverage:
84 @$(MAKE) lcov-reset
85 @$(MAKE) check
86 @$(MAKE) lcov-report
87
88clean-local:
89 @rm -rf coverage
90else
91lcov-reset:
92 @echo "reconfigure with --enable-coverage"
93
94lcov-report:
95 @echo "reconfigure with --enable-coverage"
96
97coverage:
98 @echo "reconfigure with --enable-tests --enable-coverage"
99endif