diff options
Diffstat (limited to '')
-rw-r--r-- | libraries/edje/src/lib/Makefile.am | 140 |
1 files changed, 0 insertions, 140 deletions
diff --git a/libraries/edje/src/lib/Makefile.am b/libraries/edje/src/lib/Makefile.am deleted file mode 100644 index 5a76ef3..0000000 --- a/libraries/edje/src/lib/Makefile.am +++ /dev/null | |||
@@ -1,140 +0,0 @@ | |||
1 | |||
2 | MAINTAINERCLEANFILES = Makefile.in | ||
3 | |||
4 | AM_CPPFLAGS = \ | ||
5 | -I. \ | ||
6 | -I$(top_srcdir) \ | ||
7 | -I$(top_srcdir)/src/bin \ | ||
8 | -I$(top_srcdir)/src/lib \ | ||
9 | -DPACKAGE_BIN_DIR=\"$(bindir)\" \ | ||
10 | -DPACKAGE_LIB_DIR=\"$(libdir)\" \ | ||
11 | -DPACKAGE_DATA_DIR=\"$(datadir)/$(PACKAGE)\" \ | ||
12 | @EVIL_CFLAGS@ \ | ||
13 | @EDJE_CFLAGS@ \ | ||
14 | @ECORE_IMF_CFLAGS@ \ | ||
15 | @EFL_EDJE_BUILD@ \ | ||
16 | @REMIX_CFLAGS@ \ | ||
17 | @SNDFILE_CFLAGS@ | ||
18 | |||
19 | lib_LTLIBRARIES = libedje.la | ||
20 | |||
21 | includes_HEADERS = Edje.h Edje_Edit.h | ||
22 | includesdir = $(includedir)/edje-@VMAJ@ | ||
23 | |||
24 | base_sources = \ | ||
25 | edje_box_layout.c \ | ||
26 | edje_cache.c \ | ||
27 | edje_calc.c \ | ||
28 | edje_callbacks.c \ | ||
29 | edje_container.c \ | ||
30 | edje_data.c \ | ||
31 | edje_edit.c \ | ||
32 | edje_embryo.c \ | ||
33 | edje_entry.c \ | ||
34 | edje_external.c \ | ||
35 | edje_load.c \ | ||
36 | edje_lua.c \ | ||
37 | edje_lua2.c \ | ||
38 | edje_lua_script_only.c \ | ||
39 | edje_main.c \ | ||
40 | edje_match.c \ | ||
41 | edje_message_queue.c \ | ||
42 | edje_misc.c \ | ||
43 | edje_module.c \ | ||
44 | edje_multisense.c \ | ||
45 | edje_program.c \ | ||
46 | edje_script_only.c \ | ||
47 | edje_smart.c \ | ||
48 | edje_text.c \ | ||
49 | edje_textblock_styles.c \ | ||
50 | edje_util.c \ | ||
51 | edje_var.c | ||
52 | |||
53 | if EDJE_AMALGAMATION | ||
54 | nodist_libedje_la_SOURCES = edje_amalgamation.c | ||
55 | |||
56 | edje_amalgamation.c: $(base_sources) Makefile | ||
57 | -rm -f edje_amalgamation.c | ||
58 | |||
59 | @echo "#ifdef HAVE_CONFIG_H" >> edje_amalgamation.c | ||
60 | @echo "# include \"config.h\"" >> edje_amalgamation.c | ||
61 | @echo "#endif" >> edje_amalgamation.c | ||
62 | |||
63 | @echo "#ifndef _WIN32" >> edje_amalgamation.c | ||
64 | @echo "#define _GNU_SOURCE" >> edje_amalgamation.c | ||
65 | @echo "#endif" >> edje_amalgamation.c | ||
66 | |||
67 | @echo "#ifdef HAVE_ALLOCA_H" >> edje_amalgamation.c | ||
68 | @echo "# include <alloca.h>" >> edje_amalgamation.c | ||
69 | @echo "#elif defined __GNUC__" >> edje_amalgamation.c | ||
70 | @echo "# define alloca __builtin_alloca" >> edje_amalgamation.c | ||
71 | @echo "#elif defined _AIX" >> edje_amalgamation.c | ||
72 | @echo "# define alloca __alloca" >> edje_amalgamation.c | ||
73 | @echo "#elif defined _MSC_VER" >> edje_amalgamation.c | ||
74 | @echo "# include <malloc.h>" >> edje_amalgamation.c | ||
75 | @echo "# define alloca _alloca" >> edje_amalgamation.c | ||
76 | @echo "#else" >> edje_amalgamation.c | ||
77 | @echo "# include <stddef.h>" >> edje_amalgamation.c | ||
78 | @echo "# ifdef __cplusplus" >> edje_amalgamation.c | ||
79 | @echo "#extern \"C\"" >> edje_amalgamation.c | ||
80 | @echo "# endif" >> edje_amalgamation.c | ||
81 | @echo "#void *alloca (size_t);" >> edje_amalgamation.c | ||
82 | @echo "#endif" >> edje_amalgamation.c | ||
83 | |||
84 | @echo "#include <string.h>" >> edje_amalgamation.c | ||
85 | @echo "#include <math.h>" >> edje_amalgamation.c | ||
86 | @echo "#include <time.h>" >> edje_amalgamation.c | ||
87 | @echo "#include <limits.h>" >> edje_amalgamation.c | ||
88 | @echo "#include <errno.h>" >> edje_amalgamation.c | ||
89 | @echo "#include <sys/stat.h>" >> edje_amalgamation.c | ||
90 | @echo "#include <fcntl.h>" >> edje_amalgamation.c | ||
91 | |||
92 | @echo "#ifndef _MSC_VER" >> edje_amalgamation.c | ||
93 | @echo "# include <unistd.h>" >> edje_amalgamation.c | ||
94 | @echo "#endif" >> edje_amalgamation.c | ||
95 | |||
96 | @echo "#ifdef HAVE_LOCALE_H" >> edje_amalgamation.c | ||
97 | @echo "# include <locale.h>" >> edje_amalgamation.c | ||
98 | @echo "#endif" >> edje_amalgamation.c | ||
99 | |||
100 | @echo "#include <lua.h>" >> edje_amalgamation.c | ||
101 | @echo "#include <lauxlib.h>" >> edje_amalgamation.c | ||
102 | |||
103 | @echo "#ifdef HAVE_EVIL" >> edje_amalgamation.c | ||
104 | @echo "# include <Evil.h>" >> edje_amalgamation.c | ||
105 | @echo "#endif" >> edje_amalgamation.c | ||
106 | |||
107 | @echo "#include <Eina.h>" >> edje_amalgamation.c | ||
108 | @echo "#include <Edje.h>" >> edje_amalgamation.c | ||
109 | @echo "#include <Evas.h>" >> edje_amalgamation.c | ||
110 | @echo "#include <Ecore.h>" >> edje_amalgamation.c | ||
111 | @echo "#include <Embryo.h>" >> edje_amalgamation.c | ||
112 | |||
113 | @echo "#ifdef HAVE_ECORE_IMF" >> edje_amalgamation.c | ||
114 | @echo "# include <Ecore_IMF.h>" >> edje_amalgamation.c | ||
115 | @echo "#endif" >> edje_amalgamation.c | ||
116 | |||
117 | @echo "#include <edje_private.h>" >> edje_amalgamation.c | ||
118 | |||
119 | @for f in $(base_sources); do \ | ||
120 | if [ `echo $$f | sed -e 's/^...\(.\).*/\1/'` != '/' ]; then \ | ||
121 | file="$(srcdir)/$$f" ; \ | ||
122 | else \ | ||
123 | file="$$f" ; \ | ||
124 | fi ; \ | ||
125 | echo "/* file: $$file */" >> edje_amalgamation.c; \ | ||
126 | grep -v -e '^# *include \+.\(config\|\|Evil\|Eina\|Eet\|Evas\|Ecore\|Embryo\|Ecore_IMF\|string\|math\|limits\|sys/stat\|errno\|time\|unistd\|locale\|lua\|lauxlib\|edje_private\)[.]h.*' $$file >> edje_amalgamation.c; \ | ||
127 | done | ||
128 | @echo "edje_amalgamation.c generated" | ||
129 | |||
130 | else | ||
131 | libedje_la_SOURCES = $(base_sources) | ||
132 | endif | ||
133 | |||
134 | libedje_la_LIBADD = @EDJE_LIBS@ @ECORE_IMF_LIBS@ @EVIL_LIBS@ @REMIX_LIBS@ @SNDFILE_LIBS@ -lm | ||
135 | libedje_la_LDFLAGS = -no-undefined @lt_enable_auto_import@ -version-info @version_info@ @release_info@ | ||
136 | |||
137 | EXTRA_DIST = edje_private.h edje_container.h edje_convert.h | ||
138 | |||
139 | clean-local: | ||
140 | @rm -rf *.gcno edje_amalgamation.c | ||