aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/libraries/ecore/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/ecore/src/Makefile.am')
-rw-r--r--libraries/ecore/src/Makefile.am26
1 files changed, 26 insertions, 0 deletions
diff --git a/libraries/ecore/src/Makefile.am b/libraries/ecore/src/Makefile.am
new file mode 100644
index 0000000..b8dab4f
--- /dev/null
+++ b/libraries/ecore/src/Makefile.am
@@ -0,0 +1,26 @@
1MAINTAINERCLEANFILES = Makefile.in
2
3SUBDIRS = lib bin tests examples modules
4
5if BUILD_ECORE_X_XCB
6 MAINTAINERCLEANFILES += ecore_xcb_keysym_table.h ecore_xcb_keysym_table_h
7 CLEANFILES = ecore_xcb_keysym_table.h ecore_xcb_keysym_table_h
8
9 SUBDIRS += util
10
11 BUILT_SOURCES=ecore_xcb_keysym_table.h
12
13 #
14 # Building ecore_xcb_keysym_table.h requires the makekeys utility
15 #
16
17 ecore_xcb_keysym_table.h: $(KEYSYMDEFS) $(top_builddir)/src/util/makekeys$(EXEEXT)
18 $(top_builddir)/src/util/makekeys $(KEYSYMDEFS) > ecore_xcb_keysym_table_h
19 mv -f ecore_xcb_keysym_table_h ./lib/ecore_x/xcb/$@
20
21 $(top_builddir)/src/util/makekeys$(EXEEXT): force
22 cd util && $(MAKE)
23
24 force:
25
26endif