aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/libraries/irrlicht-1.8/source/Irrlicht/jpeglib/Makefile.am
diff options
context:
space:
mode:
authorDavid Walter Seikel2013-01-13 18:54:10 +1000
committerDavid Walter Seikel2013-01-13 18:54:10 +1000
commit959831f4ef5a3e797f576c3de08cd65032c997ad (patch)
treee7351908be5995f0b325b2ebeaa02d5a34b82583 /libraries/irrlicht-1.8/source/Irrlicht/jpeglib/Makefile.am
parentAdd info about changes to Irrlicht. (diff)
downloadSledjHamr-959831f4ef5a3e797f576c3de08cd65032c997ad.zip
SledjHamr-959831f4ef5a3e797f576c3de08cd65032c997ad.tar.gz
SledjHamr-959831f4ef5a3e797f576c3de08cd65032c997ad.tar.bz2
SledjHamr-959831f4ef5a3e797f576c3de08cd65032c997ad.tar.xz
Remove damned ancient DOS line endings from Irrlicht. Hopefully I did not go overboard.
Diffstat (limited to 'libraries/irrlicht-1.8/source/Irrlicht/jpeglib/Makefile.am')
-rw-r--r--libraries/irrlicht-1.8/source/Irrlicht/jpeglib/Makefile.am268
1 files changed, 134 insertions, 134 deletions
diff --git a/libraries/irrlicht-1.8/source/Irrlicht/jpeglib/Makefile.am b/libraries/irrlicht-1.8/source/Irrlicht/jpeglib/Makefile.am
index b4b4600..42cff57 100644
--- a/libraries/irrlicht-1.8/source/Irrlicht/jpeglib/Makefile.am
+++ b/libraries/irrlicht-1.8/source/Irrlicht/jpeglib/Makefile.am
@@ -1,134 +1,134 @@
1## Process this file with automake to produce Makefile.in 1## Process this file with automake to produce Makefile.in
2# 2#
3# Automake Makefile for the JPEG library 3# Automake Makefile for the JPEG library
4# 4#
5# This file is written by Bob Friesenhahn, Guido Vollbeding 5# This file is written by Bob Friesenhahn, Guido Vollbeding
6# 6#
7 7
8# Sources to build library 8# Sources to build library
9LIBSOURCES = jaricom.c jcapimin.c jcapistd.c jcarith.c jccoefct.c jccolor.c \ 9LIBSOURCES = jaricom.c jcapimin.c jcapistd.c jcarith.c jccoefct.c jccolor.c \
10 jcdctmgr.c jchuff.c jcinit.c jcmainct.c jcmarker.c jcmaster.c \ 10 jcdctmgr.c jchuff.c jcinit.c jcmainct.c jcmarker.c jcmaster.c \
11 jcomapi.c jcparam.c jcprepct.c jcsample.c jctrans.c jdapimin.c \ 11 jcomapi.c jcparam.c jcprepct.c jcsample.c jctrans.c jdapimin.c \
12 jdapistd.c jdarith.c jdatadst.c jdatasrc.c jdcoefct.c jdcolor.c \ 12 jdapistd.c jdarith.c jdatadst.c jdatasrc.c jdcoefct.c jdcolor.c \
13 jddctmgr.c jdhuff.c jdinput.c jdmainct.c jdmarker.c jdmaster.c \ 13 jddctmgr.c jdhuff.c jdinput.c jdmainct.c jdmarker.c jdmaster.c \
14 jdmerge.c jdpostct.c jdsample.c jdtrans.c jerror.c jfdctflt.c \ 14 jdmerge.c jdpostct.c jdsample.c jdtrans.c jerror.c jfdctflt.c \
15 jfdctfst.c jfdctint.c jidctflt.c jidctfst.c jidctint.c jquant1.c \ 15 jfdctfst.c jfdctint.c jidctflt.c jidctfst.c jidctint.c jquant1.c \
16 jquant2.c jutils.c jmemmgr.c @MEMORYMGR@.c 16 jquant2.c jutils.c jmemmgr.c @MEMORYMGR@.c
17 17
18# System dependent sources 18# System dependent sources
19SYSDEPSOURCES = jmemansi.c jmemname.c jmemnobs.c jmemdos.c jmemmac.c 19SYSDEPSOURCES = jmemansi.c jmemname.c jmemnobs.c jmemdos.c jmemmac.c
20 20
21# Headers which are installed to support the library 21# Headers which are installed to support the library
22INSTINCLUDES = jerror.h jmorecfg.h jpeglib.h 22INSTINCLUDES = jerror.h jmorecfg.h jpeglib.h
23 23
24# Headers which are not installed 24# Headers which are not installed
25OTHERINCLUDES = cderror.h cdjpeg.h jdct.h jinclude.h jmemsys.h jpegint.h \ 25OTHERINCLUDES = cderror.h cdjpeg.h jdct.h jinclude.h jmemsys.h jpegint.h \
26 jversion.h transupp.h 26 jversion.h transupp.h
27 27
28# Manual pages (Automake uses 'MANS' for itself) 28# Manual pages (Automake uses 'MANS' for itself)
29DISTMANS= cjpeg.1 djpeg.1 jpegtran.1 rdjpgcom.1 wrjpgcom.1 29DISTMANS= cjpeg.1 djpeg.1 jpegtran.1 rdjpgcom.1 wrjpgcom.1
30 30
31# Other documentation files 31# Other documentation files
32DOCS= README install.txt usage.txt wizard.txt example.c libjpeg.txt \ 32DOCS= README install.txt usage.txt wizard.txt example.c libjpeg.txt \
33 structure.txt coderules.txt filelist.txt change.log 33 structure.txt coderules.txt filelist.txt change.log
34 34
35# Makefiles for various systems 35# Makefiles for various systems
36MKFILES= configure Makefile.in makefile.ansi makefile.unix makefile.bcc \ 36MKFILES= configure Makefile.in makefile.ansi makefile.unix makefile.bcc \
37 makefile.mc6 makefile.dj makefile.wat makefile.vc makejdsw.vc6 \ 37 makefile.mc6 makefile.dj makefile.wat makefile.vc makejdsw.vc6 \
38 makeadsw.vc6 makejdep.vc6 makejdsp.vc6 makejmak.vc6 makecdep.vc6 \ 38 makeadsw.vc6 makejdep.vc6 makejdsp.vc6 makejmak.vc6 makecdep.vc6 \
39 makecdsp.vc6 makecmak.vc6 makeddep.vc6 makeddsp.vc6 makedmak.vc6 \ 39 makecdsp.vc6 makecmak.vc6 makeddep.vc6 makeddsp.vc6 makedmak.vc6 \
40 maketdep.vc6 maketdsp.vc6 maketmak.vc6 makerdep.vc6 makerdsp.vc6 \ 40 maketdep.vc6 maketdsp.vc6 maketmak.vc6 makerdep.vc6 makerdsp.vc6 \
41 makermak.vc6 makewdep.vc6 makewdsp.vc6 makewmak.vc6 makejsln.v10 \ 41 makermak.vc6 makewdep.vc6 makewdsp.vc6 makewmak.vc6 makejsln.v10 \
42 makeasln.v10 makejvcx.v10 makejfil.v10 makecvcx.v10 makecfil.v10 \ 42 makeasln.v10 makejvcx.v10 makejfil.v10 makecvcx.v10 makecfil.v10 \
43 makedvcx.v10 makedfil.v10 maketvcx.v10 maketfil.v10 makervcx.v10 \ 43 makedvcx.v10 makedfil.v10 maketvcx.v10 maketfil.v10 makervcx.v10 \
44 makerfil.v10 makewvcx.v10 makewfil.v10 makeproj.mac makcjpeg.st \ 44 makerfil.v10 makewvcx.v10 makewfil.v10 makeproj.mac makcjpeg.st \
45 makdjpeg.st makljpeg.st maktjpeg.st makefile.manx makefile.sas \ 45 makdjpeg.st makljpeg.st maktjpeg.st makefile.manx makefile.sas \
46 makefile.mms makefile.vms makvms.opt 46 makefile.mms makefile.vms makvms.opt
47 47
48# Configuration files 48# Configuration files
49CONFIGFILES= jconfig.cfg jconfig.bcc jconfig.mc6 jconfig.dj jconfig.wat \ 49CONFIGFILES= jconfig.cfg jconfig.bcc jconfig.mc6 jconfig.dj jconfig.wat \
50 jconfig.vc jconfig.mac jconfig.st jconfig.manx jconfig.sas \ 50 jconfig.vc jconfig.mac jconfig.st jconfig.manx jconfig.sas \
51 jconfig.vms 51 jconfig.vms
52 52
53# Support scripts for configure 53# Support scripts for configure
54CONFIGUREFILES= config.guess config.sub install-sh ltmain.sh depcomp missing 54CONFIGUREFILES= config.guess config.sub install-sh ltmain.sh depcomp missing
55 55
56# Miscellaneous support files 56# Miscellaneous support files
57OTHERFILES= jconfig.txt ckconfig.c ansi2knr.c ansi2knr.1 jmemdosa.asm \ 57OTHERFILES= jconfig.txt ckconfig.c ansi2knr.c ansi2knr.1 jmemdosa.asm \
58 libjpeg.map 58 libjpeg.map
59 59
60# Test support files 60# Test support files
61TESTFILES= testorig.jpg testimg.ppm testimg.bmp testimg.jpg testprog.jpg \ 61TESTFILES= testorig.jpg testimg.ppm testimg.bmp testimg.jpg testprog.jpg \
62 testimgp.jpg 62 testimgp.jpg
63 63
64# libtool libraries to build 64# libtool libraries to build
65lib_LTLIBRARIES = libjpeg.la 65lib_LTLIBRARIES = libjpeg.la
66 66
67# Library sources for libjpeg.la 67# Library sources for libjpeg.la
68libjpeg_la_SOURCES = $(LIBSOURCES) 68libjpeg_la_SOURCES = $(LIBSOURCES)
69 69
70# LDFLAGS for libjpeg.la 70# LDFLAGS for libjpeg.la
71libjpeg_la_LDFLAGS = -no-undefined \ 71libjpeg_la_LDFLAGS = -no-undefined \
72 -version-info $(JPEG_LIB_VERSION) 72 -version-info $(JPEG_LIB_VERSION)
73 73
74if HAVE_LD_VERSION_SCRIPT 74if HAVE_LD_VERSION_SCRIPT
75 libjpeg_la_LDFLAGS += -Wl,--version-script=$(srcdir)/libjpeg.map 75 libjpeg_la_LDFLAGS += -Wl,--version-script=$(srcdir)/libjpeg.map
76endif 76endif
77 77
78# Executables to build 78# Executables to build
79bin_PROGRAMS = cjpeg djpeg jpegtran rdjpgcom wrjpgcom 79bin_PROGRAMS = cjpeg djpeg jpegtran rdjpgcom wrjpgcom
80 80
81# Executable sources & libs 81# Executable sources & libs
82cjpeg_SOURCES = cjpeg.c rdppm.c rdgif.c rdtarga.c rdrle.c rdbmp.c \ 82cjpeg_SOURCES = cjpeg.c rdppm.c rdgif.c rdtarga.c rdrle.c rdbmp.c \
83 rdswitch.c cdjpeg.c 83 rdswitch.c cdjpeg.c
84cjpeg_LDADD = libjpeg.la 84cjpeg_LDADD = libjpeg.la
85djpeg_SOURCES = djpeg.c wrppm.c wrgif.c wrtarga.c wrrle.c wrbmp.c \ 85djpeg_SOURCES = djpeg.c wrppm.c wrgif.c wrtarga.c wrrle.c wrbmp.c \
86 rdcolmap.c cdjpeg.c 86 rdcolmap.c cdjpeg.c
87djpeg_LDADD = libjpeg.la 87djpeg_LDADD = libjpeg.la
88jpegtran_SOURCES = jpegtran.c rdswitch.c cdjpeg.c transupp.c 88jpegtran_SOURCES = jpegtran.c rdswitch.c cdjpeg.c transupp.c
89jpegtran_LDADD = libjpeg.la 89jpegtran_LDADD = libjpeg.la
90rdjpgcom_SOURCES = rdjpgcom.c 90rdjpgcom_SOURCES = rdjpgcom.c
91wrjpgcom_SOURCES = wrjpgcom.c 91wrjpgcom_SOURCES = wrjpgcom.c
92 92
93# Manual pages to install 93# Manual pages to install
94man_MANS = $(DISTMANS) 94man_MANS = $(DISTMANS)
95 95
96# Headers to install 96# Headers to install
97include_HEADERS = $(INSTINCLUDES) 97include_HEADERS = $(INSTINCLUDES)
98 98
99# Other distributed headers 99# Other distributed headers
100noinst_HEADERS = $(OTHERINCLUDES) 100noinst_HEADERS = $(OTHERINCLUDES)
101 101
102# Other distributed files 102# Other distributed files
103EXTRA_DIST = $(DOCS) $(DISTMANS) $(MKFILES) $(CONFIGFILES) $(SYSDEPSOURCES) \ 103EXTRA_DIST = $(DOCS) $(DISTMANS) $(MKFILES) $(CONFIGFILES) $(SYSDEPSOURCES) \
104 $(OTHERFILES) $(TESTFILES) 104 $(OTHERFILES) $(TESTFILES)
105 105
106# Files to be cleaned 106# Files to be cleaned
107CLEANFILES = testout.ppm testout.bmp testout.jpg testoutp.ppm testoutp.jpg \ 107CLEANFILES = testout.ppm testout.bmp testout.jpg testoutp.ppm testoutp.jpg \
108 testoutt.jpg 108 testoutt.jpg
109 109
110# Install jconfig.h 110# Install jconfig.h
111install-data-local: 111install-data-local:
112 $(mkinstalldirs) $(DESTDIR)$(includedir) 112 $(mkinstalldirs) $(DESTDIR)$(includedir)
113 $(INSTALL_HEADER) jconfig.h $(DESTDIR)$(includedir)/jconfig.h 113 $(INSTALL_HEADER) jconfig.h $(DESTDIR)$(includedir)/jconfig.h
114 114
115# Uninstall jconfig.h 115# Uninstall jconfig.h
116uninstall-local: 116uninstall-local:
117 rm -f $(DESTDIR)$(includedir)/jconfig.h 117 rm -f $(DESTDIR)$(includedir)/jconfig.h
118 118
119# Run tests 119# Run tests
120test: check-local 120test: check-local
121check-local: 121check-local:
122 rm -f testout* 122 rm -f testout*
123 ./djpeg -dct int -ppm -outfile testout.ppm $(srcdir)/testorig.jpg 123 ./djpeg -dct int -ppm -outfile testout.ppm $(srcdir)/testorig.jpg
124 ./djpeg -dct int -bmp -colors 256 -outfile testout.bmp $(srcdir)/testorig.jpg 124 ./djpeg -dct int -bmp -colors 256 -outfile testout.bmp $(srcdir)/testorig.jpg
125 ./cjpeg -dct int -outfile testout.jpg $(srcdir)/testimg.ppm 125 ./cjpeg -dct int -outfile testout.jpg $(srcdir)/testimg.ppm
126 ./djpeg -dct int -ppm -outfile testoutp.ppm $(srcdir)/testprog.jpg 126 ./djpeg -dct int -ppm -outfile testoutp.ppm $(srcdir)/testprog.jpg
127 ./cjpeg -dct int -progressive -opt -outfile testoutp.jpg $(srcdir)/testimg.ppm 127 ./cjpeg -dct int -progressive -opt -outfile testoutp.jpg $(srcdir)/testimg.ppm
128 ./jpegtran -outfile testoutt.jpg $(srcdir)/testprog.jpg 128 ./jpegtran -outfile testoutt.jpg $(srcdir)/testprog.jpg
129 cmp $(srcdir)/testimg.ppm testout.ppm 129 cmp $(srcdir)/testimg.ppm testout.ppm
130 cmp $(srcdir)/testimg.bmp testout.bmp 130 cmp $(srcdir)/testimg.bmp testout.bmp
131 cmp $(srcdir)/testimg.jpg testout.jpg 131 cmp $(srcdir)/testimg.jpg testout.jpg
132 cmp $(srcdir)/testimg.ppm testoutp.ppm 132 cmp $(srcdir)/testimg.ppm testoutp.ppm
133 cmp $(srcdir)/testimgp.jpg testoutp.jpg 133 cmp $(srcdir)/testimgp.jpg testoutp.jpg
134 cmp $(srcdir)/testorig.jpg testoutt.jpg 134 cmp $(srcdir)/testorig.jpg testoutt.jpg