aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/libraries/evas/src/modules/savers/edb/Makefile.am
diff options
context:
space:
mode:
authorDavid Walter Seikel2012-01-04 18:41:13 +1000
committerDavid Walter Seikel2012-01-04 18:41:13 +1000
commitdd7595a3475407a7fa96a97393bae8c5220e8762 (patch)
treee341e911d7eb911a51684a7412ef7f7c7605d28e /libraries/evas/src/modules/savers/edb/Makefile.am
parentAdd the skeleton. (diff)
downloadSledjHamr-dd7595a3475407a7fa96a97393bae8c5220e8762.zip
SledjHamr-dd7595a3475407a7fa96a97393bae8c5220e8762.tar.gz
SledjHamr-dd7595a3475407a7fa96a97393bae8c5220e8762.tar.bz2
SledjHamr-dd7595a3475407a7fa96a97393bae8c5220e8762.tar.xz
Add the base Enlightenment Foundation Libraries - eina, eet, evas, ecore, embryo, and edje.
Note that embryo wont be used, but I'm not sure yet if you can build edje without it.
Diffstat (limited to 'libraries/evas/src/modules/savers/edb/Makefile.am')
-rw-r--r--libraries/evas/src/modules/savers/edb/Makefile.am32
1 files changed, 32 insertions, 0 deletions
diff --git a/libraries/evas/src/modules/savers/edb/Makefile.am b/libraries/evas/src/modules/savers/edb/Makefile.am
new file mode 100644
index 0000000..4614cec
--- /dev/null
+++ b/libraries/evas/src/modules/savers/edb/Makefile.am
@@ -0,0 +1,32 @@
1
2MAINTAINERCLEANFILES = Makefile.in
3
4AM_CPPFLAGS = -I. \
5 -I$(top_srcdir)/src/lib \
6 -I$(top_srcdir)/src/lib/include \
7 @FREETYPE_CFLAGS@ @PIXMAN_CFLAGS@ @evas_image_loader_edb_cflags@ \
8 @EINA_CFLAGS@
9
10if BUILD_LOADER_EDB
11if !EVAS_STATIC_BUILD_EDB
12
13pkgdir = $(libdir)/evas/modules/savers/edb/$(MODULE_ARCH)
14pkg_LTLIBRARIES = module.la
15
16module_la_SOURCES = evas_image_save_edb.c
17
18module_la_LIBADD = @EINA_LIBS@ @evas_image_loader_edb_libs@ $(top_builddir)/src/lib/libevas.la
19module_la_LDFLAGS = -no-undefined -module -avoid-version
20module_la_LIBTOOLFLAGS = --tag=disable-static
21
22else
23
24noinst_LTLIBRARIES = libevas_saver_edb.la
25
26libevas_saver_edb_la_SOURCES = evas_image_save_edb.c
27libevas_saver_edb_la_LIBADD = @evas_image_loader_edb_libs@
28
29endif
30endif
31
32EXTRA_DIST = evas_image_save_edb.c