aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/libraries/evas/src/modules/loaders/pmaps/Makefile.am
diff options
context:
space:
mode:
authorDavid Walter Seikel2012-01-04 18:41:13 +1000
committerDavid Walter Seikel2012-01-04 18:41:13 +1000
commitdd7595a3475407a7fa96a97393bae8c5220e8762 (patch)
treee341e911d7eb911a51684a7412ef7f7c7605d28e /libraries/evas/src/modules/loaders/pmaps/Makefile.am
parentAdd the skeleton. (diff)
downloadSledjHamr-dd7595a3475407a7fa96a97393bae8c5220e8762.zip
SledjHamr-dd7595a3475407a7fa96a97393bae8c5220e8762.tar.gz
SledjHamr-dd7595a3475407a7fa96a97393bae8c5220e8762.tar.bz2
SledjHamr-dd7595a3475407a7fa96a97393bae8c5220e8762.tar.xz
Add the base Enlightenment Foundation Libraries - eina, eet, evas, ecore, embryo, and edje.
Note that embryo wont be used, but I'm not sure yet if you can build edje without it.
Diffstat (limited to '')
-rw-r--r--libraries/evas/src/modules/loaders/pmaps/Makefile.am36
1 files changed, 36 insertions, 0 deletions
diff --git a/libraries/evas/src/modules/loaders/pmaps/Makefile.am b/libraries/evas/src/modules/loaders/pmaps/Makefile.am
new file mode 100644
index 0000000..dc07a32
--- /dev/null
+++ b/libraries/evas/src/modules/loaders/pmaps/Makefile.am
@@ -0,0 +1,36 @@
1
2MAINTAINERCLEANFILES = Makefile.in
3
4AM_CPPFLAGS = \
5-I. \
6-I$(top_srcdir)/src/lib \
7-I$(top_srcdir)/src/lib/include \
8@FREETYPE_CFLAGS@ \
9@PIXMAN_CFLAGS@ \
10@EINA_CFLAGS@ \
11@evas_image_loader_pmaps_cflags@ \
12@EVIL_CFLAGS@ \
13@WIN32_CPPFLAGS@
14
15AM_CFLAGS = @WIN32_CFLAGS@
16
17if BUILD_LOADER_PMAPS
18if !EVAS_STATIC_BUILD_PMAPS
19
20pkgdir = $(libdir)/evas/modules/loaders/pmaps/$(MODULE_ARCH)
21pkg_LTLIBRARIES = module.la
22
23module_la_SOURCES = evas_image_load_pmaps.c
24
25module_la_LIBADD = @evas_image_loader_pmaps_libs@ @EINA_LIBS@ @EVIL_LIBS@ $(top_builddir)/src/lib/libevas.la
26module_la_LDFLAGS = -no-undefined @lt_enable_auto_import@ -module -avoid-version
27module_la_LIBTOOLFLAGS = --tag=disable-static
28
29else
30
31noinst_LTLIBRARIES = libevas_loader_pmaps.la
32libevas_loader_pmaps_la_SOURCES = evas_image_load_pmaps.c
33libevas_loader_pmaps_la_LIBADD = @evas_image_loader_pmaps_libs@
34
35endif
36endif