aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/libraries/evas/src/modules/loaders/eet/Makefile.am
diff options
context:
space:
mode:
authorDavid Walter Seikel2012-01-04 18:41:13 +1000
committerDavid Walter Seikel2012-01-04 18:41:13 +1000
commitdd7595a3475407a7fa96a97393bae8c5220e8762 (patch)
treee341e911d7eb911a51684a7412ef7f7c7605d28e /libraries/evas/src/modules/loaders/eet/Makefile.am
parentAdd the skeleton. (diff)
downloadSledjHamr-dd7595a3475407a7fa96a97393bae8c5220e8762.zip
SledjHamr-dd7595a3475407a7fa96a97393bae8c5220e8762.tar.gz
SledjHamr-dd7595a3475407a7fa96a97393bae8c5220e8762.tar.bz2
SledjHamr-dd7595a3475407a7fa96a97393bae8c5220e8762.tar.xz
Add the base Enlightenment Foundation Libraries - eina, eet, evas, ecore, embryo, and edje.
Note that embryo wont be used, but I'm not sure yet if you can build edje without it.
Diffstat (limited to '')
-rw-r--r--libraries/evas/src/modules/loaders/eet/Makefile.am36
1 files changed, 36 insertions, 0 deletions
diff --git a/libraries/evas/src/modules/loaders/eet/Makefile.am b/libraries/evas/src/modules/loaders/eet/Makefile.am
new file mode 100644
index 0000000..c96a8d3
--- /dev/null
+++ b/libraries/evas/src/modules/loaders/eet/Makefile.am
@@ -0,0 +1,36 @@
1
2MAINTAINERCLEANFILES = Makefile.in
3
4AM_CPPFLAGS = \
5-I. \
6-I$(top_srcdir)/src/lib \
7-I$(top_srcdir)/src/lib/include \
8@FREETYPE_CFLAGS@ \
9@PIXMAN_CFLAGS@ \
10@evas_image_loader_eet_cflags@ \
11@EINA_CFLAGS@
12
13AM_CFLAGS = @WIN32_CFLAGS@
14
15
16if BUILD_LOADER_EET
17if !EVAS_STATIC_BUILD_EET
18
19pkgdir = $(libdir)/evas/modules/loaders/eet/$(MODULE_ARCH)
20pkg_LTLIBRARIES = module.la
21
22module_la_SOURCES = evas_image_load_eet.c
23
24module_la_LIBADD = @EINA_LIBS@ @evas_image_loader_eet_libs@ $(top_builddir)/src/lib/libevas.la
25module_la_LDFLAGS = -no-undefined @lt_enable_auto_import@ -module -avoid-version
26module_la_LIBTOOLFLAGS = --tag=disable-static
27
28else
29
30noinst_LTLIBRARIES = libevas_loader_eet.la
31
32libevas_loader_eet_la_SOURCES = evas_image_load_eet.c
33libevas_loader_eet_la_LIBADD = @evas_image_loader_eet_libs@
34
35endif
36endif