aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/libraries/evas/src/modules/loaders/edb/Makefile.am
diff options
context:
space:
mode:
authorDavid Walter Seikel2012-01-04 18:41:13 +1000
committerDavid Walter Seikel2012-01-04 18:41:13 +1000
commitdd7595a3475407a7fa96a97393bae8c5220e8762 (patch)
treee341e911d7eb911a51684a7412ef7f7c7605d28e /libraries/evas/src/modules/loaders/edb/Makefile.am
parentAdd the skeleton. (diff)
downloadSledjHamr-dd7595a3475407a7fa96a97393bae8c5220e8762.zip
SledjHamr-dd7595a3475407a7fa96a97393bae8c5220e8762.tar.gz
SledjHamr-dd7595a3475407a7fa96a97393bae8c5220e8762.tar.bz2
SledjHamr-dd7595a3475407a7fa96a97393bae8c5220e8762.tar.xz
Add the base Enlightenment Foundation Libraries - eina, eet, evas, ecore, embryo, and edje.
Note that embryo wont be used, but I'm not sure yet if you can build edje without it.
Diffstat (limited to 'libraries/evas/src/modules/loaders/edb/Makefile.am')
-rw-r--r--libraries/evas/src/modules/loaders/edb/Makefile.am34
1 files changed, 34 insertions, 0 deletions
diff --git a/libraries/evas/src/modules/loaders/edb/Makefile.am b/libraries/evas/src/modules/loaders/edb/Makefile.am
new file mode 100644
index 0000000..a0baf6b
--- /dev/null
+++ b/libraries/evas/src/modules/loaders/edb/Makefile.am
@@ -0,0 +1,34 @@
1
2MAINTAINERCLEANFILES = Makefile.in
3
4AM_CPPFLAGS = \
5-I. \
6-I$(top_srcdir)/src/lib \
7-I$(top_srcdir)/src/lib/include \
8@FREETYPE_CFLAGS@ \
9@PIXMAN_CFLAGS@ \
10@evas_image_loader_edb_cflags@ \
11@EINA_CFLAGS@
12
13
14if BUILD_LOADER_EDB
15if !EVAS_STATIC_BUILD_EDB
16
17pkgdir = $(libdir)/evas/modules/loaders/edb/$(MODULE_ARCH)
18pkg_LTLIBRARIES = module.la
19
20module_la_SOURCES = evas_image_load_edb.c
21
22module_la_LIBADD = @evas_image_loader_edb_libs@ @EINA_LIBS@ $(top_builddir)/src/lib/libevas.la
23module_la_LDFLAGS = -no-undefined -module -avoid-version
24module_la_LIBTOOLFLAGS = --tag=disable-static
25
26else
27
28noinst_LTLIBRARIES = libevas_loader_edb.la
29
30libevas_loader_edb_la_SOURCES = evas_image_load_edb.c
31libevas_loader_edb_la_LIBADD = @evas_image_loader_edb_libs@
32
33endif
34endif