aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/libraries/evas/src/modules/engines/psl1ght/Makefile.am
diff options
context:
space:
mode:
authorDavid Walter Seikel2012-01-04 18:41:13 +1000
committerDavid Walter Seikel2012-01-04 18:41:13 +1000
commitdd7595a3475407a7fa96a97393bae8c5220e8762 (patch)
treee341e911d7eb911a51684a7412ef7f7c7605d28e /libraries/evas/src/modules/engines/psl1ght/Makefile.am
parentAdd the skeleton. (diff)
downloadSledjHamr-dd7595a3475407a7fa96a97393bae8c5220e8762.zip
SledjHamr-dd7595a3475407a7fa96a97393bae8c5220e8762.tar.gz
SledjHamr-dd7595a3475407a7fa96a97393bae8c5220e8762.tar.bz2
SledjHamr-dd7595a3475407a7fa96a97393bae8c5220e8762.tar.xz
Add the base Enlightenment Foundation Libraries - eina, eet, evas, ecore, embryo, and edje.
Note that embryo wont be used, but I'm not sure yet if you can build edje without it.
Diffstat (limited to 'libraries/evas/src/modules/engines/psl1ght/Makefile.am')
-rw-r--r--libraries/evas/src/modules/engines/psl1ght/Makefile.am47
1 files changed, 47 insertions, 0 deletions
diff --git a/libraries/evas/src/modules/engines/psl1ght/Makefile.am b/libraries/evas/src/modules/engines/psl1ght/Makefile.am
new file mode 100644
index 0000000..92ccea7
--- /dev/null
+++ b/libraries/evas/src/modules/engines/psl1ght/Makefile.am
@@ -0,0 +1,47 @@
1
2MAINTAINERCLEANFILES = Makefile.in
3
4AM_CPPFLAGS = \
5-I. \
6-I$(top_srcdir)/src/lib \
7-I$(top_srcdir)/src/lib/include \
8-I$(top_srcdir)/src/modules/engines \
9@FREETYPE_CFLAGS@ \
10@PIXMAN_CFLAGS@ \
11@EINA_CFLAGS@ \
12@evas_engine_psl1ght_cflags@
13
14if BUILD_ENGINE_PSL1GHT
15
16PSL1GHT_SOURCES = \
17evas_engine.c \
18rsxutil.c
19
20PSL1GHT_LIBADD = @evas_engine_psl1ght_libs@
21
22
23includes_HEADERS = Evas_Engine_PSL1GHT.h
24includesdir = $(includedir)/evas-@VMAJ@
25
26if !EVAS_STATIC_BUILD_PSL1GHT
27
28pkgdir = $(libdir)/evas/modules/engines/psl1ght/$(MODULE_ARCH)
29pkg_LTLIBRARIES = module.la
30module_la_SOURCES = $(PSL1GHT_SOURCES)
31module_la_LIBADD = @EINA_LIBS@ $(PSL1GHT_LIBADD) $(top_builddir)/src/lib/libevas.la
32module_la_LDFLAGS = -module -avoid-version
33module_la_LIBTOOLFLAGS = --tag=disable-static
34
35else
36
37noinst_LTLIBRARIES = libevas_engine_psl1ght.la
38
39libevas_engine_psl1ght_la_SOURCES = $(PSL1GHT_SOURCES)
40libevas_engine_psl1ght_la_LIBADD = $(PSL1GHT_LIBADD)
41
42endif
43endif
44
45EXTRA_DIST = \
46evas_engine.h \
47rsxutil.h