diff options
author | David Walter Seikel | 2013-01-13 17:29:19 +1000 |
---|---|---|
committer | David Walter Seikel | 2013-01-13 17:29:19 +1000 |
commit | 07274513e984f0b5544586c74508ccd16e7dcafa (patch) | |
tree | b32ff2a9136fbc1a4a6a0ed1e4d79cde0f5f16d9 /libraries/evas/src/lib/Makefile.am | |
parent | Added Irrlicht 1.8, but without all the Windows binaries. (diff) | |
download | SledjHamr-07274513e984f0b5544586c74508ccd16e7dcafa.zip SledjHamr-07274513e984f0b5544586c74508ccd16e7dcafa.tar.gz SledjHamr-07274513e984f0b5544586c74508ccd16e7dcafa.tar.bz2 SledjHamr-07274513e984f0b5544586c74508ccd16e7dcafa.tar.xz |
Remove EFL, since it's been released now.
Diffstat (limited to '')
-rw-r--r-- | libraries/evas/src/lib/Makefile.am | 260 |
1 files changed, 0 insertions, 260 deletions
diff --git a/libraries/evas/src/lib/Makefile.am b/libraries/evas/src/lib/Makefile.am deleted file mode 100644 index 1240b2b..0000000 --- a/libraries/evas/src/lib/Makefile.am +++ /dev/null | |||
@@ -1,260 +0,0 @@ | |||
1 | MAINTAINERCLEANFILES = Makefile.in | ||
2 | |||
3 | SUBDIRS = canvas cache cserve file engines include | ||
4 | EVAS_STATIC_MODULE = | ||
5 | EVAS_STATIC_LIBADD = | ||
6 | |||
7 | if EVAS_STATIC_BUILD_SOFTWARE_GENERIC | ||
8 | SUBDIRS += ../modules/engines/software_generic/ | ||
9 | EVAS_STATIC_MODULE += ../modules/engines/software_generic/libevas_engine_software_generic.la | ||
10 | endif | ||
11 | if EVAS_STATIC_BUILD_BUFFER | ||
12 | SUBDIRS += ../modules/engines/buffer/ | ||
13 | EVAS_STATIC_MODULE += ../modules/engines/buffer/libevas_engine_buffer.la | ||
14 | endif | ||
15 | if EVAS_STATIC_BUILD_DIRECT3D | ||
16 | SUBDIRS += ../modules/engines/direct3d/ | ||
17 | EVAS_STATIC_MODULE += ../modules/engines/direct3d/libevas_engine_direct3d.la | ||
18 | EVAS_STATIC_LIBADD += @evas_engine_direct3d_libs@ | ||
19 | endif | ||
20 | if EVAS_STATIC_BUILD_DIRECTFB | ||
21 | SUBDIRS += ../modules/engines/directfb/ | ||
22 | EVAS_STATIC_MODULE += ../modules/engines/directfb/libevas_engine_directfb.la | ||
23 | EVAS_STATIC_LIBADD += @evas_engine_directfb_libs@ | ||
24 | endif | ||
25 | if EVAS_STATIC_BUILD_FB | ||
26 | SUBDIRS += ../modules/engines/fb/ | ||
27 | EVAS_STATIC_MODULE += ../modules/engines/fb/libevas_engine_fb.la | ||
28 | EVAS_STATIC_LIBADD += @evas_engine_fb_libs@ | ||
29 | endif | ||
30 | if EVAS_STATIC_BUILD_GL_X11 | ||
31 | SUBDIRS += \ | ||
32 | ../modules/engines/gl_common \ | ||
33 | ../modules/engines/gl_x11 | ||
34 | EVAS_STATIC_MODULE += \ | ||
35 | ../modules/engines/gl_x11/libevas_engine_gl_x11.la | ||
36 | EVAS_STATIC_LIBADD += @evas_engine_gl_common_libs@ @evas_engine_gl_xlib_libs@ | ||
37 | endif | ||
38 | if EVAS_STATIC_BUILD_GL_SDL | ||
39 | SUBDIRS += \ | ||
40 | ../modules/engines/gl_common \ | ||
41 | ../modules/engines/gl_sdl | ||
42 | EVAS_STATIC_MODULE += \ | ||
43 | ../modules/engines/gl_sdl/libevas_engine_gl_sdl.la | ||
44 | EVAS_STATIC_LIBADD += @evas_engine_gl_common_libs@ @evas_engine_gl_sdl_libs@ | ||
45 | endif | ||
46 | if EVAS_STATIC_BUILD_PSL1GHT | ||
47 | SUBDIRS += ../modules/engines/psl1ght/ | ||
48 | EVAS_STATIC_MODULE += ../modules/engines/psl1ght/libevas_engine_psl1ght.la | ||
49 | EVAS_STATIC_LIBADD += @evas_engine_psl1ght_libs@ | ||
50 | endif | ||
51 | if EVAS_STATIC_BUILD_SOFTWARE_16 | ||
52 | SUBDIRS += ../modules/engines/software_16/ | ||
53 | EVAS_STATIC_MODULE += ../modules/engines/software_16/libevas_engine_software_16.la | ||
54 | endif | ||
55 | if EVAS_STATIC_BUILD_SOFTWARE_16_DDRAW | ||
56 | SUBDIRS += ../modules/engines/software_16_ddraw/ | ||
57 | EVAS_STATIC_MODULE += ../modules/engines/software_16_ddraw/libevas_engine_software_16_ddraw.la | ||
58 | EVAS_STATIC_LIBADD += @evas_engine_software_16_ddraw_libs@ | ||
59 | endif | ||
60 | if EVAS_STATIC_BUILD_SOFTWARE_16_WINCE | ||
61 | SUBDIRS += ../modules/engines/software_16_wince/ | ||
62 | EVAS_STATIC_MODULE += ../modules/engines/software_16_wince/libevas_engine_software_16_wince.la | ||
63 | EVAS_STATIC_LIBADD += @evas_engine_software_16_wince_libs@ | ||
64 | endif | ||
65 | if EVAS_STATIC_BUILD_SOFTWARE_16_X11 | ||
66 | SUBDIRS += ../modules/engines/software_16_x11/ | ||
67 | EVAS_STATIC_MODULE += ../modules/engines/software_16_x11/libevas_engine_software_16_x11.la | ||
68 | EVAS_STATIC_LIBADD += @evas_engine_software_16_x11_libs@ | ||
69 | endif | ||
70 | if EVAS_STATIC_BUILD_SOFTWARE_8 | ||
71 | SUBDIRS += ../modules/engines/software_8/ | ||
72 | EVAS_STATIC_MODULE += ../modules/engines/software_8/libevas_engine_software_8.la | ||
73 | endif | ||
74 | if EVAS_STATIC_BUILD_SOFTWARE_8_X11 | ||
75 | SUBDIRS += ../modules/engines/software_8_x11/ | ||
76 | EVAS_STATIC_MODULE += ../modules/engines/software_8_x11/libevas_engine_software_8_x11.la | ||
77 | EVAS_STATIC_LIBADD += @evas_engine_software_8_x11_libs@ | ||
78 | endif | ||
79 | if EVAS_STATIC_BUILD_SOFTWARE_16_SDL | ||
80 | SUBDIRS += \ | ||
81 | ../modules/engines/software_16_sdl/ | ||
82 | EVAS_STATIC_MODULE += \ | ||
83 | ../modules/engines/software_16_sdl/libevas_engine_software_16_sdl.la | ||
84 | EVAS_STATIC_LIBADD += @SDL_LIBS@ | ||
85 | endif | ||
86 | if EVAS_STATIC_BUILD_SOFTWARE_DDRAW | ||
87 | SUBDIRS += ../modules/engines/software_ddraw/ | ||
88 | EVAS_STATIC_MODULE += ../modules/engines/software_ddraw/libevas_engine_software_ddraw.la | ||
89 | EVAS_STATIC_LIBADD += @evas_engine_software_ddraw_libs@ | ||
90 | endif | ||
91 | if EVAS_STATIC_BUILD_SOFTWARE_GDI | ||
92 | SUBDIRS += ../modules/engines/software_gdi/ | ||
93 | EVAS_STATIC_MODULE += ../modules/engines/software_gdi/libevas_engine_software_gdi.la | ||
94 | EVAS_STATIC_LIBADD += @evas_engine_software_gdi_libs@ | ||
95 | endif | ||
96 | if EVAS_STATIC_BUILD_SOFTWARE_X11 | ||
97 | SUBDIRS += ../modules/engines/software_x11/ | ||
98 | EVAS_STATIC_MODULE += ../modules/engines/software_x11/libevas_engine_software_x11.la | ||
99 | EVAS_STATIC_LIBADD += @evas_engine_software_xlib_libs@ @evas_engine_software_xcb_libs@ | ||
100 | endif | ||
101 | if EVAS_STATIC_BUILD_WAYLAND_SHM | ||
102 | SUBDIRS += ../modules/engines/wayland_shm/ | ||
103 | EVAS_STATIC_MODULE += ../modules/engines/wayland_shm/libevas_engine_wayland_shm.la | ||
104 | EVAS_STATIC_LIBADD += @evas_engine_wayland_shm_libs@ | ||
105 | endif | ||
106 | if EVAS_STATIC_BUILD_BMP | ||
107 | SUBDIRS += ../modules/loaders/bmp | ||
108 | EVAS_STATIC_MODULE += ../modules/loaders/bmp/libevas_loader_bmp.la | ||
109 | EVAS_STATIC_LIBADD += @evas_image_loader_bmp_libs@ | ||
110 | endif | ||
111 | if EVAS_STATIC_BUILD_EDB | ||
112 | SUBDIRS += ../modules/savers/edb ../modules/loaders/edb | ||
113 | EVAS_STATIC_MODULE += ../modules/savers/edb/libevas_saver_edb.la ../modules/loaders/edb/libevas_loader_edb.la | ||
114 | EVAS_STATIC_LIBADD += @evas_image_loader_edb_libs@ | ||
115 | endif | ||
116 | if EVAS_STATIC_BUILD_EET | ||
117 | SUBDIRS += ../modules/savers/eet ../modules/loaders/eet | ||
118 | EVAS_STATIC_MODULE += ../modules/savers/eet/libevas_saver_eet.la ../modules/loaders/eet/libevas_loader_eet.la | ||
119 | EVAS_STATIC_LIBADD += @evas_image_loader_eet_libs@ | ||
120 | endif | ||
121 | if EVAS_STATIC_BUILD_GENERIC | ||
122 | SUBDIRS += ../modules/loaders/generic | ||
123 | EVAS_STATIC_MODULE += ../modules/loaders/generic/libevas_loader_generic.la | ||
124 | EVAS_STATIC_LIBADD += @evas_image_loader_generic_libs@ | ||
125 | endif | ||
126 | if EVAS_STATIC_BUILD_GIF | ||
127 | SUBDIRS += ../modules/loaders/gif | ||
128 | EVAS_STATIC_MODULE += ../modules/loaders/gif/libevas_loader_gif.la | ||
129 | EVAS_STATIC_LIBADD += @evas_image_loader_gif_libs@ | ||
130 | endif | ||
131 | if EVAS_STATIC_BUILD_ICO | ||
132 | SUBDIRS += ../modules/loaders/ico | ||
133 | EVAS_STATIC_MODULE += ../modules/loaders/ico/libevas_loader_ico.la | ||
134 | EVAS_STATIC_LIBADD += @evas_image_loader_ico_libs@ | ||
135 | endif | ||
136 | if EVAS_STATIC_BUILD_JPEG | ||
137 | SUBDIRS += ../modules/loaders/jpeg | ||
138 | EVAS_STATIC_MODULE += ../modules/loaders/jpeg/libevas_loader_jpeg.la | ||
139 | if BUILD_SAVER_JPEG | ||
140 | SUBDIRS += ../modules/savers/jpeg | ||
141 | EVAS_STATIC_MODULE += ../modules/savers/jpeg/libevas_saver_jpeg.la | ||
142 | endif | ||
143 | EVAS_STATIC_LIBADD += @evas_image_loader_jpeg_libs@ | ||
144 | endif | ||
145 | if EVAS_STATIC_BUILD_PMAPS | ||
146 | SUBDIRS += ../modules/loaders/pmaps | ||
147 | EVAS_STATIC_MODULE += ../modules/loaders/pmaps/libevas_loader_pmaps.la | ||
148 | EVAS_STATIC_LIBADD += @evas_image_loader_pmaps_libs@ | ||
149 | endif | ||
150 | if EVAS_STATIC_BUILD_PNG | ||
151 | SUBDIRS += ../modules/savers/png ../modules/loaders/png | ||
152 | EVAS_STATIC_MODULE += ../modules/savers/png/libevas_saver_png.la ../modules/loaders/png/libevas_loader_png.la | ||
153 | EVAS_STATIC_LIBADD += @evas_image_loader_png_libs@ | ||
154 | endif | ||
155 | if EVAS_STATIC_BUILD_PSD | ||
156 | SUBDIRS += ../modules/loaders/psd | ||
157 | EVAS_STATIC_MODULE += ../modules/loaders/psd/libevas_loader_psd.la | ||
158 | EVAS_STATIC_LIBADD += @evas_image_loader_psd_libs@ | ||
159 | endif | ||
160 | if EVAS_STATIC_BUILD_SVG | ||
161 | SUBDIRS += ../modules/loaders/svg | ||
162 | EVAS_STATIC_MODULE += ../modules/loaders/svg/libevas_loader_svg.la | ||
163 | EVAS_STATIC_LIBADD += @evas_image_loader_svg_libs@ | ||
164 | endif | ||
165 | if EVAS_STATIC_BUILD_TGA | ||
166 | SUBDIRS += ../modules/loaders/tga | ||
167 | EVAS_STATIC_MODULE += ../modules/loaders/tga/libevas_loader_tga.la | ||
168 | EVAS_STATIC_LIBADD += @evas_image_loader_tga_libs@ | ||
169 | endif | ||
170 | if EVAS_STATIC_BUILD_TIFF | ||
171 | SUBDIRS += ../modules/savers/tiff ../modules/loaders/tiff | ||
172 | EVAS_STATIC_MODULE += ../modules/savers/tiff/libevas_saver_tiff.la ../modules/loaders/tiff/libevas_loader_tiff.la | ||
173 | EVAS_STATIC_LIBADD += @evas_image_loader_tiff_libs@ | ||
174 | endif | ||
175 | if EVAS_STATIC_BUILD_WBMP | ||
176 | SUBDIRS += ../modules/loaders/wbmp | ||
177 | EVAS_STATIC_MODULE += ../modules/loaders/wbmp/libevas_loader_wbmp.la | ||
178 | EVAS_STATIC_LIBADD += @evas_image_loader_wbmp_libs@ | ||
179 | endif | ||
180 | if EVAS_STATIC_BUILD_XPM | ||
181 | SUBDIRS += ../modules/loaders/xpm | ||
182 | EVAS_STATIC_MODULE += ../modules/loaders/xpm/libevas_loader_xpm.la | ||
183 | EVAS_STATIC_LIBADD += @evas_image_loader_xpm_libs@ | ||
184 | endif | ||
185 | |||
186 | AM_CPPFLAGS = \ | ||
187 | -I. \ | ||
188 | -I$(top_srcdir)/src/lib \ | ||
189 | -I$(top_srcdir)/src/lib/include \ | ||
190 | -DPACKAGE_BIN_DIR=\"$(bindir)\" \ | ||
191 | -DPACKAGE_LIB_DIR=\"$(libdir)\" \ | ||
192 | -DPACKAGE_DATA_DIR=\"$(datadir)/$(PACKAGE)\" \ | ||
193 | @EINA_CFLAGS@ \ | ||
194 | @FREETYPE_CFLAGS@ \ | ||
195 | @FRIBIDI_CFLAGS@ \ | ||
196 | @HARFBUZZ_CFLAGS@ \ | ||
197 | @EET_CFLAGS@ \ | ||
198 | @FONTCONFIG_CFLAGS@ \ | ||
199 | @pthread_cflags@ \ | ||
200 | @PIXMAN_CFLAGS@ | ||
201 | |||
202 | lib_LTLIBRARIES = libevas.la | ||
203 | |||
204 | includes_HEADERS = Evas.h Evas_GL.h | ||
205 | includesdir = $(includedir)/evas-@VMAJ@ | ||
206 | |||
207 | libevas_la_SOURCES = main.c | ||
208 | |||
209 | if EVAS_CSERVE | ||
210 | |||
211 | libevas_cserve_la = cserve/libevas_cserve.la | ||
212 | |||
213 | endif | ||
214 | |||
215 | libevas_la_LIBADD = \ | ||
216 | canvas/libevas_canvas.la \ | ||
217 | file/libevas_file.la \ | ||
218 | cache/libevas_cache.la \ | ||
219 | $(libevas_cserve_la) \ | ||
220 | engines/common/libevas_engine_common.la \ | ||
221 | @FREETYPE_LIBS@ \ | ||
222 | @FRIBIDI_LIBS@ \ | ||
223 | @HARFBUZZ_LIBS@ \ | ||
224 | @EET_LIBS@ \ | ||
225 | @FONTCONFIG_LIBS@ \ | ||
226 | @pthread_libs@ \ | ||
227 | @EINA_LIBS@ \ | ||
228 | $(EVAS_STATIC_MODULE) \ | ||
229 | $(EVAS_STATIC_LIBADD) \ | ||
230 | @PIXMAN_LIBS@ \ | ||
231 | -lm | ||
232 | |||
233 | libevas_la_DEPENDENCIES = \ | ||
234 | canvas/libevas_canvas.la \ | ||
235 | file/libevas_file.la \ | ||
236 | cache/libevas_cache.la \ | ||
237 | $(libevas_cserve_la) \ | ||
238 | engines/common/libevas_engine_common.la \ | ||
239 | $(EVAS_STATIC_MODULE) | ||
240 | |||
241 | if BUILD_ENGINE_SOFTWARE_16 | ||
242 | |||
243 | libevas_la_LIBADD += engines/common_16/libevas_engine_common_16.la | ||
244 | libevas_la_DEPENDENCIES += engines/common_16/libevas_engine_common_16.la | ||
245 | |||
246 | endif | ||
247 | |||
248 | if BUILD_ENGINE_SOFTWARE_8 | ||
249 | |||
250 | libevas_la_LIBADD += engines/common_8/libevas_engine_common_8.la | ||
251 | libevas_la_DEPENDENCIES += engines/common_8/libevas_engine_common_8.la | ||
252 | |||
253 | endif | ||
254 | |||
255 | libevas_la_LDFLAGS = -no-undefined @lt_enable_auto_import@ -version-info @version_info@ @release_info@ | ||
256 | |||
257 | ### Evas_GL we are still using it in our code, so just don't install it. | ||
258 | EXTRA_DIST=Evas_GL.h | ||
259 | |||
260 | DIST_SUBDIRS = canvas cache cserve file engines include | ||