aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/libraries/evas/doc/Makefile.am
diff options
context:
space:
mode:
authorDavid Walter Seikel2013-01-13 17:29:19 +1000
committerDavid Walter Seikel2013-01-13 17:29:19 +1000
commit07274513e984f0b5544586c74508ccd16e7dcafa (patch)
treeb32ff2a9136fbc1a4a6a0ed1e4d79cde0f5f16d9 /libraries/evas/doc/Makefile.am
parentAdded Irrlicht 1.8, but without all the Windows binaries. (diff)
downloadSledjHamr-07274513e984f0b5544586c74508ccd16e7dcafa.zip
SledjHamr-07274513e984f0b5544586c74508ccd16e7dcafa.tar.gz
SledjHamr-07274513e984f0b5544586c74508ccd16e7dcafa.tar.bz2
SledjHamr-07274513e984f0b5544586c74508ccd16e7dcafa.tar.xz
Remove EFL, since it's been released now.
Diffstat (limited to 'libraries/evas/doc/Makefile.am')
-rw-r--r--libraries/evas/doc/Makefile.am40
1 files changed, 0 insertions, 40 deletions
diff --git a/libraries/evas/doc/Makefile.am b/libraries/evas/doc/Makefile.am
deleted file mode 100644
index 900c3d9..0000000
--- a/libraries/evas/doc/Makefile.am
+++ /dev/null
@@ -1,40 +0,0 @@
1MAINTAINERCLEANFILES = Makefile.in evas.dox
2
3.PHONY: doc
4
5PACKAGE_DOCNAME = $(PACKAGE_TARNAME)-$(PACKAGE_VERSION)-doc
6
7if EFL_BUILD_DOC
8
9doc-clean:
10 rm -rf html/ latex/ man/ xml/ $(PACKAGE_DOCNAME).tar*
11
12doc: all doc-clean
13 $(efl_doxygen)
14 cp $(srcdir)/img/* html/
15 cp $(srcdir)/img/* latex/
16 rm -rf $(PACKAGE_DOCNAME).tar*
17 mkdir -p $(PACKAGE_DOCNAME)/doc
18 cp -R html/ latex/ man/ $(PACKAGE_DOCNAME)/doc
19 tar cf $(PACKAGE_DOCNAME).tar $(PACKAGE_DOCNAME)/
20 bzip2 -9 $(PACKAGE_DOCNAME).tar
21 rm -rf $(PACKAGE_DOCNAME)/
22 mv $(PACKAGE_DOCNAME).tar.bz2 $(top_builddir)
23 @echo "Documentation Package: doc/$(PACKAGE_DOCNAME).tar.bz2"
24 @echo "Documentation HTML: doc/html"
25
26clean-local: doc-clean
27
28else
29
30doc:
31 @echo "Documentation not built. Run ./configure --help"
32
33endif
34
35EXTRA_DIST = $(srcdir)/Doxyfile.in \
36 $(wildcard $(srcdir)/img/*.*) \
37 $(srcdir)/e.css \
38 $(srcdir)/head.html \
39 $(srcdir)/foot.html \
40 $(srcdir)/evas.dox.in