aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/libraries/evas/configure.ac
diff options
context:
space:
mode:
authorDavid Walter Seikel2012-01-23 23:30:42 +1000
committerDavid Walter Seikel2012-01-23 23:30:42 +1000
commit825a3d837a33f226c879cd02ad15c3fba57e8b2c (patch)
tree75f57bd9c4253508d338dc79ba8e57a7abc42255 /libraries/evas/configure.ac
parentAdd ability to disable the test harness, or the Lua compile test. (diff)
downloadSledjHamr-825a3d837a33f226c879cd02ad15c3fba57e8b2c.zip
SledjHamr-825a3d837a33f226c879cd02ad15c3fba57e8b2c.tar.gz
SledjHamr-825a3d837a33f226c879cd02ad15c3fba57e8b2c.tar.bz2
SledjHamr-825a3d837a33f226c879cd02ad15c3fba57e8b2c.tar.xz
Update the EFL to what I'm actually using, coz I'm using some stuff not yet released.
Diffstat (limited to 'libraries/evas/configure.ac')
-rw-r--r--libraries/evas/configure.ac130
1 files changed, 117 insertions, 13 deletions
diff --git a/libraries/evas/configure.ac b/libraries/evas/configure.ac
index 0b56053..5424e31 100644
--- a/libraries/evas/configure.ac
+++ b/libraries/evas/configure.ac
@@ -2,11 +2,11 @@
2##--##--##--##--##--##--##--##--##--##--##--##--##--##--##--##--## 2##--##--##--##--##--##--##--##--##--##--##--##--##--##--##--##--##
3m4_define([v_maj], [1]) 3m4_define([v_maj], [1])
4m4_define([v_min], [1]) 4m4_define([v_min], [1])
5m4_define([v_mic], [0]) 5m4_define([v_mic], [99])
6m4_define([v_rev], m4_esyscmd([(svnversion "${SVN_REPO_PATH:-.}" | grep -v export || echo 0) | awk -F : '{printf("%s\n", $1);}' | tr -d ' :MSP\n'])) 6m4_define([v_rev], m4_esyscmd([(svnversion "${SVN_REPO_PATH:-.}" | grep -v '\(export\|Unversioned directory\)' || echo 0) | awk -F : '{printf("%s\n", $1);}' | tr -d ' :MSP\n']))
7m4_if(v_rev, [0], [m4_define([v_rev], m4_esyscmd([git log 2> /dev/null | (grep -m1 git-svn-id || echo 0) | sed -e 's/.*@\([0-9]*\).*/\1/' | tr -d '\n']))]) 7m4_if(v_rev, [0], [m4_define([v_rev], m4_esyscmd([git log 2> /dev/null | (grep -m1 git-svn-id || echo 0) | sed -e 's/.*@\([0-9]*\).*/\1/' | tr -d '\n']))])
8##-- When released, remove the dnl on the below line 8##-- When released, remove the dnl on the below line
9m4_undefine([v_rev]) 9dnl m4_undefine([v_rev])
10##-- When doing snapshots - change soname. remove dnl on below line 10##-- When doing snapshots - change soname. remove dnl on below line
11dnl m4_define([relname], [ver-pre-svn-07]) 11dnl m4_define([relname], [ver-pre-svn-07])
12dnl m4_define([v_rel], [-release relname]) 12dnl m4_define([v_rel], [-release relname])
@@ -112,6 +112,8 @@ want_evas_engine_direct3d="no"
112want_evas_engine_fb="no" 112want_evas_engine_fb="no"
113want_evas_engine_directfb="no" 113want_evas_engine_directfb="no"
114want_evas_engine_psl1ght="no" 114want_evas_engine_psl1ght="no"
115want_evas_engine_wayland_shm="no"
116want_evas_engine_wayland_egl="no"
115 117
116want_evas_image_loader_edb="yes" 118want_evas_image_loader_edb="yes"
117want_evas_image_loader_eet="yes" 119want_evas_image_loader_eet="yes"
@@ -158,6 +160,8 @@ case "$host_os" in
158 want_evas_engine_software_xcb="no" 160 want_evas_engine_software_xcb="no"
159 want_evas_engine_gl_xcb="no" 161 want_evas_engine_gl_xcb="no"
160 want_evas_engine_fb="auto" 162 want_evas_engine_fb="auto"
163 want_evas_engine_wayland_shm="auto"
164 want_evas_engine_wayland_egl="auto"
161### no - not ready/usable/complete 165### no - not ready/usable/complete
162# want_evas_engine_software_8_x11="auto" 166# want_evas_engine_software_8_x11="auto"
163# want_evas_engine_software_16_x11="auto" 167# want_evas_engine_software_16_x11="auto"
@@ -403,8 +407,8 @@ fi
403# Pixman 407# Pixman
404have_pixman="no" 408have_pixman="no"
405AC_ARG_ENABLE([pixman], 409AC_ARG_ENABLE([pixman],
406 AC_HELP_STRING([--disable-pixman], 410 AC_HELP_STRING([--enable-pixman],
407 [disable pixman for software rendering. @<:@default=enabled@:>@]), 411 [enable pixman for software rendering. @<:@default=enabled@:>@]),
408 [ 412 [
409 if test "x${enableval}" = "xyes" ; then 413 if test "x${enableval}" = "xyes" ; then
410 want_pixman="yes" 414 want_pixman="yes"
@@ -429,12 +433,74 @@ if test "x${want_pixman}" = "xyes" -o "x${want_pixman}" = "xauto" ; then
429 ]) 433 ])
430fi 434fi
431 435
436have_pixman_font="no"
437AC_ARG_ENABLE(pixman-font,
438 AC_HELP_STRING([--enable-pixman-font], [Allow pixman to render fonts]),
439 [
440 have_pixman_font="yes"
441 AC_DEFINE(PIXMAN_FONT, 1, [Allow pixman to render fonts])
442 ]
443)
444
445have_pixman_rect="no"
446AC_ARG_ENABLE(pixman-rect,
447 AC_HELP_STRING([--enable-pixman-rect], [Allow pixman to render rects]),
448 [
449 have_pixman_rect="yes"
450 AC_DEFINE(PIXMAN_RECT, 1, [Allow pixman to render rects])
451 ]
452)
453
454have_pixman_line="no"
455AC_ARG_ENABLE(pixman-line,
456 AC_HELP_STRING([--enable-pixman-line], [Allow pixman to render lines]),
457 [
458 have_pixman_line="yes"
459 AC_DEFINE(PIXMAN_LINE, 1, [Allow pixman to render lines])
460 ]
461)
462
463have_pixman_poly="no"
464AC_ARG_ENABLE(pixman-poly,
465 AC_HELP_STRING([--enable-pixman-poly], [Allow pixman to render polys]),
466 [
467 have_pixman_poly="yes"
468 AC_DEFINE(PIXMAN_POLY, 1, [Allow pixman to render polys])
469 ]
470)
471
472have_pixman_image="no"
473AC_ARG_ENABLE(pixman-image,
474 AC_HELP_STRING([--enable-pixman-image], [Allow pixman to render images]),
475 [
476 have_pixman_image="yes"
477 AC_DEFINE(PIXMAN_IMAGE, 1, [Allow pixman to render images])
478 ]
479)
480
481have_pixman_image_scale_sample="no"
482AC_ARG_ENABLE(pixman-image-scale-sample,
483 AC_HELP_STRING([--enable-pixman-image-scale-sample], [Allow pixman to render sampled scaled images]),
484 [
485 have_pixman_image_scale_sample="yes"
486 AC_DEFINE(PIXMAN_IMAGE_SCALE_SAMPLE, 1, [Allow pixman to render image sampled scaling])
487 ]
488)
489
490have_tile_rotate="no"
491AC_ARG_ENABLE(tile-rotate,
492 AC_HELP_STRING([--enable-tile-rotate], [Enable tiled rotate algorithm]),
493 [
494 have_tile_rotate="yes"
495 AC_DEFINE(TILE_ROTATE, 1, [Enable tiled rotate algorithm])
496 ]
497)
498
432### Checks for header files 499### Checks for header files
433AC_HEADER_STDC 500AC_HEADER_STDC
434AC_CHECK_HEADERS([unistd.h stdint.h sys/param.h netinet/in.h]) 501AC_CHECK_HEADERS([unistd.h stdint.h sys/param.h netinet/in.h sys/mman.h])
435EFL_CHECK_PATH_MAX 502EFL_CHECK_PATH_MAX
436 503
437
438### Checks for types 504### Checks for types
439AC_CHECK_TYPES([struct sigaction], [], [], 505AC_CHECK_TYPES([struct sigaction], [], [],
440 [[#include <signal.h>]]) 506 [[#include <signal.h>]])
@@ -704,6 +770,10 @@ EVAS_CHECK_ENGINE([software-16-wince], [${want_evas_engine_software_16_wince}],
704 770
705EVAS_CHECK_ENGINE([software-16-sdl], [${want_evas_engine_software_16_sdl}], [no], [Software SDL 16 bits]) 771EVAS_CHECK_ENGINE([software-16-sdl], [${want_evas_engine_software_16_sdl}], [no], [Software SDL 16 bits])
706 772
773EVAS_CHECK_ENGINE([wayland-shm], [${want_evas_engine_wayland_shm}], [no], [Wayland Shm])
774
775EVAS_CHECK_ENGINE([wayland-egl], [${want_evas_engine_wayland_egl}], [no], [Wayland Egl])
776
707# SDL primitive 777# SDL primitive
708sdl_primitive="no" 778sdl_primitive="no"
709 779
@@ -856,13 +926,15 @@ have_static_evas_engine_gl_common="no"
856if test "x$have_evas_engine_gl_xlib" = "xyes" \ 926if test "x$have_evas_engine_gl_xlib" = "xyes" \
857 || test "x$have_evas_engine_gl_xcb" = "xyes" \ 927 || test "x$have_evas_engine_gl_xcb" = "xyes" \
858 || test "x$have_evas_engine_gl_sdl" = "xyes" \ 928 || test "x$have_evas_engine_gl_sdl" = "xyes" \
859 || test "x$have_evas_engine_gl_cocoa" = "xyes"; then 929 || test "x$have_evas_engine_gl_cocoa" = "xyes" \
930 || test "x$have_evas_engine_wayland_egl" = "xyes"; then
860 have_evas_engine_gl_common="yes" 931 have_evas_engine_gl_common="yes"
861fi 932fi
862if test "x$have_evas_engine_gl_xlib" = "xstatic" \ 933if test "x$have_evas_engine_gl_xlib" = "xstatic" \
863 || test "x$have_evas_engine_gl_xcb" = "xstatic" \ 934 || test "x$have_evas_engine_gl_xcb" = "xstatic" \
864 || test "x$have_evas_engine_gl_sdl" = "xstatic" \ 935 || test "x$have_evas_engine_gl_sdl" = "xstatic" \
865 || test "x$have_evas_engine_gl_cocoa" = "xstatic"; then 936 || test "x$have_evas_engine_gl_cocoa" = "xstatic" \
937 || test "x$have_evas_engine_wayland_egl" = "xstatic"; then
866 have_evas_engine_gl_common="yes" 938 have_evas_engine_gl_common="yes"
867 have_static_evas_engine_gl_common="yes" 939 have_static_evas_engine_gl_common="yes"
868fi 940fi
@@ -1272,9 +1344,16 @@ AC_ARG_ENABLE(cpu-sse3,
1272 AS_HELP_STRING([--enable-cpu-sse3], [enable sse3 code]), 1344 AS_HELP_STRING([--enable-cpu-sse3], [enable sse3 code]),
1273 [ 1345 [
1274 if test "x$enableval" = "xyes" ; then 1346 if test "x$enableval" = "xyes" ; then
1275 AC_MSG_RESULT(yes) 1347 AC_CHECK_HEADER(immintrin.h,
1276 AC_DEFINE(BUILD_SSE3, 1, [Build SSE3 Code]) 1348 [
1277 build_cpu_sse3="yes" 1349 AC_MSG_RESULT(yes)
1350 AC_DEFINE(BUILD_SSE3, 1, [Build SSE3 Code])
1351 build_cpu_sse3="yes"
1352 ],
1353 [
1354 AC_MSG_RESULT(no)
1355 build_cpu_sse3="no"
1356 ])
1278 else 1357 else
1279 AC_MSG_RESULT(no) 1358 AC_MSG_RESULT(no)
1280 build_cpu_sse3="no" 1359 build_cpu_sse3="no"
@@ -1283,7 +1362,16 @@ AC_ARG_ENABLE(cpu-sse3,
1283 [ 1362 [
1284 AC_MSG_RESULT($build_cpu_sse3) 1363 AC_MSG_RESULT($build_cpu_sse3)
1285 if test "x$build_cpu_sse3" = "xyes" ; then 1364 if test "x$build_cpu_sse3" = "xyes" ; then
1286 AC_DEFINE(BUILD_SSE3, 1, [Build SSE3 Code]) 1365 AC_CHECK_HEADER(immintrin.h,
1366 [
1367 AC_MSG_RESULT(yes)
1368 AC_DEFINE(BUILD_SSE3, 1, [Build SSE3 Code])
1369 build_cpu_sse3="yes"
1370 ],
1371 [
1372 AC_MSG_RESULT(no)
1373 build_cpu_sse3="no"
1374 ])
1287 fi 1375 fi
1288 ] 1376 ]
1289) 1377)
@@ -1805,6 +1893,8 @@ evas-direct3d.pc
1805evas-software-16-wince.pc 1893evas-software-16-wince.pc
1806evas-software-sdl.pc 1894evas-software-sdl.pc
1807evas-psl1ght.pc 1895evas-psl1ght.pc
1896evas-wayland-shm.pc
1897evas-wayland-egl.pc
1808evas.pc 1898evas.pc
1809doc/evas.dox 1899doc/evas.dox
1810doc/Makefile 1900doc/Makefile
@@ -1849,6 +1939,8 @@ src/modules/engines/software_16/Makefile
1849src/modules/engines/software_16_x11/Makefile 1939src/modules/engines/software_16_x11/Makefile
1850src/modules/engines/software_16_ddraw/Makefile 1940src/modules/engines/software_16_ddraw/Makefile
1851src/modules/engines/software_16_sdl/Makefile 1941src/modules/engines/software_16_sdl/Makefile
1942src/modules/engines/wayland_shm/Makefile
1943src/modules/engines/wayland_egl/Makefile
1852src/modules/loaders/Makefile 1944src/modules/loaders/Makefile
1853src/modules/loaders/edb/Makefile 1945src/modules/loaders/edb/Makefile
1854src/modules/loaders/eet/Makefile 1946src/modules/loaders/eet/Makefile
@@ -1945,6 +2037,8 @@ echo " Software 16bit X11.........: $have_evas_engine_software_16_x11"
1945echo " Software 16bit Directdraw..: $have_evas_engine_software_16_ddraw" 2037echo " Software 16bit Directdraw..: $have_evas_engine_software_16_ddraw"
1946echo " Software 16bit WinCE.......: $have_evas_engine_software_16_wince" 2038echo " Software 16bit WinCE.......: $have_evas_engine_software_16_wince"
1947echo " Software 16bit SDL.........: $have_evas_engine_software_16_sdl (primitive: $sdl_primitive)" 2039echo " Software 16bit SDL.........: $have_evas_engine_software_16_sdl (primitive: $sdl_primitive)"
2040echo " Wayland Shm................: $have_evas_engine_wayland_shm"
2041echo " Wayland Egl................: $have_evas_engine_wayland_egl"
1948echo 2042echo
1949echo "Image Loaders:" 2043echo "Image Loaders:"
1950echo " BMP.....................: $have_evas_image_loader_bmp" 2044echo " BMP.....................: $have_evas_image_loader_bmp"
@@ -2002,6 +2096,16 @@ echo
2002echo " Word Cache..............: $want_word_cache" 2096echo " Word Cache..............: $want_word_cache"
2003echo " Metric Cache............: $want_metric_cache" 2097echo " Metric Cache............: $want_metric_cache"
2004echo 2098echo
2099echo " Pixman..................: $have_pixman"
2100echo " Pixman Fonts............: $have_pixman_font"
2101echo " Pixman Rects............: $have_pixman_rect"
2102echo " Pixman Lines............: $have_pixman_line"
2103echo " Pixman Polygons.........: $have_pixman_poly"
2104echo " Pixman Images...........: $have_pixman_image"
2105echo " Pixman Image ScaleSample: $have_pixman_image_scale_sample"
2106echo
2107echo " Tiled 32BPP rotate......: $have_tile_rotate"
2108echo
2005echo "ARGB Software Engine Options:" 2109echo "ARGB Software Engine Options:"
2006echo " Sampling Scaler.........: $scaler_sample" 2110echo " Sampling Scaler.........: $scaler_sample"
2007echo " Smooth Scaler...........: $scaler_smooth" 2111echo " Smooth Scaler...........: $scaler_smooth"