aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/libraries/evas/Makefile.am
diff options
context:
space:
mode:
authorDavid Walter Seikel2012-01-04 18:41:13 +1000
committerDavid Walter Seikel2012-01-04 18:41:13 +1000
commitdd7595a3475407a7fa96a97393bae8c5220e8762 (patch)
treee341e911d7eb911a51684a7412ef7f7c7605d28e /libraries/evas/Makefile.am
parentAdd the skeleton. (diff)
downloadSledjHamr-dd7595a3475407a7fa96a97393bae8c5220e8762.zip
SledjHamr-dd7595a3475407a7fa96a97393bae8c5220e8762.tar.gz
SledjHamr-dd7595a3475407a7fa96a97393bae8c5220e8762.tar.bz2
SledjHamr-dd7595a3475407a7fa96a97393bae8c5220e8762.tar.xz
Add the base Enlightenment Foundation Libraries - eina, eet, evas, ecore, embryo, and edje.
Note that embryo wont be used, but I'm not sure yet if you can build edje without it.
Diffstat (limited to 'libraries/evas/Makefile.am')
-rw-r--r--libraries/evas/Makefile.am183
1 files changed, 183 insertions, 0 deletions
diff --git a/libraries/evas/Makefile.am b/libraries/evas/Makefile.am
new file mode 100644
index 0000000..665f988
--- /dev/null
+++ b/libraries/evas/Makefile.am
@@ -0,0 +1,183 @@
1ACLOCAL_AMFLAGS = -I m4
2
3SUBDIRS = src doc
4
5MAINTAINERCLEANFILES = \
6Makefile.in \
7aclocal.m4 \
8config.guess \
9config.h.in \
10config.h.in~ \
11config.sub \
12configure \
13depcomp \
14install-sh \
15ltmain.sh \
16missing \
17$(PACKAGE_TARNAME)-$(PACKAGE_VERSION).tar.gz \
18$(PACKAGE_TARNAME)-$(PACKAGE_VERSION).tar.bz2 \
19$(PACKAGE_TARNAME)-$(PACKAGE_VERSION)-doc.tar.bz2 \
20m4/libtool.m4 \
21m4/lt~obsolete.m4 \
22m4/ltoptions.m4 \
23m4/ltsugar.m4 \
24m4/ltversion.m4
25
26bin_SCRIPTS =
27
28EXTRA_DIST = \
29AUTHORS \
30COPYING \
31autogen.sh \
32evas.pc.in \
33evas-directfb.pc.in \
34evas-fb.pc.in \
35evas-opengl-x11.pc.in \
36evas-opengl-sdl.pc.in \
37evas-software-buffer.pc.in \
38evas-software-x11.pc.in \
39evas-software-16-x11.pc.in \
40evas-software-8-x11.pc.in \
41evas-software-gdi.pc.in \
42evas-software-ddraw.pc.in \
43evas-software-16-ddraw.pc.in \
44evas-direct3d.pc.in \
45evas-software-16-wince.pc.in \
46evas-software-sdl.pc.in \
47evas-psl1ght.pc.in \
48evas.spec.in \
49evas.spec \
50m4/efl_attribute.m4 \
51m4/efl_coverage.m4 \
52m4/efl_doxygen.m4 \
53m4/efl_fnmatch.m4 \
54m4/efl_path_max.m4 \
55m4/efl_pthread.m4 \
56m4/efl_tests.m4 \
57m4/evas_check_engine.m4 \
58m4/evas_check_loader.m4 \
59m4/evas_converter.m4 \
60m4/evas_dither.m4 \
61m4/evas_scaler.m4
62
63pkgconfigdir = $(libdir)/pkgconfig
64pkgconfig_DATA = evas.pc
65
66if BUILD_ENGINE_SOFTWARE_X11
67pkgconfig_DATA += evas-software-x11.pc
68endif
69
70if BUILD_ENGINE_SOFTWARE_16_X11
71pkgconfig_DATA += evas-software-16-x11.pc
72endif
73
74if BUILD_ENGINE_SOFTWARE_8_X11
75pkgconfig_DATA += evas-software-8-x11.pc
76endif
77
78if BUILD_ENGINE_DIRECTFB
79pkgconfig_DATA += evas-directfb.pc
80endif
81
82if BUILD_ENGINE_FB
83pkgconfig_DATA += evas-fb.pc
84endif
85
86if BUILD_ENGINE_BUFFER
87pkgconfig_DATA += evas-software-buffer.pc
88endif
89
90if BUILD_ENGINE_GL_X11
91pkgconfig_DATA += evas-opengl-x11.pc
92endif
93
94if BUILD_ENGINE_GL_SDL
95pkgconfig_DATA += evas-opengl-sdl.pc
96endif
97
98if BUILD_ENGINE_GL_COCOA
99pkgconfig_DATA += evas-opengl-cocoa.pc
100endif
101
102if BUILD_ENGINE_SOFTWARE_GDI
103pkgconfig_DATA += evas-software-gdi.pc
104endif
105
106if BUILD_ENGINE_SOFTWARE_DDRAW
107pkgconfig_DATA += evas-software-ddraw.pc
108endif
109
110if BUILD_ENGINE_SOFTWARE_16_DDRAW
111pkgconfig_DATA += evas-software-16-ddraw.pc
112endif
113
114if BUILD_ENGINE_DIRECT3D
115pkgconfig_DATA += evas-direct3d.pc
116endif
117
118if BUILD_ENGINE_SOFTWARE_16_WINCE
119pkgconfig_DATA += evas-software-16-wince.pc
120endif
121
122if BUILD_ENGINE_SOFTWARE_SDL
123pkgconfig_DATA += evas-software-sdl.pc
124endif
125
126if BUILD_ENGINE_PSL1GHT
127pkgconfig_DATA += evas-psl1ght.pc
128endif
129
130.PHONY: doc coverage
131
132doc:
133 @echo "entering doc/"
134 $(MAKE) -C doc doc
135
136# Unit tests
137
138if EFL_ENABLE_TESTS
139
140check-local:
141 @./src/tests/evas_suite
142
143else
144
145check-local:
146 @echo "reconfigure with --enable-tests"
147
148endif
149
150# Coverage report
151
152if EFL_ENABLE_COVERAGE
153lcov-reset:
154 @rm -rf coverage
155 @find . -name "*.gcda" -exec rm {} \;
156 @lcov --directory . --zerocounters
157
158lcov-report:
159 @mkdir coverage
160 @lcov --compat-libtool --directory $(top_srcdir)/src --capture --output-file coverage/coverage.info
161 @lcov -l coverage/coverage.info |grep "\\.h" |cut -d " " -f 2 > coverage/remove
162 @lcov -r coverage/coverage.info `cat coverage/remove` > coverage/coverage.cleaned.info
163 @rm coverage/remove
164 @mv coverage/coverage.cleaned.info coverage/coverage.info
165 @genhtml -t "$(PACKAGE_STRING)" -o coverage coverage/coverage.info
166
167coverage:
168 @make lcov-reset
169 @make check
170 @make lcov-report
171else
172lcov-reset:
173 @echo "reconfigure with --enable-coverage"
174
175lcov-report:
176 @echo "reconfigure with --enable-coverage"
177
178coverage:
179 @echo "reconfigure with --enable-tests --enable-coverage"
180endif
181
182maintainer-clean-local:
183 rm -rf coverage