aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/libraries/evas/Makefile.am
diff options
context:
space:
mode:
authorDavid Walter Seikel2013-01-13 17:29:19 +1000
committerDavid Walter Seikel2013-01-13 17:29:19 +1000
commit07274513e984f0b5544586c74508ccd16e7dcafa (patch)
treeb32ff2a9136fbc1a4a6a0ed1e4d79cde0f5f16d9 /libraries/evas/Makefile.am
parentAdded Irrlicht 1.8, but without all the Windows binaries. (diff)
downloadSledjHamr-07274513e984f0b5544586c74508ccd16e7dcafa.zip
SledjHamr-07274513e984f0b5544586c74508ccd16e7dcafa.tar.gz
SledjHamr-07274513e984f0b5544586c74508ccd16e7dcafa.tar.bz2
SledjHamr-07274513e984f0b5544586c74508ccd16e7dcafa.tar.xz
Remove EFL, since it's been released now.
Diffstat (limited to '')
-rw-r--r--libraries/evas/Makefile.am191
1 files changed, 0 insertions, 191 deletions
diff --git a/libraries/evas/Makefile.am b/libraries/evas/Makefile.am
deleted file mode 100644
index ee73e82..0000000
--- a/libraries/evas/Makefile.am
+++ /dev/null
@@ -1,191 +0,0 @@
1ACLOCAL_AMFLAGS = -I m4
2
3SUBDIRS = src doc
4
5MAINTAINERCLEANFILES = \
6Makefile.in \
7aclocal.m4 \
8config.guess \
9config.h.in \
10config.h.in~ \
11config.sub \
12configure \
13depcomp \
14install-sh \
15ltmain.sh \
16missing \
17$(PACKAGE_TARNAME)-$(PACKAGE_VERSION).tar.gz \
18$(PACKAGE_TARNAME)-$(PACKAGE_VERSION).tar.bz2 \
19$(PACKAGE_TARNAME)-$(PACKAGE_VERSION)-doc.tar.bz2 \
20m4/libtool.m4 \
21m4/lt~obsolete.m4 \
22m4/ltoptions.m4 \
23m4/ltsugar.m4 \
24m4/ltversion.m4
25
26bin_SCRIPTS =
27
28EXTRA_DIST = \
29AUTHORS \
30COPYING \
31autogen.sh \
32evas.pc.in \
33evas-directfb.pc.in \
34evas-fb.pc.in \
35evas-opengl-x11.pc.in \
36evas-opengl-sdl.pc.in \
37evas-software-buffer.pc.in \
38evas-software-x11.pc.in \
39evas-software-16-x11.pc.in \
40evas-software-8-x11.pc.in \
41evas-software-gdi.pc.in \
42evas-software-ddraw.pc.in \
43evas-software-16-ddraw.pc.in \
44evas-direct3d.pc.in \
45evas-software-16-wince.pc.in \
46evas-psl1ght.pc.in \
47evas-wayland-shm.pc.in \
48evas-wayland-egl.pc.in \
49evas.spec.in \
50evas.spec \
51m4/efl_attribute.m4 \
52m4/efl_coverage.m4 \
53m4/efl_doxygen.m4 \
54m4/efl_fnmatch.m4 \
55m4/efl_path_max.m4 \
56m4/efl_pthread.m4 \
57m4/efl_tests.m4 \
58m4/evas_check_engine.m4 \
59m4/evas_check_loader.m4 \
60m4/evas_converter.m4 \
61m4/evas_dither.m4 \
62m4/evas_scaler.m4
63
64pkgconfigdir = $(libdir)/pkgconfig
65pkgconfig_DATA = evas.pc
66
67if BUILD_ENGINE_SOFTWARE_X11
68pkgconfig_DATA += evas-software-x11.pc
69endif
70
71if BUILD_ENGINE_SOFTWARE_16_X11
72pkgconfig_DATA += evas-software-16-x11.pc
73endif
74
75if BUILD_ENGINE_SOFTWARE_8_X11
76pkgconfig_DATA += evas-software-8-x11.pc
77endif
78
79if BUILD_ENGINE_DIRECTFB
80pkgconfig_DATA += evas-directfb.pc
81endif
82
83if BUILD_ENGINE_FB
84pkgconfig_DATA += evas-fb.pc
85endif
86
87if BUILD_ENGINE_BUFFER
88pkgconfig_DATA += evas-software-buffer.pc
89endif
90
91if BUILD_ENGINE_GL_X11
92pkgconfig_DATA += evas-opengl-x11.pc
93endif
94
95if BUILD_ENGINE_GL_SDL
96pkgconfig_DATA += evas-opengl-sdl.pc
97endif
98
99if BUILD_ENGINE_GL_COCOA
100pkgconfig_DATA += evas-opengl-cocoa.pc
101endif
102
103if BUILD_ENGINE_SOFTWARE_GDI
104pkgconfig_DATA += evas-software-gdi.pc
105endif
106
107if BUILD_ENGINE_SOFTWARE_DDRAW
108pkgconfig_DATA += evas-software-ddraw.pc
109endif
110
111if BUILD_ENGINE_SOFTWARE_16_DDRAW
112pkgconfig_DATA += evas-software-16-ddraw.pc
113endif
114
115if BUILD_ENGINE_DIRECT3D
116pkgconfig_DATA += evas-direct3d.pc
117endif
118
119if BUILD_ENGINE_SOFTWARE_16_WINCE
120pkgconfig_DATA += evas-software-16-wince.pc
121endif
122
123if BUILD_ENGINE_SOFTWARE_16_SDL
124pkgconfig_DATA += evas-software-sdl.pc
125endif
126
127if BUILD_ENGINE_PSL1GHT
128pkgconfig_DATA += evas-psl1ght.pc
129endif
130
131if BUILD_ENGINE_WAYLAND_SHM
132pkgconfig_DATA += evas-wayland-shm.pc
133endif
134
135if BUILD_ENGINE_WAYLAND_EGL
136pkgconfig_DATA += evas-wayland-egl.pc
137endif
138
139.PHONY: doc coverage
140
141doc:
142 @echo "entering doc/"
143 $(MAKE) -C doc doc
144
145# Unit tests
146
147if EFL_ENABLE_TESTS
148
149check-local:
150 @./src/tests/evas_suite
151
152else
153
154check-local:
155 @echo "reconfigure with --enable-tests"
156
157endif
158
159# Coverage report
160
161if EFL_ENABLE_COVERAGE
162lcov-reset:
163 @rm -rf $(top_builddir)/coverage
164 @find $(top_builddir) -name "*.gcda" -delete
165 @lcov --zerocounters --directory $(top_builddir)
166
167lcov-report:
168 @mkdir $(top_builddir)/coverage
169 lcov --capture --compat-libtool --output-file $(top_builddir)/coverage/coverage.info --directory $(top_builddir)
170 lcov --remove $(top_builddir)/coverage/coverage.info '*.h' --output-file $(top_builddir)/coverage/coverage.cleaned.info
171 genhtml -t "$(PACKAGE_STRING)" -o $(top_builddir)/coverage/html $(top_builddir)/coverage/coverage.cleaned.info
172 @echo "Coverage Report at $(top_builddir)/coverage/html"
173
174
175coverage:
176 @$(MAKE) lcov-reset
177 @$(MAKE) check
178 @$(MAKE) lcov-report
179else
180lcov-reset:
181 @echo "reconfigure with --enable-coverage"
182
183lcov-report:
184 @echo "reconfigure with --enable-coverage"
185
186coverage:
187 @echo "reconfigure with --enable-tests --enable-coverage"
188endif
189
190maintainer-clean-local:
191 rm -rf coverage