diff options
author | David Walter Seikel | 2012-01-04 18:41:13 +1000 |
---|---|---|
committer | David Walter Seikel | 2012-01-04 18:41:13 +1000 |
commit | dd7595a3475407a7fa96a97393bae8c5220e8762 (patch) | |
tree | e341e911d7eb911a51684a7412ef7f7c7605d28e /libraries/embryo/src/bin/Makefile.am | |
parent | Add the skeleton. (diff) | |
download | SledjHamr-dd7595a3475407a7fa96a97393bae8c5220e8762.zip SledjHamr-dd7595a3475407a7fa96a97393bae8c5220e8762.tar.gz SledjHamr-dd7595a3475407a7fa96a97393bae8c5220e8762.tar.bz2 SledjHamr-dd7595a3475407a7fa96a97393bae8c5220e8762.tar.xz |
Add the base Enlightenment Foundation Libraries - eina, eet, evas, ecore, embryo, and edje.
Note that embryo wont be used, but I'm not sure yet if you can build edje without it.
Diffstat (limited to 'libraries/embryo/src/bin/Makefile.am')
-rw-r--r-- | libraries/embryo/src/bin/Makefile.am | 40 |
1 files changed, 40 insertions, 0 deletions
diff --git a/libraries/embryo/src/bin/Makefile.am b/libraries/embryo/src/bin/Makefile.am new file mode 100644 index 0000000..09f6ffd --- /dev/null +++ b/libraries/embryo/src/bin/Makefile.am | |||
@@ -0,0 +1,40 @@ | |||
1 | |||
2 | MAINTAINERCLEANFILES = Makefile.in | ||
3 | |||
4 | AM_CPPFLAGS = \ | ||
5 | -I. \ | ||
6 | -I$(top_srcdir)/src/lib \ | ||
7 | -I$(top_srcdir) \ | ||
8 | -I$(top_builddir) \ | ||
9 | -DPACKAGE_BIN_DIR=\"$(bindir)\" \ | ||
10 | -DPACKAGE_LIB_DIR=\"$(libdir)\" \ | ||
11 | -DPACKAGE_DATA_DIR=\"$(datadir)/$(PACKAGE)\" \ | ||
12 | @EINA_CFLAGS@ \ | ||
13 | @EVIL_CFLAGS@ | ||
14 | |||
15 | bin_PROGRAMS = @EMBRYO_CC_PRG@ | ||
16 | EXTRA_PROGRAMS = embryo_cc | ||
17 | |||
18 | embryo_cc_SOURCES = \ | ||
19 | embryo_cc_amx.h \ | ||
20 | embryo_cc_sc.h \ | ||
21 | embryo_cc_sc1.c \ | ||
22 | embryo_cc_sc2.c \ | ||
23 | embryo_cc_sc3.c \ | ||
24 | embryo_cc_sc4.c \ | ||
25 | embryo_cc_sc5.c \ | ||
26 | embryo_cc_sc6.c \ | ||
27 | embryo_cc_sc7.c \ | ||
28 | embryo_cc_scexpand.c \ | ||
29 | embryo_cc_sclist.c \ | ||
30 | embryo_cc_scvars.c \ | ||
31 | embryo_cc_prefix.c \ | ||
32 | embryo_cc_prefix.h | ||
33 | |||
34 | embryo_cc_CFLAGS = @EMBRYO_CFLAGS@ | ||
35 | embryo_cc_LDADD = $(top_builddir)/src/lib/libembryo.la @EVIL_LIBS@ @EINA_LIBS@ -lm | ||
36 | embryo_cc_LDFLAGS = @lt_enable_auto_import@ | ||
37 | |||
38 | EXTRA_DIST = \ | ||
39 | embryo_cc_sc5.scp \ | ||
40 | embryo_cc_sc7.scp | ||