aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/libraries/embryo/embryo.spec
diff options
context:
space:
mode:
authorDavid Walter Seikel2012-01-04 18:41:13 +1000
committerDavid Walter Seikel2012-01-04 18:41:13 +1000
commitdd7595a3475407a7fa96a97393bae8c5220e8762 (patch)
treee341e911d7eb911a51684a7412ef7f7c7605d28e /libraries/embryo/embryo.spec
parentAdd the skeleton. (diff)
downloadSledjHamr-dd7595a3475407a7fa96a97393bae8c5220e8762.zip
SledjHamr-dd7595a3475407a7fa96a97393bae8c5220e8762.tar.gz
SledjHamr-dd7595a3475407a7fa96a97393bae8c5220e8762.tar.bz2
SledjHamr-dd7595a3475407a7fa96a97393bae8c5220e8762.tar.xz
Add the base Enlightenment Foundation Libraries - eina, eet, evas, ecore, embryo, and edje.
Note that embryo wont be used, but I'm not sure yet if you can build edje without it.
Diffstat (limited to 'libraries/embryo/embryo.spec')
-rw-r--r--libraries/embryo/embryo.spec77
1 files changed, 77 insertions, 0 deletions
diff --git a/libraries/embryo/embryo.spec b/libraries/embryo/embryo.spec
new file mode 100644
index 0000000..aba0f0e
--- /dev/null
+++ b/libraries/embryo/embryo.spec
@@ -0,0 +1,77 @@
1%define _missing_doc_files_terminate_build 0
2
3%{!?_rel:%{expand:%%global _rel 0.enl%{?dist}}}
4
5Summary: A small virtual machine engine (in a library) and bytecode compiler
6Name: embryo
7Version: 1.1.0
8Release: %{_rel}
9License: BSD
10Group: System Environment/Libraries
11Source: %{name}-%{version}.tar.gz
12Packager: %{?_packager:%{_packager}}%{!?_packager:Michael Jennings <mej@eterm.org>}
13Vendor: %{?_vendorinfo:%{_vendorinfo}}%{!?_vendorinfo:The Enlightenment Project (http://www.enlightenment.org/)}
14Distribution: %{?_distribution:%{_distribution}}%{!?_distribution:%{_vendor}}
15URL: http://www.enlightenment.org/
16BuildRoot: %{_tmppath}/%{name}-%{version}-root
17
18%description
19Embryo is a tiny library designed as a virtual machine to interpret a
20limited set of small compiled programs.
21
22%package devel
23Summary: Embryo headers, static libraries, documentation and test programs
24Group: System Environment/Libraries
25Requires: %{name} = %{version}
26
27%description devel
28Headers, static libraries, test programs and documentation for Embryo
29
30%package bin
31Summary: Embryo bytecode compiler and needed data files
32Group: System Environment/Libraries
33Requires: %{name} = %{version}
34
35%description bin
36The embryo bytecode compiler and its files
37
38%prep
39%setup -q
40
41%build
42%{configure} --prefix=%{_prefix}
43### use this if you have build problems
44#./configure --prefix=%{_prefix}
45%{__make} %{?_smp_mflags} %{?mflags}
46
47%install
48%{__make} %{?mflags_install} DESTDIR=$RPM_BUILD_ROOT install
49
50%clean
51test "x$RPM_BUILD_ROOT" != "x/" && rm -rf $RPM_BUILD_ROOT
52
53%post
54/sbin/ldconfig
55
56%postun
57/sbin/ldconfig
58
59%files
60%defattr(-, root, root)
61%doc AUTHORS COPYING* README
62%{_libdir}/*.so.*
63
64%files bin
65%defattr(-, root, root)
66%attr(755,root,root) %{_bindir}/embryo_cc
67%{_datadir}/embryo/include
68
69%files devel
70%defattr(-, root, root)
71%{_libdir}/*.so
72%{_libdir}/*.la
73%{_libdir}/*.a
74%{_libdir}/pkgconfig/*
75%{_includedir}/embryo-1/*.h
76
77%changelog