diff options
author | David Walter Seikel | 2012-01-23 23:30:42 +1000 |
---|---|---|
committer | David Walter Seikel | 2012-01-23 23:30:42 +1000 |
commit | 825a3d837a33f226c879cd02ad15c3fba57e8b2c (patch) | |
tree | 75f57bd9c4253508d338dc79ba8e57a7abc42255 /libraries/eina/src/tests/Makefile.am | |
parent | Add ability to disable the test harness, or the Lua compile test. (diff) | |
download | SledjHamr-825a3d837a33f226c879cd02ad15c3fba57e8b2c.zip SledjHamr-825a3d837a33f226c879cd02ad15c3fba57e8b2c.tar.gz SledjHamr-825a3d837a33f226c879cd02ad15c3fba57e8b2c.tar.bz2 SledjHamr-825a3d837a33f226c879cd02ad15c3fba57e8b2c.tar.xz |
Update the EFL to what I'm actually using, coz I'm using some stuff not yet released.
Diffstat (limited to '')
-rw-r--r-- | libraries/eina/src/tests/Makefile.am | 9 |
1 files changed, 7 insertions, 2 deletions
diff --git a/libraries/eina/src/tests/Makefile.am b/libraries/eina/src/tests/Makefile.am index a413e6e..7e05ba9 100644 --- a/libraries/eina/src/tests/Makefile.am +++ b/libraries/eina/src/tests/Makefile.am | |||
@@ -28,7 +28,7 @@ endif | |||
28 | 28 | ||
29 | if EFL_ENABLE_TESTS | 29 | if EFL_ENABLE_TESTS |
30 | 30 | ||
31 | check_PROGRAMS = eina_suite | 31 | check_PROGRAMS = eina_suite cxx_compile_test |
32 | 32 | ||
33 | eina_suite_SOURCES = \ | 33 | eina_suite_SOURCES = \ |
34 | eina_suite.c \ | 34 | eina_suite.c \ |
@@ -38,6 +38,7 @@ eina_test_ustringshare.c\ | |||
38 | eina_test_ustr.c \ | 38 | eina_test_ustr.c \ |
39 | eina_test_binshare.c \ | 39 | eina_test_binshare.c \ |
40 | eina_test_binbuf.c \ | 40 | eina_test_binbuf.c \ |
41 | eina_test_inarray.c \ | ||
41 | eina_test_array.c \ | 42 | eina_test_array.c \ |
42 | eina_test_clist.c \ | 43 | eina_test_clist.c \ |
43 | eina_test_error.c \ | 44 | eina_test_error.c \ |
@@ -64,10 +65,14 @@ eina_test_tiler.c \ | |||
64 | eina_test_strbuf.c \ | 65 | eina_test_strbuf.c \ |
65 | eina_test_str.c \ | 66 | eina_test_str.c \ |
66 | eina_test_quadtree.c \ | 67 | eina_test_quadtree.c \ |
67 | eina_test_simple_xml_parser.c | 68 | eina_test_simple_xml_parser.c \ |
69 | eina_test_value.c | ||
68 | 70 | ||
69 | eina_suite_LDADD = @CHECK_LIBS@ $(top_builddir)/src/lib/libeina.la -lm | 71 | eina_suite_LDADD = @CHECK_LIBS@ $(top_builddir)/src/lib/libeina.la -lm |
70 | 72 | ||
73 | cxx_compile_test_SOURCES = cxx_compile_test.cxx | ||
74 | cxx_compile_test_LDADD = $(top_builddir)/src/lib/libeina.la | ||
75 | |||
71 | module_dummydir = $(libdir)/eina/test | 76 | module_dummydir = $(libdir)/eina/test |
72 | module_dummy_LTLIBRARIES = module_dummy.la | 77 | module_dummy_LTLIBRARIES = module_dummy.la |
73 | 78 | ||