aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/libraries/eina/Makefile.am
diff options
context:
space:
mode:
authorDavid Walter Seikel2013-01-13 17:29:19 +1000
committerDavid Walter Seikel2013-01-13 17:29:19 +1000
commit07274513e984f0b5544586c74508ccd16e7dcafa (patch)
treeb32ff2a9136fbc1a4a6a0ed1e4d79cde0f5f16d9 /libraries/eina/Makefile.am
parentAdded Irrlicht 1.8, but without all the Windows binaries. (diff)
downloadSledjHamr-07274513e984f0b5544586c74508ccd16e7dcafa.zip
SledjHamr-07274513e984f0b5544586c74508ccd16e7dcafa.tar.gz
SledjHamr-07274513e984f0b5544586c74508ccd16e7dcafa.tar.bz2
SledjHamr-07274513e984f0b5544586c74508ccd16e7dcafa.tar.xz
Remove EFL, since it's been released now.
Diffstat (limited to 'libraries/eina/Makefile.am')
-rw-r--r--libraries/eina/Makefile.am120
1 files changed, 0 insertions, 120 deletions
diff --git a/libraries/eina/Makefile.am b/libraries/eina/Makefile.am
deleted file mode 100644
index 501653c..0000000
--- a/libraries/eina/Makefile.am
+++ /dev/null
@@ -1,120 +0,0 @@
1## Process this file with automake to produce Makefile.in
2
3ACLOCAL_AMFLAGS = -I m4 -I m4/common -I m4/eina
4
5SUBDIRS = src doc
6
7MAINTAINERCLEANFILES = \
8Makefile.in \
9aclocal.m4 \
10config.guess \
11config.h.in \
12config.h.in~ \
13config.sub \
14configure \
15depcomp \
16install-sh \
17ltconfig \
18ltmain.sh \
19missing \
20$(PACKAGE_TARNAME)-$(PACKAGE_VERSION).tar.gz \
21$(PACKAGE_TARNAME)-$(PACKAGE_VERSION).tar.bz2 \
22$(PACKAGE_TARNAME)-$(PACKAGE_VERSION)-doc.tar.bz2 \
23m4/libtool.m4 \
24m4/lt~obsolete.m4 \
25m4/ltoptions.m4 \
26m4/ltsugar.m4 \
27m4/ltversion.m4
28
29pkgconfigdir = $(libdir)/pkgconfig
30pkgconfig_DATA = eina.pc
31
32EXTRA_DIST = \
33AUTHORS \
34COPYING \
35README \
36$(pkgconfig_DATA) \
37autogen.sh \
38eina.pc.in \
39eina.spec \
40eina.spec.in \
41m4/common/efl_attribute.m4 \
42m4/common/efl_benchmark.m4 \
43m4/common/efl_compiler_flag.m4 \
44m4/common/efl_coverage.m4 \
45m4/common/efl_cpu.m4 \
46m4/common/efl_doxygen.m4 \
47m4/common/efl_fnmatch.m4 \
48m4/common/efl_tests.m4 \
49m4/common/efl_threads.m4 \
50m4/common/efl_path_max.m4 \
51m4/eina/eina_bench.m4 \
52m4/eina/eina_check.m4
53
54.PHONY: doc coverage benchmark
55
56# Documentation
57
58doc:
59 @echo "entering doc/"
60 @cd doc && $(MAKE) doc
61
62# Unit tests
63
64if EFL_ENABLE_TESTS
65
66check-local:
67 @./src/tests/eina_suite
68
69else
70
71check-local:
72 @echo "reconfigure with --enable-tests"
73
74endif
75
76# Coverage report
77
78if EFL_ENABLE_COVERAGE
79lcov-reset:
80 @rm -rf $(top_builddir)/coverage
81 @find $(top_builddir) -name "*.gcda" -delete
82 @lcov --zerocounters --directory $(top_builddir)
83
84lcov-report:
85 @mkdir $(top_builddir)/coverage
86 lcov --capture --compat-libtool --output-file $(top_builddir)/coverage/coverage.info --directory $(top_builddir)
87 lcov --remove $(top_builddir)/coverage/coverage.info '*.h' --output-file $(top_builddir)/coverage/coverage.cleaned.info
88 genhtml -t "$(PACKAGE_STRING)" -o $(top_builddir)/coverage/html $(top_builddir)/coverage/coverage.cleaned.info
89 @echo "Coverage Report at $(top_builddir)/coverage/html"
90
91coverage:
92 @$(MAKE) lcov-reset
93 @$(MAKE) check
94 @$(MAKE) lcov-report
95else
96lcov-reset:
97 @echo "reconfigure with --enable-coverage"
98
99lcov-report:
100 @echo "reconfigure with --enable-coverage"
101
102coverage:
103 @echo "reconfigure with --enable-tests --enable-coverage"
104endif
105
106if EFL_ENABLE_BENCHMARK
107
108benchmark:
109 @cd src && $(MAKE) benchmark
110 @mkdir result || true
111 @cd result && ../src/tests/eina_bench `date +%F_%s`
112
113else
114
115benchmark:
116 @echo "reconfigure with --enable-benchmark"
117endif
118
119clean-local:
120 @rm -rf coverage benchmark