diff options
author | David Walter Seikel | 2013-01-13 17:29:19 +1000 |
---|---|---|
committer | David Walter Seikel | 2013-01-13 17:29:19 +1000 |
commit | 07274513e984f0b5544586c74508ccd16e7dcafa (patch) | |
tree | b32ff2a9136fbc1a4a6a0ed1e4d79cde0f5f16d9 /libraries/eina/Makefile.am | |
parent | Added Irrlicht 1.8, but without all the Windows binaries. (diff) | |
download | SledjHamr-07274513e984f0b5544586c74508ccd16e7dcafa.zip SledjHamr-07274513e984f0b5544586c74508ccd16e7dcafa.tar.gz SledjHamr-07274513e984f0b5544586c74508ccd16e7dcafa.tar.bz2 SledjHamr-07274513e984f0b5544586c74508ccd16e7dcafa.tar.xz |
Remove EFL, since it's been released now.
Diffstat (limited to '')
-rw-r--r-- | libraries/eina/Makefile.am | 120 |
1 files changed, 0 insertions, 120 deletions
diff --git a/libraries/eina/Makefile.am b/libraries/eina/Makefile.am deleted file mode 100644 index 501653c..0000000 --- a/libraries/eina/Makefile.am +++ /dev/null | |||
@@ -1,120 +0,0 @@ | |||
1 | ## Process this file with automake to produce Makefile.in | ||
2 | |||
3 | ACLOCAL_AMFLAGS = -I m4 -I m4/common -I m4/eina | ||
4 | |||
5 | SUBDIRS = src doc | ||
6 | |||
7 | MAINTAINERCLEANFILES = \ | ||
8 | Makefile.in \ | ||
9 | aclocal.m4 \ | ||
10 | config.guess \ | ||
11 | config.h.in \ | ||
12 | config.h.in~ \ | ||
13 | config.sub \ | ||
14 | configure \ | ||
15 | depcomp \ | ||
16 | install-sh \ | ||
17 | ltconfig \ | ||
18 | ltmain.sh \ | ||
19 | missing \ | ||
20 | $(PACKAGE_TARNAME)-$(PACKAGE_VERSION).tar.gz \ | ||
21 | $(PACKAGE_TARNAME)-$(PACKAGE_VERSION).tar.bz2 \ | ||
22 | $(PACKAGE_TARNAME)-$(PACKAGE_VERSION)-doc.tar.bz2 \ | ||
23 | m4/libtool.m4 \ | ||
24 | m4/lt~obsolete.m4 \ | ||
25 | m4/ltoptions.m4 \ | ||
26 | m4/ltsugar.m4 \ | ||
27 | m4/ltversion.m4 | ||
28 | |||
29 | pkgconfigdir = $(libdir)/pkgconfig | ||
30 | pkgconfig_DATA = eina.pc | ||
31 | |||
32 | EXTRA_DIST = \ | ||
33 | AUTHORS \ | ||
34 | COPYING \ | ||
35 | README \ | ||
36 | $(pkgconfig_DATA) \ | ||
37 | autogen.sh \ | ||
38 | eina.pc.in \ | ||
39 | eina.spec \ | ||
40 | eina.spec.in \ | ||
41 | m4/common/efl_attribute.m4 \ | ||
42 | m4/common/efl_benchmark.m4 \ | ||
43 | m4/common/efl_compiler_flag.m4 \ | ||
44 | m4/common/efl_coverage.m4 \ | ||
45 | m4/common/efl_cpu.m4 \ | ||
46 | m4/common/efl_doxygen.m4 \ | ||
47 | m4/common/efl_fnmatch.m4 \ | ||
48 | m4/common/efl_tests.m4 \ | ||
49 | m4/common/efl_threads.m4 \ | ||
50 | m4/common/efl_path_max.m4 \ | ||
51 | m4/eina/eina_bench.m4 \ | ||
52 | m4/eina/eina_check.m4 | ||
53 | |||
54 | .PHONY: doc coverage benchmark | ||
55 | |||
56 | # Documentation | ||
57 | |||
58 | doc: | ||
59 | @echo "entering doc/" | ||
60 | @cd doc && $(MAKE) doc | ||
61 | |||
62 | # Unit tests | ||
63 | |||
64 | if EFL_ENABLE_TESTS | ||
65 | |||
66 | check-local: | ||
67 | @./src/tests/eina_suite | ||
68 | |||
69 | else | ||
70 | |||
71 | check-local: | ||
72 | @echo "reconfigure with --enable-tests" | ||
73 | |||
74 | endif | ||
75 | |||
76 | # Coverage report | ||
77 | |||
78 | if EFL_ENABLE_COVERAGE | ||
79 | lcov-reset: | ||
80 | @rm -rf $(top_builddir)/coverage | ||
81 | @find $(top_builddir) -name "*.gcda" -delete | ||
82 | @lcov --zerocounters --directory $(top_builddir) | ||
83 | |||
84 | lcov-report: | ||
85 | @mkdir $(top_builddir)/coverage | ||
86 | lcov --capture --compat-libtool --output-file $(top_builddir)/coverage/coverage.info --directory $(top_builddir) | ||
87 | lcov --remove $(top_builddir)/coverage/coverage.info '*.h' --output-file $(top_builddir)/coverage/coverage.cleaned.info | ||
88 | genhtml -t "$(PACKAGE_STRING)" -o $(top_builddir)/coverage/html $(top_builddir)/coverage/coverage.cleaned.info | ||
89 | @echo "Coverage Report at $(top_builddir)/coverage/html" | ||
90 | |||
91 | coverage: | ||
92 | @$(MAKE) lcov-reset | ||
93 | @$(MAKE) check | ||
94 | @$(MAKE) lcov-report | ||
95 | else | ||
96 | lcov-reset: | ||
97 | @echo "reconfigure with --enable-coverage" | ||
98 | |||
99 | lcov-report: | ||
100 | @echo "reconfigure with --enable-coverage" | ||
101 | |||
102 | coverage: | ||
103 | @echo "reconfigure with --enable-tests --enable-coverage" | ||
104 | endif | ||
105 | |||
106 | if EFL_ENABLE_BENCHMARK | ||
107 | |||
108 | benchmark: | ||
109 | @cd src && $(MAKE) benchmark | ||
110 | @mkdir result || true | ||
111 | @cd result && ../src/tests/eina_bench `date +%F_%s` | ||
112 | |||
113 | else | ||
114 | |||
115 | benchmark: | ||
116 | @echo "reconfigure with --enable-benchmark" | ||
117 | endif | ||
118 | |||
119 | clean-local: | ||
120 | @rm -rf coverage benchmark | ||