diff options
author | David Walter Seikel | 2013-01-13 17:29:19 +1000 |
---|---|---|
committer | David Walter Seikel | 2013-01-13 17:29:19 +1000 |
commit | 07274513e984f0b5544586c74508ccd16e7dcafa (patch) | |
tree | b32ff2a9136fbc1a4a6a0ed1e4d79cde0f5f16d9 /libraries/eet/src/lib/Makefile.am | |
parent | Added Irrlicht 1.8, but without all the Windows binaries. (diff) | |
download | SledjHamr-07274513e984f0b5544586c74508ccd16e7dcafa.zip SledjHamr-07274513e984f0b5544586c74508ccd16e7dcafa.tar.gz SledjHamr-07274513e984f0b5544586c74508ccd16e7dcafa.tar.bz2 SledjHamr-07274513e984f0b5544586c74508ccd16e7dcafa.tar.xz |
Remove EFL, since it's been released now.
Diffstat (limited to 'libraries/eet/src/lib/Makefile.am')
-rw-r--r-- | libraries/eet/src/lib/Makefile.am | 163 |
1 files changed, 0 insertions, 163 deletions
diff --git a/libraries/eet/src/lib/Makefile.am b/libraries/eet/src/lib/Makefile.am deleted file mode 100644 index ae60168..0000000 --- a/libraries/eet/src/lib/Makefile.am +++ /dev/null | |||
@@ -1,163 +0,0 @@ | |||
1 | |||
2 | MAINTAINERCLEANFILES = Makefile.in | ||
3 | |||
4 | AM_CPPFLAGS = \ | ||
5 | -I. \ | ||
6 | -I$(top_srcdir)/src/lib \ | ||
7 | -I$(top_builddir)/src/lib \ | ||
8 | -DPACKAGE_BIN_DIR=\"$(bindir)\" \ | ||
9 | -DPACKAGE_LIB_DIR=\"$(libdir)\" \ | ||
10 | -DPACKAGE_DATA_DIR=\"$(datadir)/$(PACKAGE)\" \ | ||
11 | @EVIL_CFLAGS@ \ | ||
12 | @EINA_CFLAGS@ \ | ||
13 | @EET_CPPFLAGS@ \ | ||
14 | @EFL_EET_BUILD@ \ | ||
15 | @EFL_COVERAGE_CFLAGS@ \ | ||
16 | @OPENSSL_CFLAGS@ \ | ||
17 | @GNUTLS_CFLAGS@ | ||
18 | |||
19 | includes_HEADERS = Eet.h | ||
20 | includesdir = $(includedir)/eet-@VMAJ@ | ||
21 | |||
22 | lib_LTLIBRARIES = libeet.la | ||
23 | |||
24 | base_sources = \ | ||
25 | eet_alloc.c \ | ||
26 | eet_lib.c \ | ||
27 | eet_data.c \ | ||
28 | eet_image.c \ | ||
29 | eet_cipher.c \ | ||
30 | eet_dictionary.c \ | ||
31 | eet_node.c \ | ||
32 | eet_utils.c \ | ||
33 | eet_connection.c | ||
34 | |||
35 | if EET_AMALGAMATION | ||
36 | nodist_libeet_la_SOURCES = eet_amalgamation.c | ||
37 | |||
38 | eet_amalgamation.c: $(base_sources) Makefile | ||
39 | -rm -f eet_amalgamation.c | ||
40 | |||
41 | @echo "#ifdef HAVE_CONFIG_H" >> eet_amalgamation.c | ||
42 | @echo "# include \"config.h\"" >> eet_amalgamation.c | ||
43 | @echo "#endif" >> eet_amalgamation.c | ||
44 | |||
45 | @echo "#ifdef HAVE_ALLOCA_H" >> eet_amalgamation.c | ||
46 | @echo "# include <alloca.h>" >> eet_amalgamation.c | ||
47 | @echo "#elif defined __GNUC__" >> eet_amalgamation.c | ||
48 | @echo "# define alloca __builtin_alloca" >> eet_amalgamation.c | ||
49 | @echo "#elif defined _AIX" >> eet_amalgamation.c | ||
50 | @echo "# define alloca __alloca" >> eet_amalgamation.c | ||
51 | @echo "#elif defined _MSC_VER" >> eet_amalgamation.c | ||
52 | @echo "# include <malloc.h>" >> eet_amalgamation.c | ||
53 | @echo "# define alloca _alloca" >> eet_amalgamation.c | ||
54 | @echo "#else" >> eet_amalgamation.c | ||
55 | @echo "# include <stddef.h>" >> eet_amalgamation.c | ||
56 | @echo "# ifdef __cplusplus" >> eet_amalgamation.c | ||
57 | @echo "#extern \"C\"" >> eet_amalgamation.c | ||
58 | @echo "# endif" >> eet_amalgamation.c | ||
59 | @echo "#void *alloca (size_t);" >> eet_amalgamation.c | ||
60 | @echo "#endif" >> eet_amalgamation.c | ||
61 | |||
62 | @echo "#include <stdio.h>" >> eet_amalgamation.c | ||
63 | @echo "#include <string.h>" >> eet_amalgamation.c | ||
64 | @echo "#include <math.h>" >> eet_amalgamation.c | ||
65 | @echo "#include <ctype.h>" >> eet_amalgamation.c | ||
66 | @echo "#include <limits.h>" >> eet_amalgamation.c | ||
67 | @echo "#include <sys/types.h>" >> eet_amalgamation.c | ||
68 | @echo "#include <sys/stat.h>" >> eet_amalgamation.c | ||
69 | @echo "#ifdef HAVE_SIGNATURE" >> eet_amalgamation.c | ||
70 | @echo "# include <sys/mman.h>" >> eet_amalgamation.c | ||
71 | @echo "#endif" >> eet_amalgamation.c | ||
72 | @echo "#include <setjmp.h>" >> eet_amalgamation.c | ||
73 | @echo "#include <errno.h>" >> eet_amalgamation.c | ||
74 | @echo "#include <time.h>" >> eet_amalgamation.c | ||
75 | @echo "#include <fnmatch.h>" >> eet_amalgamation.c | ||
76 | @echo "#include <fcntl.h>" >> eet_amalgamation.c | ||
77 | |||
78 | @echo "#ifdef _WIN32" >> eet_amalgamation.c | ||
79 | @echo "# include <winsock2.h>" >> eet_amalgamation.c | ||
80 | @echo "#endif" >> eet_amalgamation.c | ||
81 | |||
82 | @echo "#ifndef _MSC_VER" >> eet_amalgamation.c | ||
83 | @echo "# include <unistd.h>" >> eet_amalgamation.c | ||
84 | @echo "#endif" >> eet_amalgamation.c | ||
85 | |||
86 | @echo "#ifdef HAVE_NETINET_IN_H" >> eet_amalgamation.c | ||
87 | @echo "# include <netinet/in.h>" >> eet_amalgamation.c | ||
88 | @echo "#endif" >> eet_amalgamation.c | ||
89 | |||
90 | @echo "#ifdef HAVE_GNUTLS" >> eet_amalgamation.c | ||
91 | @echo "# include <gnutls/gnutls.h>" >> eet_amalgamation.c | ||
92 | @echo "# include <gcrypt.h>" >> eet_amalgamation.c | ||
93 | @echo "#endif" >> eet_amalgamation.c | ||
94 | |||
95 | @echo "#ifdef HAVE_OPENSSL" >> eet_amalgamation.c | ||
96 | @echo "# include <openssl/err.h>" >> eet_amalgamation.c | ||
97 | @echo "# include <openssl/evp.h>" >> eet_amalgamation.c | ||
98 | @echo "# include <openssl/sha.h>" >> eet_amalgamation.c | ||
99 | @echo "#endif" >> eet_amalgamation.c | ||
100 | |||
101 | @echo "#ifdef HAVE_SIGNATURE" >> eet_amalgamation.c | ||
102 | @echo "# ifdef HAVE_GNUTLS" >> eet_amalgamation.c | ||
103 | @echo "# include <gnutls/gnutls.h>" >> eet_amalgamation.c | ||
104 | @echo "# include <gnutls/x509.h>" >> eet_amalgamation.c | ||
105 | @echo "# else" >> eet_amalgamation.c | ||
106 | @echo "# include <openssl/rsa.h>" >> eet_amalgamation.c | ||
107 | @echo "# include <openssl/objects.h>" >> eet_amalgamation.c | ||
108 | @echo "# include <openssl/err.h>" >> eet_amalgamation.c | ||
109 | @echo "# include <openssl/ssl.h>" >> eet_amalgamation.c | ||
110 | @echo "# include <openssl/dh.h>" >> eet_amalgamation.c | ||
111 | @echo "# include <openssl/dsa.h>" >> eet_amalgamation.c | ||
112 | @echo "# include <openssl/evp.h>" >> eet_amalgamation.c | ||
113 | @echo "# include <openssl/x509.h>" >> eet_amalgamation.c | ||
114 | @echo "# include <openssl/pem.h>" >> eet_amalgamation.c | ||
115 | @echo "# endif" >> eet_amalgamation.c | ||
116 | @echo "#endif" >> eet_amalgamation.c | ||
117 | |||
118 | @echo "#ifdef HAVE_CIPHER" >> eet_amalgamation.c | ||
119 | @echo "# ifdef HAVE_GNUTLS" >> eet_amalgamation.c | ||
120 | @echo "# include <gnutls/x509.h>" >> eet_amalgamation.c | ||
121 | @echo "# include <gcrypt.h>" >> eet_amalgamation.c | ||
122 | @echo "# else" >> eet_amalgamation.c | ||
123 | @echo "# include <openssl/evp.h>" >> eet_amalgamation.c | ||
124 | @echo "# include <openssl/hmac.h>" >> eet_amalgamation.c | ||
125 | @echo "# include <openssl/rand.h>" >> eet_amalgamation.c | ||
126 | @echo "# endif" >> eet_amalgamation.c | ||
127 | @echo "#endif" >> eet_amalgamation.c | ||
128 | |||
129 | @echo "#include <zlib.h>" >> eet_amalgamation.c | ||
130 | @echo "#include <jpeglib.h>" >> eet_amalgamation.c | ||
131 | |||
132 | @echo "#ifdef HAVE_EVIL" >> eet_amalgamation.c | ||
133 | @echo "# include <Evil.h>" >> eet_amalgamation.c | ||
134 | @echo "#endif" >> eet_amalgamation.c | ||
135 | |||
136 | @echo "#include <Eet.h>" >> eet_amalgamation.c | ||
137 | |||
138 | @echo "#include \"Eet_private.h\"" >> eet_amalgamation.c | ||
139 | @echo "#include \"Eet.h\"" >> eet_amalgamation.c | ||
140 | |||
141 | @for f in $(base_sources); do \ | ||
142 | if [ `echo $$f | sed -e 's/^...\(.\).*/\1/'` != '/' ]; then \ | ||
143 | file="$(srcdir)/$$f" ; \ | ||
144 | else \ | ||
145 | file="$$f" ; \ | ||
146 | fi ; \ | ||
147 | echo "/* file: $$file */" >> eet_amalgamation.c; \ | ||
148 | grep -v -e '^# *include \+.\(config\|\|Evil\|Eina\|stdio\|string\|math\|ctype\|limits\|sys/types\|sys/stat\|sys/mman\|setjmp\|errno\|time\|fnmatch\|fcntl\|winsock2\|unistd\|netinet/in\|gnutls/gnutls\|gcrypt\|gnutls/x509\|openssl/rsa\|openssl/objects\|openssl/err\|openssl/ssl\|openssl/dh\|openssl/dsa\|openssl/evp\|openssl/pem\|openssl/sha\|openssl/hmac\|openssl/x509\|openssl/rand\|zlib\|jpeglib\|Eet_private\|Eet\)[.]h.*' $$file >> eet_amalgamation.c; \ | ||
149 | done | ||
150 | @echo "eet_amalgamation.c generated" | ||
151 | |||
152 | else | ||
153 | libeet_la_SOURCES = $(base_sources) | ||
154 | endif | ||
155 | |||
156 | libeet_la_CFLAGS = @EET_CFLAGS@ @DEBUG_CFLAGS@ | ||
157 | libeet_la_LIBADD = @GNUTLS_LIBS@ @OPENSSL_LIBS@ @EFL_COVERAGE_LIBS@ @EET_LIBS@ @EINA_LIBS@ @EVIL_LIBS@ -lz -ljpeg -lm | ||
158 | libeet_la_LDFLAGS = -no-undefined @lt_enable_auto_import@ -version-info @version_info@ @release_info@ | ||
159 | |||
160 | EXTRA_DIST = Eet_private.h | ||
161 | |||
162 | clean-local: | ||
163 | @rm -rf *.gcno eet_amalgamation.c | ||