aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/libraries/edje/edje.spec
diff options
context:
space:
mode:
authorDavid Walter Seikel2012-01-04 18:41:13 +1000
committerDavid Walter Seikel2012-01-04 18:41:13 +1000
commitdd7595a3475407a7fa96a97393bae8c5220e8762 (patch)
treee341e911d7eb911a51684a7412ef7f7c7605d28e /libraries/edje/edje.spec
parentAdd the skeleton. (diff)
downloadSledjHamr-dd7595a3475407a7fa96a97393bae8c5220e8762.zip
SledjHamr-dd7595a3475407a7fa96a97393bae8c5220e8762.tar.gz
SledjHamr-dd7595a3475407a7fa96a97393bae8c5220e8762.tar.bz2
SledjHamr-dd7595a3475407a7fa96a97393bae8c5220e8762.tar.xz
Add the base Enlightenment Foundation Libraries - eina, eet, evas, ecore, embryo, and edje.
Note that embryo wont be used, but I'm not sure yet if you can build edje without it.
Diffstat (limited to 'libraries/edje/edje.spec')
-rw-r--r--libraries/edje/edje.spec105
1 files changed, 105 insertions, 0 deletions
diff --git a/libraries/edje/edje.spec b/libraries/edje/edje.spec
new file mode 100644
index 0000000..d887479
--- /dev/null
+++ b/libraries/edje/edje.spec
@@ -0,0 +1,105 @@
1%define _missing_doc_files_terminate_build 0
2
3%{!?_rel:%{expand:%%global _rel 0.enl%{?dist}}}
4
5Summary: Complex Graphical Design/Layout Engine
6Name: edje
7Version: 1.1.0
8Release: %{_rel}
9License: BSD
10Group: System Environment/Libraries
11URL: http://www.enlightenment.org/
12Source: ftp://ftp.enlightenment.org/pub/evoak/%{name}-%{version}.tar.gz
13Packager: %{?_packager:%{_packager}}%{!?_packager:Michael Jennings <mej@eterm.org>}
14Vendor: %{?_vendorinfo:%{_vendorinfo}}%{!?_vendorinfo:The Enlightenment Project (http://www.enlightenment.org/)}
15Distribution: %{?_distribution:%{_distribution}}%{!?_distribution:%{_vendor}}
16#BuildSuggests: xorg-x11-devel, vim-enhanced
17BuildRequires: eet-devel, embryo-devel, evas-devel, ecore-devel, lua-devel
18Requires: evas-module_loader_eet
19BuildRoot: %{_tmppath}/%{name}-%{version}-root
20
21%description
22Edje is a complex graphical design and layout engine. It provides a
23mechanism for allowing configuration data to define visual elements in
24terms of layout, behavior, and appearance. Edje allows for multiple
25collections of layouts in one file, allowing a complete set of images,
26animations, and controls to exist as a unified whole.
27
28Edje separates the arrangement, appearance, and behavior logic into
29distinct independent entities. This allows visual objects to share
30image data and configuration information without requiring them to do
31so. This separation and simplistic event driven style of programming
32can produce almost any look and feel one could want for basic visual
33elements. Anything more complex is likely the domain of an application
34or widget set that may use Edje as a conveneient way of being able to
35configure parts of the display.
36
37%package devel
38Summary: Edje headers, static libraries, documentation and test programs
39Group: System Environment/Libraries
40Requires: %{name} = %{version}, %{name}-bin = %{version}
41Requires: eet-devel embryo-devel evas-devel ecore-devel lua-devel
42
43%description devel
44Headers, static libraries, test programs and documentation for Edje
45
46%package bin
47Summary: Edje file compiler/decompiler suite
48Group: System Environment/Libraries
49Requires: %{name} = %{version}
50Requires: embryo-bin
51Requires: evas-module_saver_eet, evas-module_loader_png, evas-module_saver_png
52Requires: evas-module_loader_jpeg, evas-module_saver_jpeg, evas-module_engine_buffer
53
54%description bin
55Edje file compiler/decompiler suite
56
57%prep
58%setup -q
59
60%build
61%{configure} --prefix=%{_prefix}
62%{__make} %{?_smp_mflags} %{?mflags}
63
64%install
65%{__make} %{?mflags_install} DESTDIR=$RPM_BUILD_ROOT install
66test -x `which doxygen` && sh gendoc || :
67
68%post
69/sbin/ldconfig || :
70
71%postun
72/sbin/ldconfig || :
73
74%clean
75test "x$RPM_BUILD_ROOT" != "x/" && rm -rf $RPM_BUILD_ROOT
76
77%files
78%defattr(-, root, root)
79%doc AUTHORS COPYING README
80%{_libdir}/libedje*.so.*
81
82%files devel
83%defattr(-, root, root)
84%doc doc/html
85%{_libdir}/*.so
86%{_libdir}/*.la
87%{_libdir}/*.a
88%{_libdir}/pkgconfig/*
89%{_includedir}/edje-1/*.h
90%{_libdir}/edje/utils/epp
91%{_datadir}/edje/examples
92
93%files bin
94%defattr(-, root, root)
95%{_bindir}/edje_cc
96%{_bindir}/edje_decc
97%{_bindir}/edje_recc
98%{_bindir}/edje_player
99%{_bindir}/edje_external_inspector
100%{_bindir}/edje_inspector
101%{_bindir}/inkscape2edc
102%{_datadir}/edje/include/edje.inc
103%{_datadir}/mime/packages/edje.xml
104
105%changelog