aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/libraries/ecore/ecore.spec
diff options
context:
space:
mode:
authorDavid Walter Seikel2012-01-04 18:41:13 +1000
committerDavid Walter Seikel2012-01-04 18:41:13 +1000
commitdd7595a3475407a7fa96a97393bae8c5220e8762 (patch)
treee341e911d7eb911a51684a7412ef7f7c7605d28e /libraries/ecore/ecore.spec
parentAdd the skeleton. (diff)
downloadSledjHamr-dd7595a3475407a7fa96a97393bae8c5220e8762.zip
SledjHamr-dd7595a3475407a7fa96a97393bae8c5220e8762.tar.gz
SledjHamr-dd7595a3475407a7fa96a97393bae8c5220e8762.tar.bz2
SledjHamr-dd7595a3475407a7fa96a97393bae8c5220e8762.tar.xz
Add the base Enlightenment Foundation Libraries - eina, eet, evas, ecore, embryo, and edje.
Note that embryo wont be used, but I'm not sure yet if you can build edje without it.
Diffstat (limited to 'libraries/ecore/ecore.spec')
-rw-r--r--libraries/ecore/ecore.spec234
1 files changed, 234 insertions, 0 deletions
diff --git a/libraries/ecore/ecore.spec b/libraries/ecore/ecore.spec
new file mode 100644
index 0000000..a81327f
--- /dev/null
+++ b/libraries/ecore/ecore.spec
@@ -0,0 +1,234 @@
1# Conditional build stuff; from rpm 4.4 /usr/lib/rpm/macros.
2# bcond_without defaults to WITH, and vice versa. Yes, it's
3# ass-backward. Blame PLD.
4# from KainX's changes to evas...
5%if %{!?with:1}0
6%define with() %{expand:%%{?with_%{1}:1}%%{!?with_%{1}:0}}
7%endif
8%if %{!?without:1}0
9%define without() %{expand:%%{?with_%{1}:0}%%{!?with_%{1}:1}}
10%endif
11%if %{!?bcond_with:1}0
12%define bcond_with() %{expand:%%{?_with_%{1}:%%global with_%{1} 1}}
13%endif
14%if %{!?bcond_without:1}0
15%define bcond_without() %{expand:%%{!?_without_%{1}:%%global with_%{1} 1}}
16%endif
17
18## disabled features
19%bcond_with lib_ecore_directfb
20%bcond_with lib_ecore_sdl
21
22## enabled features
23##%bcond_without module_engine_software_x11
24%bcond_without lib_ecore_fb
25%bcond_without lib_ecore_imf
26
27# This just keeps a missing doxygen from killing the build.
28%define _missing_doc_files_terminate_build 0
29
30%define breq_lib_ecore_directfb %{?with_lib_ecore_directfb:DirectFB}
31%define breq_lib_ecore_sdl %{?with_lib_ecore_sdl:SDL-devel}
32
33%define ac_with_lib_ecore_directfb --%{?with_lib_ecore_directfb:en}%{!?with_lib_ecore_directfb:dis}able-ecore-directfb
34%define ac_with_lib_ecore_fb --%{?with_lib_ecore_fb:en}%{!?with_lib_ecore_fb:dis}able-ecore-fb
35%define ac_with_lib_ecore_imf --%{?with_lib_ecore_imf:en}%{!?with_lib_ecore_imf:dis}able-ecore-imf
36%define ac_with_lib_ecore_sdl --%{?with_lib_ecore_sdl:en}%{!?with_lib_ecore_sdl:dis}able-ecore-sdl
37
38%{!?_rel:%{expand:%%global _rel 0.enl%{?dist}}}
39
40Summary: Enlightened Core X interface library
41Name: ecore
42Version: 1.1.0
43Release: %{_rel}
44License: BSD
45Group: User Interface/X
46Source: %{name}-%{version}.tar.gz
47URL: http://www.enlightenment.org
48Packager: %{?_packager:%{_packager}}%{!?_packager:Michael Jennings <mej@eterm.org>}
49Vendor: %{?_vendorinfo:%{_vendorinfo}}%{!?_vendorinfo:The Enlightenment Project (http://www.enlightenment.org/)}
50Distribution: %{?_distribution:%{_distribution}}%{!?_distribution:%{_vendor}}
51#BuildSuggests: xorg-x11-devel, XFree86-devel, libX11-devel, c-ares-devel
52BuildRequires: libjpeg-devel, openssl-devel %{?breq_lib_ecore_directfb}
53BuildRequires: curl-devel, evas-devel, eet-devel %{?breq_lib_ecore_sdl}
54BuildRoot: %{_tmppath}/%{name}-%{version}-root
55
56%description
57Ecore is the event/X abstraction layer that makes doing selections,
58Xdnd, general X stuff, event loops, timeouts and idle handlers fast,
59optimized, and convenient. It's a separate library so anyone can make
60use of the work put into Ecore to make this job easy for applications.
61
62%package devel
63Summary: Ecore headers and development libraries.
64Group: Development/Libraries
65Requires: %{name} = %{version}
66Requires: curl-devel, openssl-devel, evas-devel, eet-devel
67Requires: ecore-con, ecore-evas, ecore-file, ecore-ipc
68Requires: ecore-x %{?with_lib_ecore_fb:ecore-fb} %{?with_lib_ecore_directfb:ecore-directfb}
69
70%description devel
71Ecore development files
72
73%package con
74Summary: Ecore Connection Library
75Group: Development/Libraries
76Requires: %{name} = %{version}
77
78%description con
79Ecore Connection Library
80
81%if %{with lib_ecore_directfb}
82%package directfb
83Summary: Ecore DirectFB system functions
84Group: Development/Libraries
85Requires: %{name} = %{version}
86%description directfb
87Ecore DirectFB system functions
88%endif
89
90%package evas
91Summary: Ecore Evas Wrapper Library
92Group: Development/Libraries
93Requires: %{name} = %{version}
94
95%description evas
96Ecore Evas Wrapper Library
97
98%if %{with lib_ecore_fb}
99%package fb
100Summary: Ecore frame buffer system functions
101Group: Development/Libraries
102Requires: %{name} = %{version}
103%description fb
104Ecore frame buffer system functions
105%endif
106
107%package file
108Summary: Ecore File Library
109Group: Development/Libraries
110Requires: %{name} = %{version}
111
112%description file
113Ecore File Library
114
115%if %{with lib_ecore_imf}
116%package imf
117Summary: Ecore IMF functions
118Group: Development/Libraries
119Requires: %{name} = %{version}
120%description imf
121Ecore IMF functions
122%endif
123
124%package input
125Summary: Ecore input functions
126Group: Development/Libraries
127Requires: %{name} = %{version}
128
129%description input
130Ecore input functions
131
132%package ipc
133Summary: Ecore inter-process communication functions
134Group: Development/Libraries
135Requires: %{name} = %{version}
136
137%description ipc
138Ecore inter-process communication functions
139
140%package x
141Summary: Ecore functions for dealing with the X Windows System
142Group: Development/Libraries
143Requires: %{name} = %{version}
144
145%description x
146Ecore functions for dealing with the X Windows System
147
148%prep
149%setup -q
150
151%build
152CFLAGS="-I/usr/kerberos/include -I/usr/X11R6/include/X11/extensions"
153LDFLAGS="-L/usr/kerberos/lib -L/usr/X11R6/%{_lib}"
154export CFLAGS LDFLAGS
155%{configure} --prefix=%{_prefix} \
156 %{?ac_with_lib_ecore_directfb} \
157 %{?ac_with_lib_ecore_fb} \
158 %{?ac_with_lib_ecore_imf} \
159 %{?ac_with_lib_ecore_sdl}
160
161%{__make} %{?_smp_mflags} %{?mflags}
162
163%install
164%{__make} %{?mflags_install} DESTDIR=$RPM_BUILD_ROOT install
165%{find_lang} %{name}
166
167%post
168/sbin/ldconfig || :
169
170%postun
171/sbin/ldconfig || :
172
173%clean
174test "x$RPM_BUILD_ROOT" != "x/" && rm -rf $RPM_BUILD_ROOT
175
176%files -f %{name}.lang
177%defattr(-, root, root)
178%doc AUTHORS COPYING* README*
179%{_bindir}/ecore_test
180%{_libdir}/libecore*.so.*
181
182%files devel
183%defattr(-, root, root)
184%doc doc/html
185%{_libdir}/*.so
186%{_libdir}/ecore/immodules/*.so
187%{_libdir}/ecore/immodules/*.la
188%{_libdir}/*.la
189%{_libdir}/*.a
190%{_libdir}/pkgconfig/*
191#%{_datadir}/aclocal/*
192%{_includedir}/ecore-1/*.h
193
194%files con
195%defattr(-, root, root)
196%{_libdir}/libecore_con*.so.*
197
198%if %{with lib_ecore_directfb}
199%files directfb
200%defattr(-, root, root)
201%{_libdir}/libecore_directfb*.so.*
202%endif
203
204%files evas
205%defattr(-, root, root)
206%{_libdir}/libecore_evas*.so.*
207
208%if %{with lib_ecore_fb}
209%files fb
210%defattr(-, root, root)
211%{_libdir}/libecore_fb*.so.*
212%endif
213
214%files file
215%defattr(-, root, root)
216%{_libdir}/libecore_file*.so.*
217
218%if %{with lib_ecore_imf}
219%files imf
220%defattr(-, root, root)
221%{_libdir}/libecore_imf*.so.*
222%endif
223
224%files input
225%defattr(-, root, root)
226%{_libdir}/libecore_input*.so.*
227
228%files ipc
229%defattr(-, root, root)
230%{_libdir}/libecore_ipc*.so.*
231
232%files x
233%defattr(-, root, root)
234%{_libdir}/libecore_x*.so.*