aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/libraries/ecore/Makefile.am
diff options
context:
space:
mode:
authorDavid Walter Seikel2012-01-04 18:41:13 +1000
committerDavid Walter Seikel2012-01-04 18:41:13 +1000
commitdd7595a3475407a7fa96a97393bae8c5220e8762 (patch)
treee341e911d7eb911a51684a7412ef7f7c7605d28e /libraries/ecore/Makefile.am
parentAdd the skeleton. (diff)
downloadSledjHamr-dd7595a3475407a7fa96a97393bae8c5220e8762.zip
SledjHamr-dd7595a3475407a7fa96a97393bae8c5220e8762.tar.gz
SledjHamr-dd7595a3475407a7fa96a97393bae8c5220e8762.tar.bz2
SledjHamr-dd7595a3475407a7fa96a97393bae8c5220e8762.tar.xz
Add the base Enlightenment Foundation Libraries - eina, eet, evas, ecore, embryo, and edje.
Note that embryo wont be used, but I'm not sure yet if you can build edje without it.
Diffstat (limited to '')
-rw-r--r--libraries/ecore/Makefile.am213
1 files changed, 213 insertions, 0 deletions
diff --git a/libraries/ecore/Makefile.am b/libraries/ecore/Makefile.am
new file mode 100644
index 0000000..3de7673
--- /dev/null
+++ b/libraries/ecore/Makefile.am
@@ -0,0 +1,213 @@
1## Process this file with automake to produce Makefile.in
2
3ACLOCAL_AMFLAGS = -I m4
4
5SUBDIRS = doc src
6
7if HAVE_PO
8
9SUBDIRS += po
10
11endif
12
13MAINTAINERCLEANFILES = \
14ABOUT-NLS \
15Makefile.in \
16aclocal.m4 \
17config.guess \
18config.h.in \
19config.h.in~ \
20config.rpath \
21config.sub \
22configure \
23depcomp \
24install-sh \
25ltmain.sh \
26missing \
27mkinstalldirs \
28$(PACKAGE_TARNAME)-$(PACKAGE_VERSION).tar.gz \
29$(PACKAGE_TARNAME)-$(PACKAGE_VERSION).tar.bz2 \
30$(PACKAGE_TARNAME)-$(PACKAGE_VERSION)-doc.tar.bz2 \
31m4/libtool.m4 \
32m4/lt~obsolete.m4 \
33m4/ltoptions.m4 \
34m4/ltsugar.m4 \
35m4/ltversion.m4 \
36m4/codeset.m4 \
37m4/gettext.m4* \
38m4/glibc2*.m4 \
39m4/iconv.m4 \
40m4/intdiv0.m4 \
41m4/intldir.m4 \
42m4/intl.m4 \
43m4/intlmacosx.m4 \
44m4/intmax.m4* \
45m4/inttypes_h.m4 \
46m4/inttypes.m4 \
47m4/inttypes-pri.m4 \
48m4/isc-posix.m4 \
49m4/lcmessage.m4 \
50m4/lib-ld.m4* \
51m4/lib-link.m4 \
52m4/lib-prefix.m4* \
53m4/lock.m4 \
54m4/longdouble.m4* \
55m4/longlong.m4* \
56m4/nls.m4 \
57m4/po.m4* \
58m4/printf-posix.m4* \
59m4/progtest.m4 \
60m4/signed.m4 \
61m4/size_max.m4* \
62m4/stdint_h.m4 \
63m4/uintmax_t.m4 \
64m4/ulonglong.m4* \
65m4/visibility.m4 \
66m4/wchar_t.m4 \
67m4/wint_t.m4* \
68m4/xsize.m4*
69
70if HAVE_PO
71
72MAINTAINERCLEANFILES += \
73po/boldquot.sed \
74po/en@boldquot.header \
75po/en@quot.header \
76po/insert-header.sin \
77po/Makefile.in.in* \
78po/Makevars.template \
79po/quot.sed \
80po/remove-potcdate.sin \
81po/Rules-quot*
82
83endif
84
85bin_SCRIPTS =
86
87EXTRA_DIST = \
88AUTHORS \
89COPYING \
90autogen.sh \
91ecore.supp \
92ecore.pc.in \
93ecore-con.pc.in \
94ecore-config.pc.in \
95ecore-directfb.pc.in\
96ecore-evas.pc.in \
97ecore-fb.pc.in \
98ecore-file.pc.in \
99ecore-imf.pc.in \
100ecore-imf-evas.pc.in \
101ecore-ipc.pc.in \
102ecore-x.pc.in \
103ecore-win32.pc.in \
104ecore-sdl.pc.in \
105ecore-cocoa.pc.in \
106ecore-psl1ght.pc.in \
107ecore-input.pc.in \
108ecore-wince.pc.in \
109ecore.spec.in \
110ecore.spec \
111m4/ac_abstract_socket.m4 \
112m4/ac_attribute.m4 \
113m4/check_x_extension.m4 \
114m4/ecore_check_module.m4 \
115m4/ecore_check_options.m4 \
116m4/efl_doxygen.m4 \
117m4/efl_path_max.m4 \
118m4/efl_tests.m4 \
119m4/efl_threads.m4
120
121
122pkgconfigdir = $(libdir)/pkgconfig
123pkgconfig_DATA = ecore.pc
124
125if BUILD_ECORE_CON
126pkgconfig_DATA += ecore-con.pc
127endif
128
129if BUILD_ECORE_CONFIG
130pkgconfig_DATA += ecore-config.pc
131endif
132
133if BUILD_ECORE_DIRECTFB
134pkgconfig_DATA += ecore-directfb.pc
135endif
136
137if BUILD_ECORE_EVAS
138pkgconfig_DATA += ecore-evas.pc
139endif
140
141if BUILD_ECORE_FB
142pkgconfig_DATA += ecore-fb.pc
143endif
144
145if BUILD_ECORE_FILE
146pkgconfig_DATA += ecore-file.pc
147endif
148
149if BUILD_ECORE_IMF
150pkgconfig_DATA += ecore-imf.pc
151endif
152
153if BUILD_ECORE_IMF_EVAS
154pkgconfig_DATA += ecore-imf-evas.pc
155endif
156
157if BUILD_ECORE_INPUT
158pkgconfig_DATA += ecore-input.pc
159endif
160
161if BUILD_ECORE_INPUT_EVAS
162pkgconfig_DATA += ecore-input-evas.pc
163endif
164
165if BUILD_ECORE_IPC
166pkgconfig_DATA += ecore-ipc.pc
167endif
168
169if BUILD_ECORE_X
170pkgconfig_DATA += ecore-x.pc
171endif
172
173if BUILD_ECORE_WIN32
174pkgconfig_DATA += ecore-win32.pc
175endif
176
177if BUILD_ECORE_WINCE
178pkgconfig_DATA += ecore-wince.pc
179endif
180
181if BUILD_ECORE_SDL
182pkgconfig_DATA += ecore-sdl.pc
183endif
184
185if BUILD_ECORE_COCOA
186pkgconfig_DATA += ecore-cocoa.pc
187endif
188
189if BUILD_ECORE_PSL1GHT
190pkgconfig_DATA += ecore-psl1ght.pc
191endif
192
193.PHONY: doc
194
195# Documentation
196
197doc:
198 @echo "entering doc/"
199 make -C doc doc
200
201# Unit tests
202
203if EFL_ENABLE_TESTS
204
205check-local:
206 @./src/tests/ecore_suite
207
208else
209
210check-local:
211 @echo "reconfigure with --enable-tests"
212
213endif