aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/libraries/ecore/Makefile.am
diff options
context:
space:
mode:
authorDavid Walter Seikel2013-01-13 17:29:19 +1000
committerDavid Walter Seikel2013-01-13 17:29:19 +1000
commit07274513e984f0b5544586c74508ccd16e7dcafa (patch)
treeb32ff2a9136fbc1a4a6a0ed1e4d79cde0f5f16d9 /libraries/ecore/Makefile.am
parentAdded Irrlicht 1.8, but without all the Windows binaries. (diff)
downloadSledjHamr-07274513e984f0b5544586c74508ccd16e7dcafa.zip
SledjHamr-07274513e984f0b5544586c74508ccd16e7dcafa.tar.gz
SledjHamr-07274513e984f0b5544586c74508ccd16e7dcafa.tar.bz2
SledjHamr-07274513e984f0b5544586c74508ccd16e7dcafa.tar.xz
Remove EFL, since it's been released now.
Diffstat (limited to '')
-rw-r--r--libraries/ecore/Makefile.am218
1 files changed, 0 insertions, 218 deletions
diff --git a/libraries/ecore/Makefile.am b/libraries/ecore/Makefile.am
deleted file mode 100644
index 8a6ef9a..0000000
--- a/libraries/ecore/Makefile.am
+++ /dev/null
@@ -1,218 +0,0 @@
1## Process this file with automake to produce Makefile.in
2
3ACLOCAL_AMFLAGS = -I m4
4
5SUBDIRS = doc src
6
7if HAVE_PO
8
9SUBDIRS += po
10
11endif
12
13MAINTAINERCLEANFILES = \
14ABOUT-NLS \
15Makefile.in \
16aclocal.m4 \
17config.guess \
18config.h.in \
19config.h.in~ \
20config.rpath \
21config.sub \
22configure \
23depcomp \
24install-sh \
25ltmain.sh \
26missing \
27mkinstalldirs \
28$(PACKAGE_TARNAME)-$(PACKAGE_VERSION).tar.gz \
29$(PACKAGE_TARNAME)-$(PACKAGE_VERSION).tar.bz2 \
30$(PACKAGE_TARNAME)-$(PACKAGE_VERSION)-doc.tar.bz2 \
31m4/libtool.m4 \
32m4/lt~obsolete.m4 \
33m4/ltoptions.m4 \
34m4/ltsugar.m4 \
35m4/ltversion.m4 \
36m4/codeset.m4 \
37m4/gettext.m4* \
38m4/glibc2*.m4 \
39m4/iconv.m4 \
40m4/intdiv0.m4 \
41m4/intldir.m4 \
42m4/intl.m4 \
43m4/intlmacosx.m4 \
44m4/intmax.m4* \
45m4/inttypes_h.m4 \
46m4/inttypes.m4 \
47m4/inttypes-pri.m4 \
48m4/isc-posix.m4 \
49m4/lcmessage.m4 \
50m4/lib-ld.m4* \
51m4/lib-link.m4 \
52m4/lib-prefix.m4* \
53m4/lock.m4 \
54m4/longdouble.m4* \
55m4/longlong.m4* \
56m4/nls.m4 \
57m4/po.m4* \
58m4/printf-posix.m4* \
59m4/progtest.m4 \
60m4/signed.m4 \
61m4/size_max.m4* \
62m4/stdint_h.m4 \
63m4/uintmax_t.m4 \
64m4/ulonglong.m4* \
65m4/visibility.m4 \
66m4/wchar_t.m4 \
67m4/wint_t.m4* \
68m4/xsize.m4*
69
70if HAVE_PO
71
72MAINTAINERCLEANFILES += \
73po/boldquot.sed \
74po/en@boldquot.header \
75po/en@quot.header \
76po/insert-header.sin \
77po/Makefile.in.in* \
78po/Makevars.template \
79po/quot.sed \
80po/remove-potcdate.sin \
81po/Rules-quot*
82
83endif
84
85bin_SCRIPTS =
86
87EXTRA_DIST = \
88AUTHORS \
89COPYING \
90autogen.sh \
91ecore.supp \
92ecore.pc.in \
93ecore-con.pc.in \
94ecore-config.pc.in \
95ecore-directfb.pc.in\
96ecore-evas.pc.in \
97ecore-fb.pc.in \
98ecore-file.pc.in \
99ecore-imf.pc.in \
100ecore-imf-evas.pc.in \
101ecore-ipc.pc.in \
102ecore-x.pc.in \
103ecore-win32.pc.in \
104ecore-sdl.pc.in \
105ecore-cocoa.pc.in \
106ecore-psl1ght.pc.in \
107ecore-input.pc.in \
108ecore-wince.pc.in \
109ecore-wayland.pc.in \
110ecore.spec.in \
111ecore.spec \
112m4/ac_abstract_socket.m4 \
113m4/ac_attribute.m4 \
114m4/check_x_extension.m4 \
115m4/ecore_check_module.m4 \
116m4/ecore_check_options.m4 \
117m4/efl_doxygen.m4 \
118m4/efl_path_max.m4 \
119m4/efl_tests.m4 \
120m4/efl_threads.m4
121
122
123pkgconfigdir = $(libdir)/pkgconfig
124pkgconfig_DATA = ecore.pc
125
126if BUILD_ECORE_CON
127pkgconfig_DATA += ecore-con.pc
128endif
129
130if BUILD_ECORE_CONFIG
131pkgconfig_DATA += ecore-config.pc
132endif
133
134if BUILD_ECORE_DIRECTFB
135pkgconfig_DATA += ecore-directfb.pc
136endif
137
138if BUILD_ECORE_EVAS
139pkgconfig_DATA += ecore-evas.pc
140endif
141
142if BUILD_ECORE_FB
143pkgconfig_DATA += ecore-fb.pc
144endif
145
146if BUILD_ECORE_FILE
147pkgconfig_DATA += ecore-file.pc
148endif
149
150if BUILD_ECORE_IMF
151pkgconfig_DATA += ecore-imf.pc
152endif
153
154if BUILD_ECORE_IMF_EVAS
155pkgconfig_DATA += ecore-imf-evas.pc
156endif
157
158if BUILD_ECORE_INPUT
159pkgconfig_DATA += ecore-input.pc
160endif
161
162if BUILD_ECORE_INPUT_EVAS
163pkgconfig_DATA += ecore-input-evas.pc
164endif
165
166if BUILD_ECORE_IPC
167pkgconfig_DATA += ecore-ipc.pc
168endif
169
170if BUILD_ECORE_X
171pkgconfig_DATA += ecore-x.pc
172endif
173
174if BUILD_ECORE_WIN32
175pkgconfig_DATA += ecore-win32.pc
176endif
177
178if BUILD_ECORE_WINCE
179pkgconfig_DATA += ecore-wince.pc
180endif
181
182if BUILD_ECORE_SDL
183pkgconfig_DATA += ecore-sdl.pc
184endif
185
186if BUILD_ECORE_COCOA
187pkgconfig_DATA += ecore-cocoa.pc
188endif
189
190if BUILD_ECORE_PSL1GHT
191pkgconfig_DATA += ecore-psl1ght.pc
192endif
193
194if BUILD_ECORE_WAYLAND
195pkgconfig_DATA += ecore-wayland.pc
196endif
197
198.PHONY: doc
199
200# Documentation
201
202doc:
203 @echo "entering doc/"
204 make -C doc doc
205
206# Unit tests
207
208if EFL_ENABLE_TESTS
209
210check-local:
211 @./src/tests/ecore_suite
212
213else
214
215check-local:
216 @echo "reconfigure with --enable-tests"
217
218endif